### Table of Contents

1. Introduction ........................................................................................................... 1  
   1.1. Overview ........................................................................................................ 1  
   1.2. Document Structure ..................................................................................... 2  
2. General Information ............................................................................................. 3  
   2.1. Preparing the Program Environment ............................................................. 3  
   2.2. Navigating in CrysVUn ............................................................................... 6  
   2.3. Activating the Context Sensitive Help ........................................................... 8  
3. Geometry Mode ..................................................................................................... 10  
   3.1. Zooming and Scrolling .................................................................................. 10  
   3.2. Drawing and Modifying the Drawing .............................................................. 11  
   3.3. Selecting Elements ...................................................................................... 13  
   3.4. Using Tolerance and Raster ........................................................................ 14  
   3.5. Moving and Copying Elements ................................................................... 17  
   3.6. Further Handling of Selected Elements ....................................................... 19  
   3.7. Changes to the Complete Drawing ............................................................... 21  
   3.8. Importing a CAD File (dxf-Format) ............................................................... 23  
   3.9. Setting Symmetry ....................................................................................... 25  
4. Materials Mode ...................................................................................................... 26  
   4.1. Materials dialog ............................................................................................ 26  
   4.2. Adding, Replacing and Deleting Materials .................................................... 27  
   4.3. Modifying Materials Properties ................................................................... 32  
   4.4. Assigning Materials to Regions .................................................................... 37  
   4.5. Saving Materials Data Files ......................................................................... 39  
   4.6. Setting up and Maintaining the Material Database ....................................... 40  
   4.7. Using the Characteristic Numbers Dialog .................................................... 44  
5. Simulation Mode: Settings .................................................................................... 47  
   5.1. Selecting Elements in Simulation Mode ......................................................... 47  
   5.2. Labels and Joiner .......................................................................................... 48  
   5.3. Grid Properties ............................................................................................ 53  
   5.4. Physical Phenomena .................................................................................... 56  
   5.5. Initial Values ............................................................................................... 57  
   5.6. Boundary Conditions .................................................................................. 58  
   5.7. Heaters ........................................................................................................ 61  
   5.8. Control Points for Inverse Simulation ......................................................... 64  
   5.9. Moving Regions .......................................................................................... 66  
6. Simulation Mode: Computation ............................................................................ 70  
   6.1. Time Model Choice ..................................................................................... 70  
   6.2. Setting Process parameters .......................................................................... 71  
   6.3. Setting Numerical parameters ..................................................................... 76  
   6.4. Setting Convection parameters .................................................................... 84  
   6.5. Setting the parameters for alloy solidification ............................................. 89  
   6.6. Display of Solver Information ..................................................................... 96  
   6.7. Computation Operations .......................................................................... 98  
7. Simulation Mode: Variables ................................................................................ 102  
   7.1. List of Variable Groups and Variables .......................................................... 102  
8. Simulation Mode: Visualization and Analysis ................................................... 105  
   8.1. Visualizing results ...................................................................................... 105  
   8.2. Analysis ....................................................................................................... 107  
9. Tutorials .............................................................................................................. 118  
   9.1. Running a Thermal Analysis (Quick Start) ................................................... 118  
   9.2. Modifying the Sample Cartridge Assembly (SCA) ...................................... 130  
   9.3. Handling Materials ..................................................................................... 135  
   9.4. Running an Inverse Simulation .................................................................. 140  
   9.5. Computing a Time-dependent Simulation .................................................. 147  
   9.6. Computing a Time-dependent Simulation with Moving Regions ............... 153  
   9.7. Computing Pseudo-stationary and Time-dependent Convection ............... 155
Chapter 1. Introduction

*CrysVUn* is a program for global numerical simulation of Crystal growth in complex furnaces with axial or translational symmetry, based on the Finite Volume method and an Unstructured grid. The simulation provides information for making predictions about physical quantities, so called variables, in a complex system and for controlling the crystal growing process in furnaces.

Global simulation has to consider all relevant physical phenomena influencing the variables investigated. Temperature is the most important variable and the basis for computing other variables like heat flux, flow velocity and von Mises Stress.

*CrysVUn* allows to compute simulations in both directions:

- **Forward Simulation**
  
The simulation is computed for given heating powers in the heaters. The temperature distribution is computed for the whole setup.

- **Inverse Simulation**
  
The simulation computes the heating powers needed in each heater for reaching certain temperatures at defined points in the furnace (control points).

*CrysVUn* is able to perform stationary and time-dependent simulations for furnaces heated by resistance as well as by inductive heaters. The program can control an arbitrary number of heaters and also in case of inverse simulation an arbitrary number of control points.

Basic knowledge in thermal analysis and mathematical simulation is prerequisite. Specific knowledge needed for running *CrysVUn* will be imparted in this documentation.

1.1. Overview

A simulation comprises three major steps:

- Preparing the furnace geometry
- Defining materials and assigning them to furnace regions
- Defining conditions and setting parameters for computing variables

*CrysVUn* provides a mode of operation for each of these steps.

Modes of operation

In the *Geometry Mode* you draw or modify the geometry of a furnace. *CrysVUn* geometry uses points and lines only. You can import CAD drawings, but curvy shapes have to be transferred to lines. Otherwise the furnace outline may show gaps.

In the *Material Mode* you set up the material database, define materials and their properties, and assign materials to the regions of the furnace.

In the *Simulation Mode* you set the basic conditions in the *Settings* menu and you define the parameters for the simulation in the *Computation* menu. Prerequisite for Simulation Mode is that the furnace geometry is complete, and that materials were assigned to all furnace regions.

Visualization of results

You have various choices to visualize the results of your simulation, such as isolines, the scalar field or the vector field, and you can determine the interval gradation. For showing
isolines, for instance, you either open the pop-up window by selecting **Visualization > Show** or you click on the appropriate button in the tool bar.

**Data export**

*CrysVUn* enables you to export almost any data you want to. You can export the complete data file as well as selected variables for particular points or along polylines.

### 1.2. Document Structure

To facilitate an easy access to the information, the documentation sections correspond to the *CrysVUn* structure.

<table>
<thead>
<tr>
<th>Section</th>
<th>Content</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Information</td>
<td>Starting the program. Features of the general user interface. Navigating in <em>CrysVUn</em>.</td>
</tr>
<tr>
<td>Geometry Mode</td>
<td>Drawing and modifying the furnace geometry. Importing a <em>.dxf</em> file. Setting symmetry.</td>
</tr>
<tr>
<td>Material Mode</td>
<td>Defining and assigning materials. Handling the material database.</td>
</tr>
<tr>
<td>Simulation Mode: Settings</td>
<td>Labelling regions and lines. Defining properties for the unstructured grid. Defining moving regions for time-dependent computation. Defining boundaries, heaters and control points. Specifying physical phenomena and initial values.</td>
</tr>
<tr>
<td>Simulation Mode: Variables</td>
<td>List of variable groups and variables which <em>CrysVUn</em> can compute.</td>
</tr>
<tr>
<td>Simulation Mode: Visualization and Analysis</td>
<td>Determining visualization features for the left and right sides of the furnace. Specifying range of data for export.</td>
</tr>
</tbody>
</table>

**Tutorial**

How to compute specific tasks.

**Menus and Dialogs**

Overview of all menus and dialogs in *CrysVUn*.

**Appendices**

Chapter 2. General Information

*CrysVUn* is a software tool easy to learn and easy to use. The software does not require a sophisticated installation process. The graphical user interface is self-explanatory. Before you start the program, you need to know:

- How to prepare the program environment
- How to navigate in the software

2.1. Preparing the Program Environment

*CrysVUn* is intended for use on Linux or Microsoft Windows (9x, NT, 2000, XP) operating systems. The content of your distribution kit and the installation procedure are adapted to your operating system.

*CrysVUn* is running on standard PCs equipped with at least:

- 128 MB RAM
- 30 MB free hard disk space for program and documentation
- 1024x768 screen resolution
- Mouse with 3 keys or 2 keys and a scroll wheel

**Note**

Because the speed of the simulations depends on the computation power (processor speed and amount of memory), we recommend a PC with 2 GHz processor and 512 MB RAM. Running simulations with less memory may cause disk swapping which has a severe impact on the performance of the program.

2.1.1. Installing CrysVUn in a Linux environment

The distribution kit for Linux contains one archive file: `crysvun-version.tar.gz`.

**Note**

Make sure you have the right of access for the directories where you install *CrysVUn*. You may need to be root/administrator.

1. Copy the file `crysvun-version.tar.gz` to the desired directory, e.g. `/usr/local` directory.
2. Type `cd /usr/local`.
3. Unpack the archive by typing `tar -xzf crysvun-version.tar.gz` or `tar -xzf crysvun-version.tar.gz -c /usr/local`.

The directory `/usr/local/crysvun-version` will be created and shall contain the following directories and files:

<table>
<thead>
<tr>
<th>Directory/File name</th>
<th>Content</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data</td>
<td>Material database file.</td>
</tr>
</tbody>
</table>
### Directory/File name | Content
--- | ---
Optional, the joiner configuration file, the furnace inserts and cartridges. | Doc Documentation including: printable (Manual.pdf) and online (Manual/*.html) user manual for CrysVUn.
Sample files for the tutorials. e.g. LGF-prototype.crys, Inductive_heating.crys, VGF_geometry.pcs, Catridge_prof.mov. | Examples
Main application (GUI version) of CrysVUn. | crysvun
Batch (online) version of CrysVUn. | crysvun_onl
CrysVUn help browser | assistant

4. The name of the directory depends on the number of CrysVUn versions you have and want to keep:
   If you want to keep more than one CrysVUn version, create a symbolic link to your latest CrysVUn version by typing `ln -s crysvun-version crysvun`.

5. If your shell is `bash`, `ksh`, `zsh` or `sh`, you need to edit the file `~/.profile` to set the PATH environment variable. Create the file `~/.profile`, if it does not exist, or edit `/etc/profile` for system wide effect.
   Open the file `~/.profile` respectively `/etc/profile`.

6. Add the lines `PATH=$PATH:/usr/local/crysvun` and `export PATH`.

7. Save and close the file.

8. For `csh` or `tcsh` shells, you need the file `~/.login` to set the PATH environment variable. If this file does not exist, create it first respectively edit `/etc/csh.login`.
   Open the file `~/.login` respectively `/etc/csh.login`.

9. Add the line `set path = ($path /usr/local/crysvun)`. These changes take effect the next time you login.

#### 2.1.2. Installing CrysVUn in a Windows environment


1. Open the Windows explorer.
2. Select the directory where you want to install CrysVUn, e.g. `c:\programs`.
3. Copy the file `crysvun-version.zip` from the distribution kit to the selected directory.
4. Double-click on the file `crysvun-version.zip` to extract it using a standard archiver, e.g. WinZip.
   The files are extracted to the `crysvun-version` directory.
If you want to keep more than one version of CrysVUn, you may leave the name. Otherwise rename the directory to crysvun.

The crysvun directory shall contain the following files and directories:

<table>
<thead>
<tr>
<th>Directory/File name</th>
<th>Content</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data</td>
<td>Material database file. Optionally, the joiner configuration file, the furnace inserts and cartridges.</td>
</tr>
<tr>
<td>Doc</td>
<td>Documentation including: printable (Manual.pdf) and online (Manual/*.html) user manual for CrysVUn.</td>
</tr>
<tr>
<td>Examples</td>
<td>Sample files for the tutorials, e.g. LGF-proto-type.crys, Inductive_heating.crys, VGF_geometry.pcs, Cartridge_prof.mov.</td>
</tr>
<tr>
<td>crysvun.exe</td>
<td>Main application (GUI version) of CrysVUn</td>
</tr>
<tr>
<td>crysvun_onl.exe</td>
<td>Batch (online) version of CrysVUn</td>
</tr>
<tr>
<td>assistant.exe</td>
<td>CrysVUn help browser</td>
</tr>
<tr>
<td>msvcrt.dll, msvcp60.dll, zlib.dll, qtm311.dll</td>
<td>Several system files (libraries)</td>
</tr>
</tbody>
</table>

**Note**

In most Windows environments system files like *.dll are hidden. If you want them to be displayed, check in the Windows Explorer under View > Options that all files are displayed.

**Tip**

In addition you may want to create a shortcut to the crysvun.exe on your desktop and set the “working directory” of the application to the work directory of CrysVUn.

### 2.1.3. Starting the program

CrysVUn requires no installation procedure.

1. Open the directory containing the crysvun executable file in the graphical user interface or in the terminal window.

2. Double-click on the file crysvun(.exe) in the explorer or on the CrysVUn desktop link.
   or
   Type crysvun in the terminal window and press the Enter key.

The CrysVUn Main Window and, optionally, the terminal window for monitoring program activities come up.
2.2. Navigating in CrysVUn

The graphical user interface (GUI) conforms to common standards: menu bar, tool bar, working field, status bar and dialog windows are the major GUI elements. For input you use the keyboard and/or the mouse. Many GUI elements are handled in the familiar way, but some of the features are CrysVUn specific, e.g. the multi-functionality of the mouse buttons.

2.2.1. Screen sections

When you start CrysVUn, the Main Window always opens in Simulation Mode. The file name displayed in the status bar is unknown and will be replaced as soon as you load a *.crys file, or you save the current file in the example toymodel (.crys).

![Main Window](image)

1. Menu bar
2. Tool bar
3. Working area
4. Status bar
5. Mouse pointer coordinates
6. In Materials Mode: Material assigned; in Simulation Mode: Region number and material or value of variable
7. File name
8. Status
9. Progress indicator
10. Log messages window (optional)

*Figure 2.1. Sections of Main Window*

**Screen elements overview**

In the graphical user interface, you only find standard elements:

- Menu bar with drop-down menus
• Icon tool bar for frequently used menu items
• Working area
• Dialog Windows with buttons, list boxes, check boxes and input fields

Most of the screen elements are used as is common practice.
The drop-down menus in the menu bar enable you to select the mode of operation, edit the geometry and open the dialogs necessary to define materials and settings as well as computation and output parameters. For many menu items shortcuts are available.

2.2.2. Dialog windows

The dialog windows contain the dialogs associated with certain menu items. The dialog's name is displayed in the head line of each dialog. The dialog box contains buttons, list boxes, check boxes and input fields. The dialog window's functionality is exemplified on the Heaters dialog.

![Figure 2.2. Dialog example from settings menu](image)

In most dialog windows, you find these five buttons in the bottom line:

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ok</td>
<td>Saves the changes and closes the dialog window.</td>
</tr>
<tr>
<td>Apply</td>
<td>Applies the changes, but leaves the window open.</td>
</tr>
<tr>
<td>Reset</td>
<td>Resets changes to the values before the dialog was opened respectively after the last Apply.</td>
</tr>
<tr>
<td>Close/Cancel</td>
<td>Closes the dialog/cancels the changes.</td>
</tr>
<tr>
<td>?</td>
<td>Opens the CrysVUn Help Window and shows the help for dialog.</td>
</tr>
</tbody>
</table>

2.2.3. Tool bar icons

With few exceptions, the icons represent menu items or dialog options. When you keep the mouse pointer on an icon without clicking, a tool tip will pop up after a few seconds telling you the icon's function.
The availability of the tool bar icons depends on the mode. In Tool Bar Buttons (page260) you find a table containing all icons and telling you in which mode they are available.
2.2.4. Input tools

Your input tools are keyboard and mouse. For many menu items, keyboard shortcuts are available and in the dialog windows you can jump from element to element by using the Tab key. Alternatively you can use the mouse for navigating on the screen and selecting items. CrysVUn requires a three key mouse or a mouse with scroll wheel. Depending on the mode of operation, the mouse buttons have different functions.

<table>
<thead>
<tr>
<th>Mouse button</th>
<th>Geometry Mode</th>
<th>Material Mode</th>
<th>Simulation Mode</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>left mouse button</strong></td>
<td>Press and hold: select a rectangle, zoom in.</td>
<td>Press and hold: select a rectangle, zoom in.</td>
<td>Click: Select 1 region, Press and hold: select a rectangle, zoom in.</td>
</tr>
<tr>
<td><strong>middle mouse button</strong></td>
<td>Draw points and lines.</td>
<td>Not assigned.</td>
<td>Select/unselect 1 line.</td>
</tr>
<tr>
<td></td>
<td>Copy button activated: Copy selected elements.</td>
<td>Move button activated: Move selected elements.</td>
<td></td>
</tr>
<tr>
<td><strong>right mouse button</strong></td>
<td>Select points, lines and rectangles</td>
<td>Not assigned.</td>
<td>Define a point.</td>
</tr>
</tbody>
</table>

For further key functions and shortcuts see Key Functions and Shortcuts (page 260).

2.3. Activating the Context Sensitive Help

The context sensitive help is implemented in CrysVUn based on Qt Assistant browser and uses the HTML version of the User Manual.

The help can be triggered in several ways:

- from Help menu: two items are opening the help browser - Help Contents menu which opens the starting page of the user manual, and FAQs menu which opens the Frequently asked questions section from the manual.

  Additionally, the Release Notes menu opens a window showing the changes made during program development.

- from any Dialog window: clicking on button opens the help for dialog.

- pressing F1 key: opens the starting page of the help, if the main window has focus, or opens the help for the dialog, if a dialog has focus.

First time the user triggers the help, the program is looking for browser application - assistant(.exe) program - and initializes it. If the initialization was successful, the browser window opens showing the help page. Otherwise, either the browser or the user manual was not found and you have to set the valid location:

1. Select File > Preferences.

   The Preferences dialog opens.

2. Select Paths tab.

   The Paths tab opens.
3. Check or set the **User manual path**.
   The on-line user manual (*.html files) is installed, by default, in *CrysVUn's Doc/Manual* subdirectory. If not, specify the actual *Manual* directory or select it using button.

4. Check or set the **Help browser**.
   The help pages are shown by *QtAssistant* application coming with *CrysVUn* software. The program is installed, by default, in *CrysVUn's* directory. If not, select the assistant(.exe) file using button.

5. Save changes clicking **Apply** button.
   The help system is activated and you can press F1 key or click on button.

![Figure 2.3. Preferences dialog, Paths tab](image)
Chapter 3. Geometry Mode

The furnace geometry is crucial to the result of the simulation. CrysVUn provides the opportunity to draw a furnace from scratch or to import the geometry from a *.dxf file. For axial-symmetric furnaces, only the right half has to be designed. The simulation program can also compute variables for translational furnaces, see Setting Symmetry (page 25).

CrysVUn also offers the opportunity of inserting different cartridges into furnaces of the same kind and checks the compatibility during the joining procedure, see Labels and Joiner (page 48).

The drawing tool enables you to draw complex geometries by only using points and lines. The Edit menu, only available in Geometry Mode, enables you to select, to group, or to modify elements of the drawing. Any operation can be revoked either by selecting Edit > Undo or pressing Esc. The Undo can be repeated for several steps, but it is only available in Geometry Mode. There is no Undo in Materials and in Simulation Modes.

You can save geometry data separately from the rest of the information, if you want to use the data for experimenting with different materials. These files get the extension *.pcs and can be opened only in Geometry Mode. Geometry data are also automatically stored in the *.crys file which is saved in Simulation Mode.

In Geometry Mode, you can perform the following operations:

- Zooming and Scrolling (page 10)
- Drawing and Modifying the Drawing (page 11)
- Selecting Elements (page 13)
- Using Tolerance and Raster (page 14)
- Moving and Copying Elements (page 17)
- Further Handling of Selected Elements (page 19)
- Changes to the Complete Drawing (page 21)
- Importing a CAD File (dxf-Format) (page 23)
- Setting Symmetry (page 25)

3.1. Zooming and Scrolling

Zooming a drawing is available and necessary in each CrysVUn mode:

- In Geometry Mode, you enlarge certain parts of the drawing for adding or modifying details.
- In Material Mode, you may have to assign materials to very small regions.
- In Simulation Mode, you want to examine the grid in an area, where three or four regions meet one another.

The zooming-in tool is the same in all three modes, zooming out differs a little. Once you zoomed in a drawing, maybe you want to see a different furnace region and scroll the drawing up or down.

Note
The gradual enlarging or decreasing by + or - works in all three modes.

3.1.1. Zooming in

If you want to enlarge a drawing, you can do this gradually or in one go by using the mouse.

- To gradually increase the drawing size, press the + key. The drawing will be magnified from the center.
  or
- To enlarge a specific area of the drawing, press and hold the left mouse button and drag a rectangle around the area of interest. CrysVUn will fit this area into the working space of the Main Window.

3.1.2. Zooming out

For decreasing the drawing size, you have the following options:

- Press the - key to gradually decrease the drawing size.
  or
- Click on to reset the drawing to its original size, i.e. the whole geometry is visible on the screen.
  or
- Select Visualization > Zoom Out (only available in Simulation Mode).

3.1.3. Scrolling

After the drawing was enlarged, you sometimes have to move the drawing to see a different cutout.

- You have two options for scrolling the drawing up, down, left and right:
  Use the cursor keys on the key board to scroll the drawing up, down, left and right.
  or
  Use the page up and page down keys or mouse wheel, if your magnifying factor is large and you want to move faster.

Note

Whenever you open a file or change the operational mode, the drawing will always be placed in the original position and have its original size.

3.2. Drawing and Modifying the Drawing

If no CAD data are available, CrysVUn enables you to draw a furnace. The CrysVUn geometry is limited to points and lines.

3.2.1. Drawing and connecting points
• Type the point coordinates in the input field next to the add point in the tool bar and press the Enter key.

or

Navigate the mouse to the desired point and click the middle mouse button. Release the middle mouse button without moving the mouse.

The point will be displayed as a small square in your working area. In case the point does not appear in your working area, check if its coordinates are outside the current windows coordinates.

Note

If you prefer to use the mouse and want to start at the zero point, you should observe the coordinates in the left corner of the status bar. For getting the exact 0/0 coordinates you may have to enlarge the drawing.

Related Procedures

Merging points (page16 ) Splitting lines (page16 )

3.2.2. Handling dangling points

Each point needs to be connected to at least two lines, because CrysVUn’s simulation model is based on regions.

If you have “dangling points”, the system displays the following message when you try to switch to Materials Mode:

![Figure 3.1. Error dangling points](image)

Dangling points are highlighted in red. You need to take care of these dangling points, before you are allowed to quit Geometry Mode, see Merging points (page16 ).

You have two options for handling dangling points:

• Because the system highlights the dangling points, you can erase the points by pressing the delete key or by selecting Edit > Delete.

• The other option is to connect the points to lines.

Connecting points means you draw a line between two dangling points, a specific case of the procedure described in Drawing lines (page13 ).

1. Enlarge the area with the dangling points, see Zooming and Scrolling (page 10).

2. Place the mouse pointer exactly on the first point.

3. Click and hold the middle mouse button.

4. Drag the mouse towards the second point.
As you come closer, you will notice that the mouse pointer is automatically attracted and precisely linked to the center of the point. CrysVUn supports you in connecting points by employing raster points and tolerance, see Using Tolerance and Raster (page 14).

3.2.3. Drawing lines

Lines can only be added by using the middle mouse button.

1. Place the mouse pointer on the starting point of the line. For exact placement, observe the coordinates in the left corner of the status bar.

2. Press and hold the middle mouse button and move the mouse pointer to the end of the line.

3. Release the middle mouse button.

The line appears in your working field.

Note

The system will display the message concerning “dangling points” also in case of lines which do not belong to an area. You need to connect both ends of the line to an area or, as called in Simulation Mode, to a region.

3.3. Selecting Elements

Before you can copy, move, or delete points and lines for modifying the geometry of the furnace or the cartridge, you need to select them. Again, you have two ways for selecting objects, but in any case you have to use the right mouse button.

Note

For marking elements, be sure to use the right mouse button. If you take the left mouse button and move the mouse just a little bit, you unintentionally zoom into the drawing. According to the extreme magnifying factor, it seems as if the drawing vanished from your screen. Just click on [ ] and the drawing reappears.

3.3.1. Selecting a point or a line

You can select as many points and lines as you need. The selection will hold as long as you click on the selected element again. In Geometry Mode, clicking next to the drawing will not cancel any selection.

1. Move the mouse pointer exactly on the point or line that you want to select.

2. Click the right mouse button.

The color of the point or the line will turn red.

Note

When selecting a line make sure that the points at the end of line are also selected. Otherwise some operations will not be carried out.

3.3.2. Selecting points and lines by dragging a rectangle
1. Move the mouse pointer to the upper left corner of the area you want to select.

2. Press and hold the **right mouse button** and drag the mouse to the lower right corner of the area that you want to select.

All points and lines within the selected rectangle will turn red.

**Related Procedures**

Selecting the elements to be moved (page 130)

### 3.3.3. Selecting all elements

For selecting all elements in a drawing you have two options:

- Drag a rectangle around the complete drawing using the **right mouse button**.
  or
  Select **Edit > Select All**.

The color of the selected points and lines changes to red.

### 3.3.4. Cancelling selection

You can cancel selections in the drawing by using the mouse or by selecting the associated menu item.

- Move the mouse pointer on a selected point or line and click the **right mouse button**.
  or
  Select **Edit > Unselect All** to cancel all selections at once.

Points and lines turn to black.

**Related Procedures**

Selecting the elements to be moved (page 130)

**Related Dialogs**

Edit Menu (page 209)

### 3.4. Using Tolerance and Raster

Tolerance and raster increase the drawing accuracy and help to avoid dangling points, see Drawing and connecting points (page 11). It is hard to hit exactly the center of the small square representing a point. For this reason the mouse pointer is automatically attracted to the point center as soon as it comes close enough due to the defined tolerance. Raster is most useful, when you want to design a drawing true to scale. The distance between raster points is defined by the tolerance value.

### 3.4.1. Setting tolerance

Because geometries have to be considerably scaled down for running simulations in **Cry**-

**VUn**, it may not be easy to hit exactly the point you want to connect or to change. But if you miss it just a little bit, you produce an additional (dangling) point. Enlarging the draw-
ing every time would be tedious. So CrysVUn supports you in finding the exact center of a point by attracting the mouse pointer to the point as soon as the pointer comes close enough. This tolerance is very useful for modifying drawings.

CrysVUn measures the distance between an existing point and the mouse pointer and tolerance specifies the radius of the attraction circle around an existing point. *Tolerance is measured in meter.* Adjust the tolerance at a minimum distance for the task you have to do. Changing the tolerance does not have any impact on existing points and lines.

For changing the tolerance you proceed as follows:

1. Place the mouse pointer in the tolerance input field \( \text{Tolerance} \) in the tool bar.
2. Change the value for tolerance.
3. Confirm and apply the new value by pressing the *Enter* key while the pointer is still in the input field.

The attraction radius will change according to the value. You might have to enlarge your drawing or to activate the raster, before you can observe any difference.

**Note**

You are not allowed to place points closer than the tolerance. If necessary, you have to change the tolerance first.

### 3.4.2. Using raster

The raster in Geometry Mode is displayed as regularly arranged points. The tolerance defines the increment of the raster. Once the raster has been activated, points can be set only on raster points. But the raster mode will not affect already drawn points and lines. You can use a fine raster for small details in the drawing and then increase the tolerance to continue with a coarser raster.

The raster facilitates in particular

- drawing on a dimensional worksheet
- transferring a scaled drawing into CrysVUn

**Warning**

If the points and lines of your drawing do not match the tolerance, avoid drawing any points or lines while the raster is on.

If the new line crosses old lines, the intersection points will be automatically attracted to the raster points. This will distort your drawing.

Make sure that the *Toggle Raster* button is turned off, before you modify your drawing.

- Activate the raster by clicking on the *Toggle Raster* button ![Toggle Raster](toggle_raster.png).

The raster points will be displayed.

**Note**

If raster points are not visible, your tolerance may be too small. You can either increase the tolerance or enlarge the drawing.
3.4.3. Merging points

*CrysVUn* will check for each pair of selected points whether they are closer to each other than the tolerance. If this is the case, one of the points will be deleted and the line ending at the second point will be connected to the remaining point.

1. Select the points you want to merge.
2. Select **Edit > Merge Points**.

The points merge and the lines are connected.

**Note**

Merging only occurs, if the points to be merged are within the tolerance. Increase the tolerance stepwise, until the points merge.

**Related Procedures**

Drawing and connecting points (page 11)

3.4.4. Splitting lines

Splitting lines is similar to merging points. Sometimes you try to hit a line and when enlarging the drawing, you notice that you missed it. *CrysVUn* checks for each selected line, whether a point is closer than the tolerance and moves this point to the line by normal projection. The line will then be split, i.e. you can select both parts separately. If the point is an end point of a line, the closest end points of both lines will be connected to each other.

1. Select the line which shall be split by the point.
2. Select **Edit > Split lines**.

The point is moved to the line. The end point of a line is connected to the closest end point of the selected line.

**Note**

Merging only happens, if the points to be merged with lines are within the tolerance. Increase the tolerance stepwise, if necessary.

**Related Procedures**

Splitting a line (page 133)

3.4.5. Intersecting lines

Intersecting lines is needed e.g. for dividing regions. The **Intersect lines** menu item will try to intersect each pair-combination of selected lines. It will generate a new point at the intersection and automatically split the two lines at that point.

Alternatively you can draw a line across one or more existing lines with the **middle mouse button** and *CrysVUn* will automatically create a point at the intersections which splits the lines crossed. You have to cut the jutting ends.

- Select **Edit > Intersect lines**.
The selected lines will be intersected.

**Related Dialogs**

Edit Menu (page209 )

**3.5. Moving and Copying Elements**

When modifying a geometry, you probably want to change the location of elements, e.g. to make the sample larger or smaller, or you want to duplicate elements, e.g. to add another heater.

**3.5.1. Moving elements via the Copy/Move-to dialog**

In this section we explain how to move points and lines by specifying new coordinates. How to move elements by drag and drop is described in section Moving elements by drag and drop (page18 ).

**Note**

Be sure to select all elements you want to be moved. For moving a line, always select both end points. If you select only one end point, only this point will be moved and the line becomes inclined.

For moving elements you proceed as follows:

1. Select the point(s) or the line(s) you want to move by using the right mouse button.
2. Select **Edit > Copy/Move to** menu item.
   
   The **Copy/Move to** dialog opens:

   ![Copy/Move-to dialog](image)

   *Figure 3.2. Copy/Move-to dialog: moving parameters.*

3. Check **move** option.
4. Check **absolute** option, if you want to give the coordinates of the new position starting from point zero.
   
   or
   
   Check **relative** option, if you want to specify the new position as difference relative to the actual position.
5. Type the new coordinate for x (r) or y (z) in the associated input field.
6. Check the box in front of **Change x (r) to** or **Change y (z) to** or both, if you want the new coordinate(s) to be applied.
7. Click on **Apply** button to apply the changes.

The selected point or line moves to the right. If nothing happens, look into the **Move to**...
dialog, whether you forgot to check any of the boxes.

**Related Procedures**

Changing the sample size by entering exact values (page 132)

### 3.5.2. Copying elements via the Copy/Move-to dialog

In this section we explain how to copy points and lines by specifying new coordinates. How to copy elements by drag and drop is described in section Copying elements by drag and drop (page 19).

**Note**
The new points and lines are placed relative to the position of initial elements, so the x and y fields represent the displacement between original elements and their copy.

For copying elements you proceed as follows:

1. Select the point(s) or the line(s) you want to copy by using the right mouse button.
2. Select **Edit > Copy/Move to**.
   
The **Copy/Move to** dialog opens:

   ![Copy/Move to dialog](image)

   *Figure 3.3. Move-to dialog: copying parameters.*

3. Check **copy** option.
   
The **absolute/relative** check box is disabled while the copy is always relative.
4. Type the displacement for x (r) or y (z) in the associated input field.
5. Check the box in front of **Change x (r) to** or **Change y (z) to** or both, to specify the relative position of copied elements.
6. Click on **Apply** button to apply the changes.

### 3.5.3. Moving elements by drag and drop

In addition to specifying the coordinates where elements shall be moved to, you can also move the selected elements by drag and drop.

Make sure that all needed points and lines are selected:

- If you select the line, but no end point, nothing will be moved.
- If you select only one end point, the other will remain fixed and the line will be stretched.
• If you select both end points, the line will be moved, even though it was not selected.
• If you select both end points and the line, the line will be moved.

**Note**
You have to reconnect the moved elements to the drawing.

1. Select the point(s) or the line(s) you want to move by using the **right mouse button**.
2. Click on the **move** button in the tool bar.
3. Move the mouse pointer to the selected elements.
4. Press and hold the **middle mouse button** and move the elements to their new position.
5. Release the **middle mouse button**.

The selected elements are relocated, and the move button is automatically toggled off.

**Related Procedures**
Changing the sample size by drag and drop (page132)

**3.5.4. Copying elements by drag and drop**
Your geometry may have components that are used in more than one place. So you want to duplicate these elements. The procedure is similar to moving elements by drag and drop:

1. Select the point(s) or the line(s) you want to copy by using the **right mouse button**.
2. Click on the **copy** button in the tool bar.
3. Move the mouse pointer to the selected elements.
4. Press and hold the **middle mouse button**, and move the copied elements to their destination.
5. Release the **middle mouse button**.

The selected elements are copied to a new destination, and the copy button is automatically toggled off.

**Related Dialogs**
Edit Menu (page209)

**3.6. Further Handling of Selected Elements**
The purpose of selecting elements is not only to copy and move them. Maybe you want to delete them or to align your drawing to the raster. Sometimes it is also convenient to group elements or to rotate them.

**3.6.1. Deleting elements**
For deleting elements you have two options:

1. Select the point(s) and the line(s) you want to delete by using the right mouse button.
2. Click on the Delete button in the tool bar. 
   or
   Select Edit > Delete.

The selected elements disappear.

Tip
If more elements are deleted as desired, just reverse the action by selecting Edit > Undo or using the shortcut, see Key Functions and Shortcuts (page 260).

3.6.2. Using grid alignment
If you started drawing without raster and now want to use the raster for finishing or modifying a drawing, grid alignment will move all selected points to the closest raster point.

Note
Grid alignment will work, even though the Raster button is off.

1. Select the point(s) and the line(s) you want to be aligned to raster points by using the right mouse button.
2. Select Edit > Grid Alignment.

The selected points are moved to raster points, the selection is canceled.

3.6.3. Working with blocks
CrysVUn offers the possibility to work with blocks, which facilitates copying and moving, for instance. Each block can be easily identified by its own color. Each line can belong to only one block. The block information is only available in Geometry Mode. If you want to preserve it, you have to save the *.pcs file of the drawing.

In order to work with blocks, you need to click on the Toggle Block button in the tool bar. Otherwise, only lines or points hit by the right mouse button will be selected. The Toggle Block button remains active, as long as you click on it again to turn it off. Clicking the right mouse button anywhere in the drawing will select the closest block, i.e. the block to which the closest line belongs. To select a particular block, just click inside or right outside this block.

To create a block you proceed as follows:

1. Select the lines you want to be included in the block by using the right mouse button. Selecting points is not necessary, because they are ignored.
2. Select Edit > Create Block.

The block appears in the drawing as group of lines of the same color.
3.6.4. Rotating elements

*CrysVUn* enables you to rotate selected elements. All you have to do is to specify the rotation angle. The rotation center is the center of the rectangle containing all selected elements.

![Figure 3.4. Rotation of elements](image)

1. Rotation center
2. Rotation object
3. Rectangle including all elements to be rotated

*Figure 3.4. Rotation of elements*

For rotating elements proceed as follows:

1. Select *Edit > Rotate Selection*.
   
The *Rotate Selection* dialog opens.

   ![Rotate selection dialog](image)

   *Figure 3.5. Rotation dialog*

2. A positive value means counterclockwise rotation, a negative value means clockwise rotation.
   
   Type the rotation angle in the input field, e.g. 30° and click **OK**.

   The selected elements are rotated counterclockwise by 30°.

**Related Procedures**

- Modifying the Sample Cartridge Assembly (SCA) (page130)

**Related Dialogs**

- Edit Menu (page209)

3.7. Changes to the Complete Drawing
Certain operations you can apply to the complete drawing, which is particularly useful for preparing *.dxf files for CrysVu

3.7.1. Applying Flip
If the CAD file was drawn with a horizontal symmetry axis, Flip changes the x and the y coordinate. Two consecutive flip operations are equivalent to a unitary transformation, i.e. no change.

- Select Edit > Flip.
  The drawing is flipped, i.e. rotated by 90° and left/right reversed.

3.7.2. Applying Mirror
Mirror changes the x into -x. This is useful if the CAD drawing was made with a different vertical symmetry axis. Two consecutive mirror operations are equivalent to a unitary transformation, i.e. no change.

- Select Edit > Mirror.
  The drawing is swapped left/right.

3.7.3. Applying scale
Most CAD files are drawn in mm, CrysVu’s computation is based on m. Therefore you need to scale the CAD drawing, before you can compute. The default scaling factor 0.001 transforms mm into m, which is the most frequent operation.

1. Select Edit > Scale.
   The scale dialog opens:

   ![](scale_dialog.png)

   Figure 3.6. scale dialog

2. Confirm the default scaling factor 0.001 by clicking on OK.
   or
   Type the desired scaling factor into the input field and click on OK.
   Your drawing will be displayed in the new scale.

3.7.4. Applying Align Left
This option moves the point with the smallest x-coordinate to the symmetry axis and re-arranges the rest of the drawing appropriately. Again, you need this function for CAD files
which usually do not supply absolute coordinates.

- Select **Edit > Align Left**.
  The symmetry axis of the drawing moves to the coordinate \( x = 0 \).

### 3.7.5. Applying Align Origin

This option determines the point with the smallest \( x \) and \( y \) coordinates, moves it to the origin \( (x = 0, y = 0) \), and remodels the whole drawing. This function is not only helpful for imported CAD files, but also for cancelling previous operations.

- Select **Edit > Align Origin**.
  The complete drawing is aligned to the coordinates \( x = 0, y = 0 \).

#### Related Dialogs

**Edit Menu (page209 )**

### 3.8. Importing a CAD File (dxf-Format)

If a CAD program was used for furnace design, the geometry in *CrysVUn* can be build on the CAD file, provided it has a standard *.dxf* format. But in any case you have to fix the *.dxf* files to meet *CrysVUn* ’s requirements. Maybe you notice that some of the lines in the *.dxf* file are intersected and some contours not closed.

You may be confronted with the following problems when importing a *.dxf* file:

- In *CrysVUn* geometries are designed only with points and lines.
- Unlike most CAD designers, *CrysVUn* uses the international system of units, i.e. meter for lengths, not millimeter.
- For axial symmetric geometry, the symmetry axis is \( x = 0 \). The geometry data contain only the information for the right side of the geometry.
- The *.dxf* file may contain points and lines which are meaningless from the simulation point of view, because they do not define regions. But these elements have to be removed.

*CrysVUn* is prepared to handle these problems. The following sequence exemplifies the most common procedure:

1. Close your current file by selecting **File > Close**.
2. Change to Geometry Mode by selecting **Mode > Geometry**.
3. Select **File > Import**.
   The **Import File** dialog opens:
4. Select the desired *.dxf file (Furnace.dxf in the example above), and click on Open.

5. If the drawing contains arcs, CrysVu converts these arcs into lines before processing the file. In the Arc dialog, you are asked to specify the length of the lines (arc unit length) which the arcs shall be segmented into.

![Figure 3.8. Dialog for specifying the arc unit length](image)

Type the arc unit length into the input field of the Arc dialog, in the example: 14. After loading the *.dxf file the lines of converted arcs are automatically selected (displayed in red).

6. Because CAD designers tend to use millimeters, convert the length unit from millimeter to meter:
   Select Edit > scale and set the scale factor to 0.001.

7. Click on the Toggle Raster button to activate the Raster.

8. Set the tolerance to the minimum length of the CAD drawing. For instance, if the minimum length is 5 mm, set the tolerance to 0.005.

9. Select Edit > Select All to be sure not to miss any point or line.

10. Select Edit > Grid Alignment to align the drawing to the raster.

11. Set the tolerance to a higher value, e.g. 0.01, because you can continue on a coarser raster.

12. Draw a vertical line from the top to the bottom of the object to serve as symmetry axis.

13. Select all points and lines on the left side using the right mouse button.

14. Click on the Delete button in the tool bar.
   or
   Select Edit > Delete.
The left side of the drawing vanishes. If more lines were deleted than expected, select **Edit > Undo** or draw them again.

15. Select **Edit > Align Left** to set the symmetry axis to \( x = 0 \).

16. Select **File > Save** to save the geometry information in the \( *.pcs \) format.

17. Now you can verify the geometry by switching to Materials Mode.
   - Select **Mode > Materials**.
   - If **CrysVUn** fails to compute the regions because of dangling points, you will get a message and you need to take care of them, see Drawing and connecting points (page 11), before you are allowed to switch to Materials Mode.

**Note**

If **CrysVUn** cannot open a \( *.dxf \) file, try to save the file in AutoCAD standard R13. For loading and saving your file, you can also use a Linux software, such as **qcad**.

### 3.9. Setting Symmetry

**CrysVUn** was developed for axial symmetry, which is the normal use case. But it can also simulate translational symmetry. In this case the geometry is treated in Cartesian coordinates (2D simulation, coordinates \( x, y \)) and extended infinitely in the third direction (\( z \)). No gradient is assumed in \( z \)-direction.

**Note**

Be sure to change the symmetry before you switch to Materials Mode, because symmetry has an impact on boundary conditions.

The default is axial symmetry. If you have to change it, proceed as follows:

1. Select **Settings > Symmetry**.
   - The symmetry dialog opens:

   ![Symmetry dialog](image)

   *Figure 3.9. Symmetry dialog*

2. Click on the check box in front of **Translational**.
   - The symmetry basics is changed to translational.
Chapter 4. Materials Mode

After having designed or modified the geometry, you need to define materials and their properties and to assign a material to each of the furnace's regions. In order to improve the simulation result, materials can be replaced and their properties can be modified. Materials have to be assigned before you start computing.

For new geometries you have three options for getting materials:

- Import materials from the CrysVUn material database in the Database dialog window.
- Add materials and their properties manually in the Materials dialog window.
- Import materials from another CrysVUn file, provided you saved them in a separate file (*.mat).

In Materials Mode only the file menu and the Materials dialog invoked by the Settings menu are available. For zooming use the left mouse button.

For dealing with the components of the Materials dialog and assigning materials in Materials Mode see

- section Adding, Replacing and Deleting Materials (page 27)
- section Modifying Materials Properties (page 32)
- section Assigning Materials to Regions (page 37)
- section Saving Materials Data Files (page 39)
- section Setting up and Maintaining the Material Database (page 40)

4.1. Materials dialog

When you load a *.crys file and open the Materials dialog, the following window appears:

![Materials dialog window](image)

Figure 4.1. Materials dialog window
The Materials dialog window is divided into two sections: In the left section the name of the selected material, the list of all materials in the current furnace is displayed and the buttons Delete Material and Database are offered.

The large frame on the right hand side contains properties and phases for each material in the materials list. On top of the material properties field you find buttons for adding and deleting phases to materials, plotting properties and displaying the characteristic numbers for the sample material.

Underneath the material properties field are a few fields for displaying and entering additional information:

<table>
<thead>
<tr>
<th>Field</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Revision</td>
<td>Revision number of material.</td>
</tr>
<tr>
<td>Status</td>
<td>Status of material compared to the material database, e.g. Up_to_date, LocallyModified, NeedsPatch.</td>
</tr>
<tr>
<td>Critical T (K)</td>
<td>Represents the maximal temperature this material can support.</td>
</tr>
<tr>
<td>Mushy zone (K)</td>
<td>Represents half the interval in which latent heat is released.</td>
</tr>
<tr>
<td>Comments</td>
<td>Room for your comments.</td>
</tr>
</tbody>
</table>

4.2. Adding, Replacing and Deleting Materials

For modifying the list of materials you open the Materials dialog. This dialog is available in Materials Mode and in Simulation Mode and allows you to add, replace and delete materials or to modify their properties, see Modifying Materials Properties (page32).

If you designed or imported a new furnace, the list of materials in the Materials dialog and the material list box in the tool bar will be empty.

Figure 4.2. Materials dialog window for new furnace
You have the following options to add materials to the furnace:

- You use CrysVUn’s material database.
- You enter the required materials and their properties manually.
- You use materials saved in a *.mat file (rarely used).

### 4.2.1. Copying materials from the material database to the furnace

A material database is compiled and provided within the CrysVUn software. The materials of the database are available to the user in the Database dialog. If no materials are available, you have to set the location of the database file, see Configuring the material database (page 40).

1. Select **Settings > Materials** to open the Materials dialog.

2. Click on the Database button.

The list of materials in the Material database will be displayed in the Database dialog.

3. Select the material you want to transfer to the local database and click on the button.

The selected material, in this case **Boroxid** copied to the Local materials field:
4. Click on **Apply** to save the changes and keep the dialog open.
   or
   Click on **OK** or **Apply** and **Close** to apply the changes and to close the dialog.

**Note**

Materials copied to the **local database** will be available simultaneously in the list of materials in the **Materials** dialog and in the list box in the tool bar of the main window.

**Related Procedures**

- Adding a material to the furnace (page136 )

**4.2.2. Adding and replacing materials in the Materials dialog**

The user has the full control over the furnace's materials and their properties in the **Materials** dialog.

Adding a material to an already existing list of materials saves time, because you only have to assign a name to the material and to adapt the properties. If the list is completely empty, you have to supply not only the material name, but also all relevant properties.

Number and types of properties are predetermined. You cannot add new ones because materials' properties are essential to *CrysVUn*'s computation process.

To add or replace a furnace material proceed as follows:

1. Select **Settings > Materials** to open the **Materials** dialog.

   The **Materials** dialog opens.
2. The name of a material must be unique and can not be changed. Observe case sens-
itivity when typing the material name.

If materials are available, select a material with similar properties than the one you
want to add from the materials list in the left window and overwrite the name in the in-
put field under Material name.

or

Type the name of the new material in the input field under Material name.

3. Press Enter.

The material name appears in the materials' list window on the left and its properties
will be considered in future computations.

4. Change properties, if necessary, see Modifying Materials Properties (page32 ).

5. Click on Apply, if you want to keep the dialog open for adding more materials.

or

Click on OK or Apply and Close to apply the changes and to close the dialog.

The new material(s) can be assigned to furnace regions.

Note
For replacing a material you proceed as if you were adding a new material. After
you changed the assignment, see Assigning Materials to Regions (page37 ), de-
lete the material no longer needed before you close the dialog.

Related Procedures
Adding a material to the furnace (page136 )

Related Dialogs
Materials (page213 )

4.2.3. Deleting a material

Warning
If you click on **Delete material** unintentionally, the current material and its properties will be deleted immediately.
Data will be lost, because there is no Undo in Materials Mode.
Do not click on this button, unless you are positive that you do not need this material anymore.

The procedure for deleting materials is very simple:

1. Select **Settings > Materials** to open the **Materials** dialog.
2. Select the material.
3. Click on **Delete Material**.

The material vanishes from the materials' list.

**Note**
You can only delete materials which are not assigned to any region of the current file!

### 4.2.4. Updating furnace materials based on the material database

Whenever materials properties are changed, the material database keeps the revision of each furnace material. You may use any revision of any material, because the database contains all revisions available.

If an old revision of a material is used in a furnace, the program automatically displays the following warning, when you open the *.crys* file:

![Old material properties warning](image.png)

*Figure 4.7. Old material properties warning*

The status **NeedsPatch** is assigned to the material(s) concerned.
You can update the properties of selected materials or of all materials in this furnace.

1. Select **Settings > Materials** to open the **Materials** dialog.
2. Click on the **Database** button to open the **Database** dialog.
   The **Database** dialog opens.
3. Select the material you want to update in the furnace materials list on the right and click on the button.

or

Click on the button to update all materials which have the NeedsPatch status.

The selected material(s) are updated and their status is changed to 'Up_to_date'.

4. Click on Apply to save the changes.

Related Dialogs

Database (page 214)

4.3. Modifying Materials Properties

Materials, their properties and the material assignments to regions are the prerequisites for computing simulations with CrysVUn. Modifying materials' properties becomes necessary, if you add a new material or if you want to improve the computation results after a simulation run. You do not have to change the operation mode for modifying properties, because the Materials dialog is available in Materials Mode and in Simulation Mode.

The properties of the material selected in the Material name field are displayed in the large frame on the right hand side of the window, see Materials dialog window (page 26). The first column shows the properties' name and parameters, the second the unit of measurement, the third the entries for the properties in phase 0, the fourth the entries for phase 1 and so on. You can add phases by clicking on the Add Phase button. You delete phases by clicking in the column's head to select the phase and then click on Delete Phase. Press and hold the CTRL key for selecting more than one phase to delete.

Warning

The column(s) will be deleted immediately.

Potential data loss, because there is no Undo in Materials Mode!

Make sure that you really do not need these data anymore.

Each material needs at least one phase and therefore CrysVUn will prevent you from deleting the last remaining phase by displaying the following message:
Only phase columns and only properties assigned to the material can be edited. Values to be entered or modified have to be typed into the respective phase column line. We recommend to use the mouse for navigating in the tables cells, but *CrysVUn* also offers a number of shortcuts, see Keys for editing material properties (page 261). The program controls your input and will not allow you to specify a viscosity for solid materials, for instance. Fields which can not be edited are displayed in gray color.

To facilitate defining or changing properties, *CrysVUn* offers some list boxes in the phase columns for selecting the appropriate characteristic. You just check in the list box, for instance, whether your material is transparent or opaque instead of writing it in.

Properties are grouped into six groups: General, thermal, optical, fluid, species transport and mechanical properties. Fluid, species transport and mechanical properties can be collapsed by clicking on the button in front of the property group's name.

### 4.3.1. Changing general properties

There are four general properties, the last two you only need to specify for inductive heating:

<table>
<thead>
<tr>
<th>General properties</th>
<th>Unit</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>State</td>
<td></td>
<td>List box for selecting the material state depending on the current state of the phase.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>List box options: <strong>solid</strong> and <strong>liquid</strong>.</td>
</tr>
<tr>
<td>Density</td>
<td>kg/m³</td>
<td>Material density as a function of temperature ( f(T) ).</td>
</tr>
<tr>
<td>Electrical conductivity</td>
<td>S/m</td>
<td>To be specified for conductive materials and needed for inductive heating.</td>
</tr>
<tr>
<td>Magnetic permeability</td>
<td>H/m</td>
<td>A constant of proportionality that exists between magnetic induction and magnetic field intensity. This constant is equal to approximately ( 1.257 \times 10^{-6} ) henry per meter (H/m) in free space (vacuum).</td>
</tr>
</tbody>
</table>

1. Place the cursor in the phase column of the property that you want to change.
2. Type respectively overwrite the value.
or
Select the state in the list box.

3. Click on **Apply** or press the **Enter** key and continue with the next property.
or
Click on **OK** to apply the changes and to close the dialog.
The next computation will consider the changed properties.

### 4.3.2. Changing thermal properties

Here you specify at least the material heat capacity and conductivity-r. The default for conductivity is isotropic. Only when changing to anisotropic, you can specify conductivity -z and Phi. **Melting point** and **Latent heat** are only displayed for materials with at least two phases, normally the material of the sample.

<table>
<thead>
<tr>
<th>Thermal properties</th>
<th>Unit</th>
<th>Explanation/Possible entries</th>
</tr>
</thead>
<tbody>
<tr>
<td>Heat capacity</td>
<td>J/(kg·K)</td>
<td>Specific heat capacity of the material ((f(T))).</td>
</tr>
<tr>
<td>Conductivity - r</td>
<td>W/(m·K)</td>
<td>Thermal conductivity ((\Lambda_r)) as function of (T) for the conductivity along the r-axis, default = 0.</td>
</tr>
<tr>
<td>Conductivity - z</td>
<td>W/(m·K)</td>
<td>Thermal conductivity ((\Lambda_z)) as function of (T) for the conductivity along the z-axis, default = 0. Requires <strong>Anisotrop</strong> = yes.</td>
</tr>
<tr>
<td>Anisotrop</td>
<td></td>
<td>Default is isotropic (Anisotrop = no). To enter an anisotrop conductivity, the list box option must be set to yes.</td>
</tr>
<tr>
<td>Phi</td>
<td>DEG</td>
<td>Anisotrop Phi specifies the angle between (z) axis and symmetry axis. Requires <strong>Anisotrop</strong> = yes.</td>
</tr>
<tr>
<td>Melting point</td>
<td>K</td>
<td>Temperature at which a solid material becomes a liquid. Only displayed if material has more than one phase!</td>
</tr>
<tr>
<td>Latent heat</td>
<td>J/kg</td>
<td>Heat associated with a phase; heat absorbed (or released) by a unit mass of substance to change its state without any change in temperature. Only displayed if material has more than one phase!</td>
</tr>
</tbody>
</table>

1. Place the cursor in the phase column of the property that you want to change.
2. Type respectively overwrite the value.
or
Select yes in the list box of the Anisotrop property to specify Conductivity -z and/or Phi.

3. Click on Apply or press the Enter key and continue with the next property.
or
Click on OK to apply the changes and to close the dialog.
The next computation will consider the changed properties.

4.3.3. Changing optical properties

<table>
<thead>
<tr>
<th>Optical properties</th>
<th>Unit</th>
<th>Explanation</th>
</tr>
</thead>
</table>
| Transparency       |      | Degree of opacity or transparency of a material.  
The list box in CrysVUn offers three transparency types: |
|                    |      | - Opaque  
Fully opaque, no transparency at all. |
|                    |      | - Transparent  
Fully transparent. |
|                    |      | - Visibility bands  
Semitransparent material showing different transparencies in different wavelength domains.  
CrysVUn uses the n-Band model. |
| Emissivity         |      | The emissivity of the material in the approximation of gray bodies is needed for materials at the border of a radiation cavity and must be a real number between 0 and 1. |
| Visibility windows | µm   | If transparency is Visibility bands, you need to specify the visibility band windows by entering a list of wavelengths or a formula, e.g. 0-1 1-4 4-1e+10.  
A fully transparent material has the Visibility bands list 0-1e+10, an opaque material 0-0, i.e. no transparency window. |

1. Place the cursor in the phase column of the property that you want to change.
2. Type respectively overwrite the value.
or
Select Yes in the list box of the Anisotrop property to specify Conductivity -z and/or Phi.
3. Click on **Apply** or press the **Enter** key and continue with the next property.
   or
   Click on **OK** to apply the changes and to close the dialog.
   The next computation will consider the changed properties.

### 4.3.4. Changing fluid properties

<table>
<thead>
<tr>
<th>Fluid properties</th>
<th>Unit</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Viscosity</td>
<td>kg/(m·s)</td>
<td>Dynamic viscosity to be specified for fluid flow computations.</td>
</tr>
<tr>
<td>Volumetric expansion coefficient</td>
<td>1/K</td>
<td>Expansion coefficient in the Boussinesq approximation. This value is not used for compressible flow computations.</td>
</tr>
<tr>
<td>Ideal gas</td>
<td></td>
<td>Default is no. If your material permits, you can change it to yes in the list box.</td>
</tr>
<tr>
<td>Molar weight</td>
<td>kg/mol</td>
<td>Mass divided by amount of substance.</td>
</tr>
<tr>
<td>Marangoni coefficient</td>
<td>N/(K·m)</td>
<td>Temperature dependence of surface tension, needed for the computation of surface-active flow.</td>
</tr>
</tbody>
</table>

1. Place the cursor in the phase column of the property that you want to change.
2. Type respectively overwrite the value.
3. Click on **Apply** or press the **Enter** key and continue with the next property.
   or
   Click on **OK** to apply the changes and to close the dialog.
   The next computation will consider the changed properties.

### 4.3.5. Changing species transport coefficients

<table>
<thead>
<tr>
<th>Species transport properties</th>
<th>Unit</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Diffusion coefficient</td>
<td>m²/s</td>
<td>Diffusion coefficient of the species in the liquid.</td>
</tr>
<tr>
<td>Partition coefficient</td>
<td></td>
<td>Ratio between solid and liquid concentration at the solid/liquid interface.</td>
</tr>
<tr>
<td>Solutal expansion coefficient</td>
<td>1/wt-pct</td>
<td>Needed for calculations with solutal convection.</td>
</tr>
<tr>
<td>Equilibrium solubility</td>
<td>wt-pct</td>
<td>Limit of solubility as for the a chemical species.</td>
</tr>
</tbody>
</table>
1. Place the cursor in the phase column of the property that you want to change.
2. Type respectively overwrite the value.
3. Click on **Apply** or press the **Enter** key and continue with the next property.
   or
   Click on **OK** to apply the changes and to close the dialog.
   The next computation will consider the changed properties.

### 4.3.6. Changing mechanical properties

<table>
<thead>
<tr>
<th>Mechanical properties</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Thermal expansion</td>
<td>1/K</td>
</tr>
<tr>
<td>Stress coefficient - c_{11}</td>
<td>Pa</td>
</tr>
<tr>
<td>Stress coefficient - c_{12}</td>
<td>Pa</td>
</tr>
<tr>
<td>Stress coefficient - c_{13}</td>
<td>Pa</td>
</tr>
<tr>
<td>Stress coefficient - c_{22}</td>
<td>Pa</td>
</tr>
<tr>
<td>Stress coefficient - c_{23}</td>
<td>Pa</td>
</tr>
<tr>
<td>Stress coefficient - c_{33}</td>
<td>Pa</td>
</tr>
<tr>
<td>Stress coefficient - c_{44}</td>
<td>Pa</td>
</tr>
</tbody>
</table>

1. Place the cursor in the phase column of the property that you want to change.
2. Type respectively overwrite the value.
3. Click on **Apply** or press the **Enter** key and continue with the next property.
   or
   Click on **OK** to apply the changes and to close the dialog.
   The next computation will consider the changed properties.

### 4.4. Assigning Materials to Regions

In Materials Mode selecting a region is employed for assigning a material to that region, one by one, using the **left mouse button**. The **middle mouse button** and the **right mouse button** have no function in the assigning procedure.

After you finished drawing in Geometry Mode, you switch to Materials Mode. All regions will be white.
As soon as a material is assigned, the region will adopt the color associated with the material in the list box. If you changed regions in a file which had already materials assigned to its regions, only the modified regions will be white.

**Note**
Colors are randomly assigned to materials in alphabetical order. If you add a material in the middle of the list, for instance, the color of the following materials will change in the furnace!

Eventually all regions of your furnace will be colored:

**Note**
It is absolutely necessary that you assign a material to each region. *CrysVUn* will not start computing, if regions exist to which no material was assigned! In this case, you will get the following error message after starting the computation:
Note
If you want to avoid computing the unstructured grid in certain regions, assign the material vacuum.

For assigning materials proceed as follows:

1. Select Mode > Materials.
   The furnace regions are displayed. Each region has a different color, see Materials assigned to regions (page 38).

2. The list box in the tool bar contains the materials available in the current furnace. If the list box is empty, you can import materials by opening any *.mat file.
   Select the desired material from the list box in the tool bar.

3. If the region is very small, you can enlarge the cutout by using the left mouse button.
   For zooming back you click on . You can assign a material only to one region at a time.
   Move the mouse pointer to the region where you want to assign this material.

4. Press and hold the CTRL key and click the left mouse button.
   The selected region will adopt the color allocated to the material in the list box.

5. Repeat steps 2 and 3, until a material has been assigned to each region of the geometry respectively all changes have been made.

6. Select Mode > Simulation to switch to Simulation Mode.
   or
   Save the *.mat file with the current materials and their properties, before switching to Simulation Mode.

Note
Colors are randomly assigned to materials. The same material can and probably will have different colors in different files, depending on number and sequence of materials.

Related Procedures
Assigning materials (page138 )

Related Dialogs
Materials (page213 )

4.5. Saving Materials Data Files
As in Geometry Mode it is possible to save files in a special format in Materials Mode. In addition to saving materials in the local material database, you can save the materials used in the current simulation in a separate file with the extension *.mat. * .mat files can be opened in Materials Mode only, e.g. for importing materials to new furnaces.

In this file, you save the materials and their properties only, but no information about their assignment to regions. If you want to save this information as well, you have to save the file in Simulation Mode as *.crys file.
Tip
If no *.mat file is available, you can open a *.crys file, switch to Material Mode and then save the file again. Opening this *.mat file will transfer the materials and their properties to your current file.

- Select File > Save.
  or
- Select File > Save as...

In the first case, the open file will be saved to a file with the same name, but the extension *.mat. In the 2nd case you can specify a different file name, but the extension will be *.mat as well.

4.6. Setting up and Maintaining the Material Database

Materials stored in CrysVUn files ( *.mat or *.crys ) are collected in a material database. The database contains user defined materials as well as materials provided by an external source (software provider, central administrator).

Materials provided by an external source are locked in the material database and can not be changed or deleted by the user. The user has total control only over locally added materials. The program keeps track of the changes in the material database. Changing the local database requires writing permission for the file material_database.mat.

4.6.1. Configuring the material database

The material database is provided with CrysVUn and consists of one material file stored in CrysVUn 's Data directory, default is material_database.mat. You have to specify the valid path and the file name for the material database, in the Preferences dialog.

Note
For consistency reasons, the material database file shall only be modified in CrysVUn.

1. Select File > Preferences.
2. Select Paths tab.
   The Paths tab opens.

   ![Figure 4.14. Preferences dialog, Paths tab](image)

3. Browse for the material database file, e.g. material_database.mat.
File name and path of the material database appear in the **Material database** field.

4. To apply the changes and close the dialog:
   Click on **Apply** and **Close**.
   
or
   Click on **OK**.

5. In the **Database** dialog you can verify that the database materials are actually available:
   Select **Settings > Materials** to open the **Materials** dialog.

6. Click on the **Database** button.
   The list of materials in the local database will be displayed on the left hand side of the **Database** dialog.

![Figure 4.15. Database dialog, material database loaded](image)

7. Click on **Close** to close the dialog.
   As soon as you open a *.crys* file, its local materials list will be displayed.

![Figure 4.16. Database dialog, database and furnace materials available](image)

Now you can transfer missing materials from the database to the list of local materials.
on the right side of the dialog or update the materials having the status NeedsPatch.

Related Dialogs
Database (page214)

4.6.2. Adding materials to the material database and updating materials

The materials defined in CrysVUn are stored in the material database. A material that shall be added or updated has to be made available in the list of local materials in the Database dialog.

You have three possibilities to add a material to the list of local materials:

- Load a * .mat or a * .crys file containing the desired material
- Add this new material in the Materials dialog (no opened file is required)
- Get an old revision of the material, if you only want to update it (no opened file is required)

Example:

2. Add the new material and its properties, e.g. Crucible Support, see Adding, Replacing and Deleting Materials (page 27).
3. Click on Apply.
4. Click on the Database button.
   The material Crucible Support is displayed in the Local materials list.
5. Click on the Database button.
   The material Crucible Support is saved in the Material database. If this material has already been saved to the database, a new revision of Crucible Support will be added.
6. To apply the changes and close the dialog:
   Click on Apply and Close.
   or
   Click on OK.

Note
You can add or update more than one material using the Save all button. In this case materials having the status LocallyAdded or LocallyModified in the local materials list are saved to the material database all at once.

4.6.3. Deleting materials in the material database

Locally added materials can be deleted from the Materials database.
1. Select **Settings > Materials** to open the **Materials** dialog.

2. Click on the **Database** button.

3. Select the material to be deleted in the material database list.

4. Click on the **Delete** button.
   The material vanishes from the list.

5. To apply the changes and close the dialog:
   Click on **Apply and Close**.
   or
   Click on **OK**.

**Note**
Only locally added materials can be deleted. If a material has several revisions, only the selected one is deleted. In case it is used in a furnace, the status property of the furnace's material is automatically updated.

### 4.6.4. Locking materials in the material database

Locally added materials can be locked and unlocked in the **Material database** list. The lock status is indicated by an open or closed lock in front of the material name.

1. Select **Settings > Materials** to open the **Materials** dialog.

2. Click on the **Database** button.

3. Select the material you want to lock or unlock in the material database list.

4. Click on the **Lock/Unlock** button.
   The lock status of the material changes in the **Material database** list.

5. To apply the changes and close the dialog:
   Click on **Apply and Close**.
   or
   Click on **OK**.

**Note**
If the material has more revisions, all revisions are locked or unlocked. In case it is used in a furnace, it will change the lock status in the furnace, too.

### 4.6.5. Updating the database from an external source

Besides adding materials in the **Database** dialog, the user can add materials to the database from an external source, e.g. materials provided by a central administrator or by the software provider. These materials will automatically get the status **CentralDb** and be locked in the material database.

1. Select **File > Preferences**.
2. Select **Maintenance** tab.

   The **Maintenance** tab opens.

   ![Preferences dialog, Maintenance tab](image)

   *Figure 4.17. Preferences dialog, Maintenance tab*

3. Browse for the materials file containing the updates, e.g. `latest_revision_materials.mat`.

4. Click on the **Update database** button.

5. Click on **Apply** and **Close** to apply the changes and close the dialog.

   or

   Click on **OK** to update the local database and close the dialog.

### 4.7. Using the Characteristic Numbers Dialog

Within this section the usage of the characteristic numbers dialog is explained. In addition the definition and physical meaning is given. This tool can help you to define parameters reasonable, like size of the grid elements or time steps. It also allows an estimation if the problem under investigation can be handled by CrysVUn at all. Of course this requires background knowledge in fluid dynamics and the physics of heat transfer, which this manual cannot provide. Please refer to literature available. Some hints are given in the bibliography.

**Related Dialogs**

Characteristic Numbers (page216)

#### 4.7.1. Computing Characteristic Numbers

In order to use the characteristic number calculator some prerequisites have to be fulfilled.

- At least one phase of the currently selected material must be set to liquid
- This phase must be selected.
- The material parameters needed for the specific characteristic number must be defined correctly in the selected phase.

In the following it is described how to calculate characteristic numbers:

1. Open the **Materials** dialog in the **Settings** menu.
2. Select a material containing a liquid phase filling the region of interest.
3. If the material is a multiphase one, select the liquid phase.

4. Click on the **Characteristic Numbers** button.
   The **Characteristic Numbers** dialog opens.

   \[
   \text{Figure 4.18. Characteristic Numbers dialog}
   \]

5. Type in the values for the characteristic temperature, the length, the temperature gradient and the velocity.

6. Press the **Apply** button.
   Depending on the material parameters defined in the selected phase several values will be displayed at the same time.

7. If you want to compute characteristic numbers for different values of e.g velocities, you can change the value in the text field and press **Apply** again.

### 4.7.2. Definitions and Explanations of Characteristic Numbers

In this section a short overview of the definitions for characteristic numbers used in CrysVUn is given. In addition a short explanation of the physical meaning is added. For a more detailed description please refer to the literature. The units of the physical quantities used are given in the Appendix.

<table>
<thead>
<tr>
<th>Characteristic number</th>
<th>Definition</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Prandtl number Pr</td>
<td>( Pr = \frac{\nu_d \cdot c_p}{\lambda} )</td>
<td>Material related characteristic number: Describes the ratio of sensitivity to convective or diffusive heat transfer in a material. High Pr means that in such a material it is expected that fluid flow will lead to significant changes even if the flow velocities are not to high.</td>
</tr>
<tr>
<td></td>
<td>( \nu_d = ) dynamic viscosity, ( c_p = ) heat capacity, ( \lambda = ) thermal conductivity</td>
<td></td>
</tr>
<tr>
<td>Grashof number Gr</td>
<td>( Gr = \frac{(g \cdot d T \cdot b \cdot L^3 \cdot \rho^2)}{(\nu_d^2)} )</td>
<td>Ratio between thermal buoyancy forces and viscous forces.</td>
</tr>
<tr>
<td></td>
<td>( L = ) characteristic length, ( g = ) gravity, ( b = ) thermal expansion coefficient, ( \rho = ) density, ( d T = ) thermal gradient</td>
<td></td>
</tr>
<tr>
<td>Rayleigh number Ra</td>
<td>( Ra = \frac{(g \cdot d T \cdot b \cdot L^3)}{(\nu_k \cdot \text{diff}_T)} )</td>
<td>Ratio between thermal buoyancy forces and viscous forces; Please note: ( Ra = Gr \cdot Pr )</td>
</tr>
<tr>
<td></td>
<td>( \nu_k = ) kinematic viscosity, ( \text{diff}_T = ) thermal diffusivity ( (l/(c_p \cdot \rho)) )</td>
<td></td>
</tr>
<tr>
<td>Reynolds number Re</td>
<td>( Re = \frac{v \cdot L \cdot \rho}{\nu_d} )</td>
<td>Ratio between dynamic and viscous forces. If Re &gt; 2000 the flow is considered to be turbulent.</td>
</tr>
<tr>
<td></td>
<td>( v = ) characteristic velocity</td>
<td></td>
</tr>
<tr>
<td>Characteristic number</td>
<td>Definition</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------</td>
<td>------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Schmidt number Sc</td>
<td>$Sc = \frac{v_d}{\rho D}$</td>
<td>Material related characteristic number: Characterizes the ratio of convective and diffusive species transport for different materials with given flow field.</td>
</tr>
<tr>
<td>D = diffusion coefficient</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Lewis number Le</td>
<td>$Le = \frac{l}{(c_p \rho D)}$</td>
<td>Material related characteristic number: Characterizes the ratio of energy to species transport for different materials with given flow field. Le = Sc/Pr;</td>
</tr>
<tr>
<td>Solutal Peclet number PeC</td>
<td>$PeC = \frac{vL}{D}$</td>
<td>Ratio between diffusive and convective species transport in a flow field.</td>
</tr>
<tr>
<td>Thermal Peclet number PeT</td>
<td>$PeT = \frac{vL}{\text{diff}_T}$</td>
<td>Ratio between diffusive and convective energy transport in a flow field.</td>
</tr>
<tr>
<td>Magnetic Taylor number Ta_m</td>
<td>$Ta_m = B_0^2 \frac{R^4 s^4 f (2 \rho c_k \rho p)}{(2 \rho c_k \rho p)}$</td>
<td>Magnetic Taylor number for rotating magnetic fields. Give the ration of the Lorentz-force to the viscous forces. High Ta indicates a time dependent or turbulent flow. The actual critical Ta for the transition to time dependent flows depends on the aspect ratio of the sample.</td>
</tr>
<tr>
<td>$B_0$ = Magnetic induction at the wall</td>
<td></td>
<td></td>
</tr>
<tr>
<td>$R$ = sample radius</td>
<td></td>
<td></td>
</tr>
<tr>
<td>$s$ = electrical conductivity of the sample</td>
<td></td>
<td></td>
</tr>
<tr>
<td>$f$ = rotation frequency</td>
<td></td>
<td></td>
</tr>
<tr>
<td>$p$ = Number of pole pairs</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Hartmann number Ha</td>
<td>$Ha = B \frac{L \sqrt{s/(c_k \rho)}}$</td>
<td>Describes the effective strength of the magnetic induction not depending on the material used as sample. Used for static magnetic fields.</td>
</tr>
<tr>
<td>Materials Mode</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

46
Chapter 5. Simulation Mode: Settings

Simulations can only be computed when the furnace geometry is complete and materials were assigned to each region. CrysVUn will not allow you to leave Geometry Mode, if some points and lines have not been connected to regions.

You may change, however, from Materials Mode to Simulation Mode without having assigned materials to every region. But you have to return to Materials Mode and take care of the assignment. Otherwise you will not be able to start any computation.

Two items in the Settings menu are described in other sections, because they are closely related to Geometry respectively and Materials Mode:

- **Symmetry**
  The symmetry should be set immediately after the geometry was changed, because it has an impact on material properties, see Setting Symmetry (page 25).

- **Materials**
  The menu item Materials opens the Materials dialog for changing materials and their properties. For handling the Materials dialog see Materials Mode (page 26).

The remaining menu items of the Settings menu serve to determine the general setup for the simulation by defining:

- Labels and Joiner
- Grid
- Physical Phenomena
- Initial Values
- Boundaries
- Heaters
- Control points
- Moving Regions

All settings and parameters entered in the Settings menu dialogs will be saved together with geometry, materials and all computational parameters in the *.crys file.

**Warning**
Files saved in the Simulation Mode contain all data available for a furnace and should never be changed manually.

If you change a *.crys file, CrysVUn will not be able to run simulations from this file anymore.

Do not modify *.crys files manually.

5.1. Selecting Elements in Simulation Mode

Selecting lines and regions is required or desired for various settings and computation operations in Simulation Mode. It is done by using the mouse buttons, but in a different way as you do it in Geometry Mode.
5.1.1. Selecting lines and regions

1. Move the mouse pointer to the line or region which you want to select.

2. For selecting more than one line or region, press and hold CTRL key and simultaneously
   press the **middle mouse button** to select a line.
   or
   press the **left mouse button** to select a region.

The selected line(s) and region(s) will be displayed in different colors.

**Note**

In some dialogs you will find buttons for selecting all regions or all lines, because you cannot select them by drawing a rectangle with the **left mouse button** as in Geometry Mode.

**Related Procedures**

Mouse buttons (page262 )

5.1.2. Cancelling selection

There are two ways to cancel selections in Simulation Mode. Either you cancel the selection of a single element by clicking on it again with the appropriate mouse button.

Or you cancel all selections of one kind of element at once by clicking the relative mouse button clearly outside the furnace, far away from any line or surface.

- Press the **left mouse button** for cancelling the selection of all regions.
  or
  Press the **middle mouse button** for cancelling the selection of all lines.
  or

5.2. Labels and Joiner

For joining cartridges and furnace inserts two dialogs have been implemented:

- **Labels**
  Specific labels assigned in the **Labels** dialog are a prerequisite for joining cartridges and furnace inserts in SQF configurations, see Assigning labels (page48 ).

- **Joiner**
  In the **Joiner** dialog cartridges and furnace inserts to be joined are selected and joined to form the final simulation model, see Joining cartridge and furnace insert (page49 ). Because cartridge and furnace insert files are *.crys files, the **Joiner** dialog is available in Simulation Mode only.

5.2.1. Assigning labels

The **Labels** dialog is not specific to the joining process, but also used by other functions, e.g. to assign the property “sliding” to the contact line between a fixed region and a moving
region, see Moving Regions (page 66). The procedure for assigning the label is the same.

In a Solidification and Quenching Furnace (SQF) the Sample Cartridge Assembly (SCA) contains one or more regions constituting the Liquid Metal Ring (LMR), which must have a fixed position inside the furnace. In the Labels dialog you define the LMR by labelling the region(s) and a contact line between cartridge and Furnace Insert (FI).

1. Load the SQF sample cartridge assembly (SCA) *.crys file.
2. Select Settings > Labels.
   The Labels dialog opens:

   ![Figure 5.1. Labels Dialog](image)

3. Select all regions belonging to the LMR by pressing CTRL and left mouse button.
4. Type LMR in the input field for regions or select the same word from the keywords list.
5. Click on Apply and Close.
   or
   Click on OK to apply the changes and to close the dialog.
7. Load the SQF furnace insert *.crys file.
8. Select Settings > Labels.
9. Select the contact line by pressing the middle mouse button.
10. Type contact in the input field for lines.
11. Click on Apply and Close.
    or
    Click on OK to apply the changes and to close the dialog.
12. Select File > Save.

The files are ready to be joined, see Joining cartridge and furnace insert (page 49).

Note
The joiner for SCA and FI recognizes only the keywords “contact” and “LMR”. If other labels are used, the joining process will fail!

5.2.2. Joining cartridge and furnace insert
Only cartridges and furnace inserts of the same kind can be joined: LQF cartridge with
LQF furnace insert, SQF cartridge with SQF furnace insert and so on. CrysVUn checks dimensions and labels.

**Note**
Always observe the dimensions of the furnace inserts when changing the geometry of a cartridge. If the cartridge is too wide or too long, the joining will fail!

**Note**
The joining will also fail, if you did not save the file as *crys* file, after you changed the geometry and assigned materials to the regions changed.

The **Join** dialog has two sub-dialogs (tabs):

- **Join**
  Select and join Sample Cartridge Assembly (SCA) and Furnace Insert (FI) for the current simulation model.

- **Configure**
  Save cartridge and furnace insert configurations.

### 5.2.2.1. Joining SCA and FI

#### 5.2.2.1.1.
For the SCA geometry and materials must be defined and saved to a *crys* file.
For the FI geometry, materials, boundaries and heaters must be defined and saved to a *crys* file.

1. Select **File > Join**.
   The **Join** dialog opens:

   ![Figure 5.2. Join dialog](image)

   Cartridges listed in the configuration list are displayed in the left frame of the **Join** dialog. Furnace inserts listed in the configuration list can be chosen from the list box on top of the right side.

2. Select the cartridge and the furnace insert you want to join.
   or
Click on the Advanced check box to browse for cartridges and furnace inserts which have not yet been added to the configuration list, but should be joined for the current simulation. You have to choose both either by browsing or from the configuration list. Listed objects cannot be combined with browsing result.

3. The offset defines the initial position of the cartridge in the furnace for the current joining procedure.

   Change the Offset value, if necessary.

4. Specify the output file for the complete simulation model by typing the name or by browsing.

5. Click on Join.

If you activated the box preview files, you can follow the assembling of the final simulation model. First the cartridge will be displayed:

![LGF cartridge](image1)

*Figure 5.3. LGF cartridge*

When the joining is finished, the complete furnace will be displayed:

![Complete LGF furnace](image2)

*Figure 5.4. Complete LGF furnace*

Now the simulation model is available for computation.

Related Dialogs
5.2.2.2. Saving SCA and FI configurations

On the Configure tab in the Join dialog you assemble cartridges and furnace inserts available for combination. When you save these configurations, the entries will be listed on the Join tab.

To assemble the lists proceed as follows:

1. Select File > Join > Configure tab.

The Configure tab of the Join dialog opens:

![Configure tab of Join dialog](image)

2. The cartridge manager assists you in administering the cartridge list for the joiner.

Browse for the cartridge *.crys file and select it.

The file name will be displayed in the field file. If necessary, delete the path information.

3. Click on Add.

4. The Furnace insert manager assists you in administering the furnace insert list for the joiner.

Browse for the furnace insert *.crys file and select it.

5. Click on Add.

6. The default offset defines the initial position of the cartridge in the furnace, e.g. the distance between the top of the cartridge and the top of the insertion region of the furnace (contact). The joiner assumes that SCA and FI have the same symmetry axis.

Set or change the Default offset in the bottom of the dialog window.

7. Click on Save configuration to save both lists.

Both lists will be saved to the configuration file joiner.cfg in CrysVu's DATA directory and be available on the Join tab.

Related Dialogs

Configure tab (page201)
5.3. Grid Properties

*CrysVUn*’s computation is based on an unstructured grid consisting of irregular triangles inside each region. The quality of the simulation result depends on the appropriateness of the grid. Modifying the grid parameters can considerably improve the computation result.

Starting from these values *CrysVUn* will compute the unstructured grid:

<table>
<thead>
<tr>
<th>Grid parameter</th>
<th>Default value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Regions properties:</strong> Edge length (m)</td>
<td>0.1</td>
<td>Desired edge length inside a region.</td>
</tr>
<tr>
<td><strong>Regions properties:</strong> Fit slope</td>
<td>0.3</td>
<td>Maximum allowed gradient of the edge length inside a region. The fit slope defines how fast the mesh size will increase towards the middle of the region. Small fit slope means small meshes.</td>
</tr>
<tr>
<td><strong>Lines properties:</strong> Edge length (m)</td>
<td>0.1</td>
<td>Desired edge length along lines.</td>
</tr>
</tbody>
</table>

The influence of the fit slope is illustrated in Influence of fit slope on unstructured grid (page 53). The parameters for edge lengths of lines and regions are identical in both cases 0.01 (vertical lines) and region edge length = 0.05.

• A: Fit slope = 0.3
• B: Fit slope = 0.1
• A+B: Line edge length = 0.05 (horizontal lines), 0.01 (vertical lines)
• A+B: Region edge length = 0.05

*Figure 5.6. Influence of fit slope on unstructured grid*

If your furnace has many small regions, the grid may become unnecessarily fine in certain regions. To reduce the computing time, you select a line and click on the **respect edge length** button. The program is forced to respect the edge length of the line. The effect is illustrated in Respect edge length active for highlighted line (page 54) and in Respect edge length active for highlighted line (page 54).
5.3.1. Changing the Grid parameters

1. Click on the **Show/hide grid** button in the tool bar.

   If a grid was already computed, it will be displayed. The button is gray, if grid data are not yet available respectively were not saved after the last run.

2. Select **Settings > Grid**.

   The **Grid** dialog opens:

   ![Figure 5.9. Grid dialog](image)

3. If you do not select any line(s) or region(s) and change either of the three values, clicking on **Apply** or pressing the **Enter** key will change the default values and delete the existing grid completely.

   Select the line(s) or region(s) where you want to change the value respectively to compute a new grid.

4. Overwrite the value you want to change.

5. Click on **Apply** or press the **Enter** key to apply the changes and keep the dialog open.

   Depending on your selection you will observe the following effect on the existing grid:
   - If you selected one or more regions, the grid will be deleted in these regions.
   - If you selected one or more lines, the grid will be deleted in all neighboring regions.
6. After all changes have been made, close the Grid dialog by clicking OK or Close.

**Note**
Before any variable can be computed again, a new grid has to be generated. CrysVUn will take care of this in the computation process, but you can also generate the grid separately.

**Related Dialogs**
Grid (page 219)

### 5.3.2. Generating the Grid

1. Click on the Show/hide grid button in the tool bar.
   When a grid was computed, it will be displayed and so you can immediately see the effect of your setting.

2. If necessary, open the Grid dialog to change any of the grid parameters, see Changing the Grid parameters (page 54).

3. Select Computation > Generate Grid.
   The generated grid will be displayed in the drawing.

![Unstructured grid in the VHF furnace](image)

*Figure 5.10. Unstructured grid in the VHF furnace*

If you changed only parts of the furnace, this message will appear:

![Delete grid warning](image)

*Figure 5.11. Delete grid warning*

You can choose if you want to compute the whole grid again (Yes) or for the empty
regions only (No).

Note
The grid data will be saved with the complete *.crys file or with geometry only.

Note
By default no grid is generated in regions with materials named vacuum.

Related Procedures
Generating the grid (page120 )
Defining grid properties (page157 )

Related Dialogs
Grid (page219 )

5.4. Physical Phenomena
The most important variable is temperature. In addition, CrysVUn can compute a variety of variables. On the one hand certain variables require specific parameters to be set. On the other hand you do not want all variables available to be computed automatically. CrysVUn checks for variables and corresponding parameters and you can determine the degrees of freedom in the Physical Phenomena dialog, i.e. whether a variable group shall be solved or not.

<table>
<thead>
<tr>
<th>Category</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Yes</td>
<td>This variable group will be solved in the selected regions.</td>
</tr>
<tr>
<td>No</td>
<td>This variable group is eligible, but will not be solved in the selected region(s).</td>
</tr>
<tr>
<td>Unchanged</td>
<td>The status (yes/no) of the variables in this variable group remains unchanged for all regions selected.</td>
</tr>
</tbody>
</table>

Temperature is always computed and therefore it is set to yes by default in the Physical Phenomena dialog.
Phenomena dialog. All you have to do is to select the regions in the drawing or to click on the select all regions button, which will result in computing the overall temperature distribution.

The remaining variables are only computed, if the settings and parameters are appropriate and the Yes box is checked.

Note
It is not possible to compute variables, if settings and parameters are not correct. For instance, you cannot compute inductive heating for a furnace with resistance heaters. CrysVUn matches settings and parameters and offers only variables which can be solved. The remaining variables are gray and inactive.

Related Dialogs
Physical Phenomena (page219).

5.5. Initial Values
Before starting computation, CrysVUn needs an initial value inside the regions for all variables. There is a reasonable default value for each variable, but you can change it, if necessary. The initial value for temperature has to be specified, because it is necessary for every computation run. The default value for temperature is 300 K.

5.5.1. Changing initial values

1. Select Settings > Initial Values. The Initial Values dialog opens.

![Initial Values dialog](image)

Figure 5.13. Initial values dialog

2. Select region(s) with the left mouse button.
   or
   Click on select all regions button.

3. Initial values can be defined for the following variables:
Select the variable from the list box.

4. Write or overwrite the value displayed in the input field Initial value.

5. The default setting is that only the variable selected will be refreshed. But you can also choose to refresh all variables at once:
   If you want to refresh the values for all variables, click on the check box all variables.

6. Click on Apply or press the Enter key to apply the changes and keep the dialog open.
   or
   Click on OK to apply the changes and close the dialog.

Related Dialogs
Initial Values (page220)

5.6. Boundary Conditions
In this section boundary conditions for temperature are described. Other types of boundaries, in particular for convection, are explained in the respective tutorial sections, see Computing a Time-dependent Simulation (page147), Computing Pseudo-stationary and Time-dependent Convection (page156) and in the dialog Boundaries (page221).

5.6.1. Types of boundaries
CrysVUln will support you in specifying a boundary condition for each line and for each variable. In the Boundaries dialog you can choose between three types of boundary conditions: Dirichlet, Neumann and Poincaré. Boundaries can be displayed in the drawing.

Neumann boundary
The Neumann boundary specifies a constant flux density of the variable normal to the line, for temperature the heat flux density. You can specify an adiabatic boundary condition setting the flux = 0.

The flux density can be constant along the line or may have a dependency along the line. In the last case, it is a function f(l), where l is 0 at the start point and 1 at the end point of the line.

Dirichlet boundary
The Dirichlet boundary specifies fixed values for the variable along the line. The boundary will be displayed in the drawing as variable name (D = value). The Dirichlet boundary for temperature, for instance, is displayed as Temperature (D = 300).

Values which are not constant along the line can be defined in two ways:

• by a f(l) function (like for Neumann boundaries)
• by specifying the values along the line in a profile file (*.pro file).

The *.pro file has two rows divided into columns.
The first row specifies the number of points and their positions along the line. The position is the distance between the start point and the actual position in relation to the length of the line. This distance can adopt values between 0 and 1.
The first column of the second row is reserved for time-dependent computation and must contain the time values. In the remaining columns the values for the variable in each point are specified. CrysVuN will set values between these points by linear interpolation. The *.pro file shall not contain any additional comments.

<table>
<thead>
<tr>
<th>col 1</th>
<th>col 2 (point 1)</th>
<th>col 3 (point 2)</th>
<th>col 4 (point 3)</th>
</tr>
</thead>
<tbody>
<tr>
<td>3</td>
<td>0.2</td>
<td>0.5</td>
<td>0.7</td>
</tr>
<tr>
<td>0</td>
<td>300</td>
<td>350</td>
<td>370</td>
</tr>
</tbody>
</table>

If this boundary is specified for time-dependent computation, the *.pro file will have one line for each time step. The first column always contains the time value. The boundary values between the time steps will be automatically calculated by linear interpolation.

**Tip**
In the beginning the coordinates of the start point are usually not known. You can easily determine them by using the Monitor/Write Profile dialog, see Monitor/Write Profile (page 108). You select the boundary line and the coordinates of start and end points will be listed in the output file.

You can also see the direction of the boundary line pressing the show button for displaying the boundaries for the variable selected or the show all button for displaying the boundaries for all variables. Boundaries will be drawn in red, with an arrow indicating their direction.

**Poincaré boundary**
The Poincaré boundary specifies that the flux of a variable is proportional to the difference between the value of the variable on the line and a given reference value.

In case of temperature, the reference value is the temperature of the surrounding media \((\text{Ref Value} = f(l))\) and the proportional coefficient is called the heat transfer coefficient \((\text{Coeff} = f(x))\).

**Temperature dependent Poincaré and Dirichlet boundary**
The temperature dependent Poincaré and Dirichlet boundary types have the same behavior as their "normal" counterparts described in before. The major difference is, that the coefficients or values used in this types are functions of the temperature \(f(T)\) at the corresponding point on the region line.

Boundaries of this type are particularly useful for modeling evaporation or dissolution of a chemical species at a boundary of a fluid region. As these boundary types are redundant for the variable temperature, they cannot be set for this variable.
5.6.2. Defining boundaries

You set the boundary conditions in the **Boundaries** dialog.

1. **Open a *.crys file.**
2. **Select Settings > Boundaries.**

   The **Boundaries** dialog opens.

   ![Figure 5.16. Boundaries dialog](image)

   **Figure 5.16. Boundaries dialog**

3. **Before you can specify any boundary condition you have to select at least one line.**

   Select one or more lines with the **middle mouse button**.

   The line(s) will turn green in the drawing and the parameter input field will be displayed.

4. **Boundaries can be defined for the following variables:**

   ![Figure 5.17. List box options for Boundary dialog](image)

   **Figure 5.17. List box options for Boundary dialog**

   Select the variable you want to set the boundary condition for.

5. **Select the boundary you want to define.**

6. **If you check one of the boundary boxes, you have to enter a value in the input field or to specify a profile file, otherwise an error message will come up. In case of the Dirichlet boundary will be displayed:**

   ![Error rating Dirichlet boundary condition](image)
Figure 5.18. Boundaries error

Enter the value for the boundary in the input field.
or
Check Profile option and write the file name of the *.pro file into the input field and specify the start column.
or
Click on the Browse button to search for the *.pro file and specify the start column.

7. Click on the Apply button to set the boundary or press the Enter key.
8. Repeat steps 3 to 6 until boundaries are set for all variables required.
9. Click on the Close button to close the dialog.
or
Click on OK to apply the last changes and close the dialog.

Related Procedures
Defining boundaries (page149)

Related Dialogs
Boundaries (page221)

5.7. Heaters

CrysVUn can handle an arbitrary number of resistance heaters or induction heaters. The default is resistance heating and its power is specified in Watt (W). Induction heaters are defined by the intensity of the current through the coil in Ampère (A) and the frequency in Hertz (Hz).

For stationary and time-dependent simulations, the heaters have to be controlled in various ways and CrysVUn is even able to adapt the heating power in inverse simulations.

5.7.1. Defining a heater

You define heaters by selecting regions in the drawing and specifying settings current in the Heaters dialog. One heater can have more than one region, but each region can belong only to one heater. If a heater consists of more than one region, each region only emits a fraction of the total heating power of that heater. By default CrysVUn splits the heating power equally between all regions of one heater, but you can also specify different fractions for one heater. However, the sum of all fractions must be 1. If not, the following message will be displayed:

Figure 5.19. Heater fractions message

You have to adjust the fractions, before you are able to continue.

Note
If the region for the new heater does not yet exist, you need to draw it in Geometry Mode first.

1. Open a *.crys file, e.g. VGF_prototype.crys.
   The geometry will be displayed by default.

   ![Figure 5.20. Basic screen of resistance heater (Simulation Mode)](image)

2. Select Settings > Heaters.
   The Heaters dialog opens.

   ![Figure 5.21. Heaters dialog](image)

3. The right side of the furnace shall be completely visible and not covered by the Heaters dialog window, because you have to select at least one region for defining a heater.

   You can select more than one region for a heater by pressing and holding the Control key during selection with the left mouse button.

   Select the region(s) for the new heater with a click of the left mouse button.

   The region is highlighted in green.

   A heater noname is added to the heaters' list in the Heaters frame on the left.
The number of the region accompanied by the property “Heater” is added in the **Regions of heater** frame on top of the right.

4. The default heater name is “noname” and displayed in the field **Name** below the heaters’ list. If you change it, do not use blanks in the new name. Overtype **noname** in the field **Name** and click on **Apply** or press the **Enter** key. The new heater name appears in the list, but the heater is not yet defined. As soon as you cancel the selection in the drawing or select an already defined heater, the new heater will vanish from the list.

5. If the heater consists of more than one region, and you want to change the fraction proportions:
   Select the region, and type the new value in the input field **Fraction**.

6. Click on the **Resistance** or the **Induction** check box; in case of induction, specify the frequency.

7. You can choose between four heater settings:

<table>
<thead>
<tr>
<th>Heater setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fixed power</td>
<td>Heating power is set by the user and remains constant during computation.</td>
</tr>
<tr>
<td>Power profile</td>
<td>User defines time-dependent heating power values in table form (*.pro file).</td>
</tr>
<tr>
<td>Controlled power</td>
<td>Power will be computed by CrysVUn in an inverse simulation; minimum and maximum have to be specified; the initial value will be replaced automatically after computation.</td>
</tr>
<tr>
<td>Controlled profile</td>
<td>Power will be computed by CrysVUn in a time-dependent computation; minimum and maximum have to be specified.</td>
</tr>
</tbody>
</table>

Select the type of heater settings.

8. Depending on the type of heater setting:
   Type the value in the input field for **Fixed power**.
   or
   Specify the *.pro file for **Power profile**.
   or
   Specify the initial, minimum and maximum values for **Controlled power**.
   or
   Specify the *.pro file and minimum/maximum values for **Controlled profile**.

9. Click on **Apply** or press **Enter** to apply the changes, and click on **Close** to close the dialog.
   or
   Click on **OK** to apply the changes, and close the dialog.
Related Procedures
   Defining heaters (page 141)
   Defining heaters in time-dependent computation (page 150)

Related Dialogs
   Heaters (page 223)

5.7.2. Deleting heaters and regions
   Both actions are very simple, because the dialog provides buttons for these tasks.

   1. Select Settings > Heaters.
   2. Select the heater or region you want to delete.
       The selected heater will appear in the Name field, the selected region will just be
       highlighted in the list.
   3. Click on the delete heater button to delete the selected heater.
       or
       Click on the delete region button to delete the selected region.
   4. Click on Apply or press Enter to apply the changes, and click on Close to close the
       dialog.
       or
       Click on OK to apply the changes and to close the dialog.

5.7.3. Modifying heaters' properties
   The process for modification is similar to adding a heater. The difference is that you do not
   select a new region, but a region which is already a heater.

   1. Select Settings > Heaters.
   2. Select the heater respectively the region you want to change.
       The selected heater will appear in the Name field.
   3. You may change fractions of regions, the type of heater setting or the values.
   4. Click on Apply or press Enter to apply the changes, and click on Close to close the
       dialog.
       or
       Click on OK to apply the changes and to close the dialog.

5.8. Control Points for Inverse Simulation
   Inverse simulation determines which heating power you need to achieve given tempera-
   tures at given control points. Control points can only be defined for temperature.
   For inverse simulation you need to define:
• Heaters of the setting type **Controlled power** for which CrysVUn has to compute the heating powers, see Defining a heater (page 61).

• **Control points** defining which temperature should be reached at certain points inside the furnace

In the **Control Points** dialog you define the coordinates, or you specify a *.pro* file containing the coordinates of control points.

**5.8.1. Defining control points**

1. Select **Settings > Control Points**.

   The **Control Points** dialog opens.

   ![Control Points dialog](image)

   *Figure 5.22. Control Points dialog*

2. Specify the point coordinates in the input fields \( r \) and \( z \).

   or

   Specify the *.pro* file containing the coordinates.

3. Check whether the position of the control point is **Absolute** or **Relative** and, if relative, specify the reference \( r \)- and \( z \)-coordinates.

4. If **Relative** is checked for coordinates, it will also be applied to temperature! Specify the value for temperature at that point.

5. Click on **Add**, if the control point is new.

   or

   Click on **Change**, if you changed a control point.

6. Click on **Apply** or press **Enter** to apply the changes, and click on **Close** to close the dialog.

   or

   Click on **OK** to apply the changes and to close the dialog.

   The control point is displayed as red cross in the drawing. You can control the position of any control point by selecting it.

   **Note**
If the specified control point is not identical to a grid point, CrysVUn will choose the closest grid point (indicated by an arrow).

**Related Procedures**
Defining control points (page 142)

**Related Dialogs**
Control Points (page 225)

5.8.2. Deleting a control point

1. Select **Settings > Control Points**.
   The **Control Points** dialog opens.

2. Select the control point you want to delete using the **left mouse button**.
   The coordinates of the selected control point are displayed in the r and z fields, and the point is shown in the geometry.

3. Click on **Delete**.
   The control point vanishes from the list and in the geometry.

5.9. Moving Regions
Moving regions usually belong to the sample cartridge assembly (SCA) and require time-dependent computation (full implicit time model). You specify either constant velocities in radial (r) or axial (z) direction or you specify a file containing time-dependent position or velocity profiles. The file must be a text file with the extension 

\[*.mov\]

and has to correspond to the following format:

<table>
<thead>
<tr>
<th>Time (col. 1)</th>
<th>r-coordinate (col. 2)</th>
<th>z-coordinate (col. 3)</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0.</td>
<td>0.</td>
</tr>
<tr>
<td>100</td>
<td>0.</td>
<td>0.</td>
</tr>
<tr>
<td>500</td>
<td>0.</td>
<td>0.5</td>
</tr>
<tr>
<td>1000</td>
<td>0.</td>
<td>0.5</td>
</tr>
</tbody>
</table>

In this example the region will not move at all in the interval from 0 to 100 seconds. Then the region will move 5 cm in z-direction within the next 400 seconds and remain in this position until 1000 seconds have elapsed.

The program will take the information about the position from columns 2 and 3 for the first moving region. In the dialog you only specify the column of the r-coordinate, the program takes the next column automatically as z-coordinate. If you want to specify time profiles for more than one moving region in the profile file, you add column 4 and 5 for the second moving region, 6 and 7 for the third and so on.

If you want to specify time-dependent velocity profiles, the \[*.mov\] file has a similar format, but instead of coordinates you have to write the values of r and z-velocity.

The following prerequisites should be considered when working with moving regions:

- A moving region shall not intersect a line of a fixed region or collide with other parts of the geometry.
• By default, monitor points in moving regions stay in their original position. However, if you check the **moving** button in the **Monitor/Write Profile** dialog, they move together with the region. You will be able to monitor the temperature at this point moving through the furnace.

• Do not define more moving regions than necessary. For instance, if you have a sample mounted on a rod which is moving through the furnace, only assign the sample as moving region. The rod will automatically be detected as a distorting region. If the distorting region has a non-zero velocity component perpendicular to an outer boundary, also convective heat fluxes resulting from the movement will be taken into account.

• Fixed regions adjoining a moving region (e.g. floating sealing) will be distorted (distorting region), because their form is adjusted at every time step in order to stay connected with their neighbors. Usually this distortion can be neglected, because only the result for the moving region is of interest. The changing shape of the fixed region (shortening or elongating, depending on the direction of movement) does not have any impact on the results for the moving regions. The following figure illustrates this fact:

![Figure 5.23. Distortion effect in moving regions](image)

• Moving region
  • Fixed region
  • Fixed region, to be re-meshed

• If a moving region is enclosed in a radiation cavity, the view factors of this cluster will be recomputed at every time step. The contact line between a fixed region and a moving region can be labeled as “sliding”, see Assigning labels (page 48). The moving region will slide along the fixed region and the fixed region will not be distorted.

• The line upstream on the moving region must not have any intersections nor lose contact to the sliding line:
5.9.1. Defining a moving region

1. Select Computation > TimeModel.
2. Select time model Full implicit from the list box and specify the relevant parameters.
3. Select Settings > Moving Regions.
   The Moving Regions dialog opens:

   ![Moving Regions dialog](image)

   Figure 5.25. Moving regions dialog

4. If you want to define different velocities for the moving regions, you have to select the regions one after the other.
   Select the moving region(s) in the geometry. For selecting more than one region keep the CTRL key pressed.
The number of the selected region(s) is displayed in the dialog window.

5. Select the moving type.
   You can either specify a constant velocity for the selected regions or provide a profile file containing the position or velocity time-dependence, see Moving Regions (page 66).
   Specify the values for constant velocities in r- and/or z-direction in the respective input fields.
   or
   Specify the *.mov file containing time-dependent velocity (in case of Variable velocity option) or regions displacement (in case of Position profile option), and enter the column of the r-velocity or r-coordinate.

6. Click on Apply.

7. Click on select all moving regions to verify your changes.

8. Close the dialog by clicking on Close or OK.

Related Procedures
   Defining a moving region (page154 )

Related Dialogs
   Moving Regions (page226 )
Chapter 6. Simulation Mode: Computation

In the Computation menu you choose the time model and define controlling parameters for the computation process. Furthermore you can follow the computation process by displaying the solver information and you define points and lines for the monitoring output in time-dependent computation. Finally, you can initiate the actual computation of the grid, the view factors and the simulation run by selecting the respective menu items.

parameters set in the Computation menu dialogs will be saved to a *.crys file together with all other data available for a furnace.

Warning

Files saved in the Simulation Mode contain all data available for a furnace and should never be changed manually.

If you modify a *.crys file manually, CrysVUn will not be able to run simulations from this file anymore.

Do not modify *.crys files manually!

6.1. Time Model Choice

CrysVUn can compute pseudo-stationary as well as time-dependent simulations. If you want to change the time model, open the Time Model dialog. The pseudo-stationary time model is the default. Here, you can compute a stationary state. Since you are able to compute the release of latent heat during solidification or the translation of heat flux this model is not called stationary, but pseudo-stationary.

However, if you switch to the full implicit time model, you need to specify the relevant parameters such as start time, end time, number of time steps etc. The variables are computed at every time step between start time and end time.

6.1.1. Selecting the full implicit time model

1. Select Computation > Time Model.

   The Time Model dialog opens. If you already had a time-dependent simulation, the input fields will be white and you can change parameters. If your model was pseudo-stationary, all input fields are gray.

2. Select Full implicit in the list box on top of the Time Model dialog window.

   The input fields in the Time Model dialog window turn white.

   ![Figure 6.1. Time Model dialog](image)
3. You have to specify **Start time**, **Stop time** and the length of the **Time step**. The time step is increased by the incremental factor, if the last time step was finished in less than the "max. iterations", decreased if more iterations were necessary, otherwise left unchanged. The rate of in- or decreasing is changed by the incremental and decremental factors.

Type the values in the input fields or overwrite the default values, if necessary.

4. Click on **Apply** or press the **Enter** key to apply the changes and keep the dialog open.

5. After all changes have been made, close the **Time Model** dialog by clicking **OK** or **Close**.

The time-dependent information will be used for profile and monitoring operations.

**Note**

In any time-dependent computation the growth rate must be set to 0 in the **Process parameters** dialog.

### 6.2. Setting Process parameters

Selecting the menu item **Process parameters** enables you to specify general process parameters for heat transfer by conduction or process parameters for magnetic fields for heat transfer by radiation.

Parameters for magnetic fields are relevant for computing Lorentz forces. Depending on the type of magnetic field, you need to set specific parameters in the **Process parameters** dialog and to check different items in the **Physical Phenomena** dialog.

**CrysVUn** can handle different types of magnetic fields, time-dependent and stationary ones:

- Rotating fields
- Alternating fields
- Travelling fields
- Stationary fields

#### 6.2.1. General process parameters

Under specific circumstances modifying the general process parameters is necessary, e.g. for computing latent heat of materials or for experiments in space.

**Growth rate**

You need to specify the estimated growth rate of the crystal for pseudo-stationary computations. The growth rate has to be specified in m/s. The growth rate has to be positive, if the interface between the solid and the liquid phase is moving upwards in positive z-direction as in VGF furnaces. The growth rate has to be negative, if the interface is moving down in negative z-direction as in Czochralski furnaces.

**Note**

In time-dependent computation the growth rate must be set to 0.

**Gas pressure**
The gas pressure (N/s²) has to be specified for computing convection, if the ideal gas model has been chosen.

**Gravity**

Default is the gravity of the earth (9.81 m/s²). This value is used to compute buoyancy forces for convection.

**Crystal rotation**

The frequency (Hz) of the crystal rotation is an important parameter for the simulation model.

**Translation heat flux**

The additional heat flux due to the movement of the crystal is included as a quasi-steady approximation in the temperature computation.

### 6.2.2. Process parameters: Rotating magnetic field

For rotating magnetic fields the checkbox RMF in the **Electrical Potential** dialog has to be chosen, and the following parameters have to be specified:

- Number of **Pole pairs**
- **Magnetic induction** (T)
- **Sample radius** (m)
- Rotating **frequency** (Hz) of the external magnetic field

Now you can compute the Lorentz forces:

1. Select the region in the furnace.
2. Check the **Electrical Potential** box in the **Physical Phenomena** dialog.
3. Start computation by selecting **Computation > Start Computation** or by clicking on 

   For actually computing the Lorentz forces, you need to check the **Lorentz Forces** box in the **Physical Phenomena** dialog.

![Figure 6.2. Physical Phenomena dialog: Lorentz forces](image)
6.2.3. Process parameters: Alternating magnetic fields

Alternating magnetic fields are defined only by the parameters for inductive heating. No other parameters need to be specified.

The Lorentz forces are computed as post-process after the vector potential was solved by checking the Inductive Heating box in the Physical Phenomena dialog.

Now you are ready to compute the Lorentz forces:

1. Select the region in the furnace.
2. Check the Lorentz Forces box in the Physical Phenomena dialog.
3. Start computation by selecting Computation > Start Computation or by clicking on .

When you start the convection computation, the Lorentz forces are taken into account.

6.2.4. Process parameters: Travelling magnetic fields

Two different models for travelling magnetic fields are available: The continuous model and the discrete model, both require different sets of parameters. You find a detailed description of these models in Maria Iuga's study on the influence of travelling magnetic fields on melt convection, see Bibliography (page 277).

6.2.4.1. Setting parameters for the continuous model

The following parameters are to be specified:

- **AC frequency (Hz)**
- **Travelling wavelength (m)**
- **Magnetic induction (T)**

If you want to change the direction of the travelling field, you simply change the sign:

- Positive value: The field travels upwards
• Negative value: The field travels down

![Figure 6.4. Travelling magnetic fields: Continuous model parameters](image)

Now you are ready to compute the Lorentz forces:

1. Enter the relevant parameters in the **Process parameters** dialog.
2. Select the region in the furnace.
3. Check the **Lorentz Forces** box in the **Physical Phenomena** dialog.
4. Start computation by selecting **Computation > Start Computation** or by clicking on **[ ]**.

### 6.2.4.2. Setting parameters for the discrete model

The discrete model assumes three single coils for generating the magnetic field. The following parameters are to be specified:

- **AC frequency (Hz)**
- **Coil radius (m)**: Must be greater than the radius of the melt
- **Cylinder height (m)**: Distance between the first and the last coil
- **Current intensity (A)**: Intensity of the current in the coils
- **Phase shift (rad)**: The phase shift between two neighboring coils

If you want to change the direction of the travelling field, you simply change the sign of the phase shift:

- Positive value: The field travels upwards
- Negative value: The field travels down
Now you are ready to compute the Lorentz forces:

1. Enter the relevant parameters in the **Process parameters** dialog.
2. Select the region in the furnace.
3. Check the **Lorentz Forces** box in the **Physical Phenomena** dialog.
4. Start computation by selecting **Computation > Start Computation** or by clicking on ![](image)

### 6.2.5. Process parameters: Stationary magnetic field

For stationary magnetic fields the checkbox Stationary Fields in the **Electrical Potential** dialog has to be chosen, and the following parameters have to be specified:

- **Magnetic induction (T)**
- **Sample radius (m)**
- **Model** (MHD1 or MHD2)
- **Configuration** (axial or CUSP field)
- **Cusp Origin** (Offset of the CUSP origin from the CrysVUn coordinate system)

Now you can compute the Lorentz forces:

1. Select the region in the furnace.
2. Check the **Electrical Potential** box in the **Physical Phenomena** dialog.
3. Start computation by selecting **Computation > Start Computation** or by clicking on ![](image)

For actually computing the Lorentz forces, you need to check the **Lorentz Forces** box in the **Physical Phenomena** dialog.
6.3. Setting Numerical parameters

The **Numerical parameters** dialog provides 5 sections (tabs) for controlling the mathematical solving process:

- **View factors**
- **Forward**
- **Inverse**
- **Species**
- **Stress**

Radiation is implemented in *CrysVuIn* by so called view factors. The quality of the view factors is important for the quality of the computation result: If there are artificial heat sources or sinks due to inaccurate view factors, increase the view factor precision (i.e. decrease the value specified). View factors are always calculated before temperature, either in an independent run or automatically in the same computation run as temperature.

**Linear system equations solvers**

The numerical parameters determine the way the linear system equations are solved by *CrysVuIn*.

*CrysVuIn* uses several linear system equations solvers. The user can optionally select which of them to be used in simulation.

Iterative solvers:

- **BiCG**: Biconjugate gradient iteration.
- **STABBiCG**: Biconjugate gradient iteration stabilized.
- **CGS**: Conjugate gradient squared iteration.
- **IR**: Richardson iteration.
Direct solver:

- **GSSV**

Two pre-conditioners can be used for an iterative solver:

- **DIAG**
- **ILU** (default)

**Note**
A default solver is selected for any type of computation and you should only change it if you want to evaluate the computational time.

### 6.3.1. View factors

*CrysVUn* can handle heat transfer by radiation in perfectly transparent media and for media which show certain transparency windows in a given wavelength domain (Visibility Bands). The physical model used by *CrysVUn* is that of the gray body radiation: Surfaces of a cavity are emitting a hemispherical flux proportional to $\sigma T^4$ and proportionality coefficient $\varepsilon$ is called emissivity.

The numerical approach used in *CrysVUn* is that of the view factors. The view factor is defined between two elements of the cavities’ surface. If $i$ and $j$ are two such elements, the view factor from $i$ to $j$, $F_{ji}$, represents the fraction of the energy that leaves element $i$ and arrives to $j$ if the assumption of black body radiation. For the gray body, the $\Gamma$ matrix is of interest. It is defined in the following way:

$$q_{net} = \Gamma \cdot q^{em}$$

*Figure 6.7.*

$q_{net} = \Gamma \cdot q^{em}$ is thereby the difference between absorbed and emitted energy at surface element $i$. $\Gamma$ can be directly computed from the view factors and the emissivities. $q_{net}$ is taken as a heating source density.

The energy leaving element $i$ must arrive at the other elements without loss, therefore the view factors have the following property:

$$\sum_j F_{ji} = 1$$

*Figure 6.8.*

In the numerical treatment this sum does not exactly equal 1 and the energy inside the furnace is not conserved completely. *CrysVUn* provides a renormation function for the $\Gamma$ matrix on the View factors tab of the Numerical parameters dialog.

**Note**
View factors have to be recomputed, if geometry or emissivity were changed. In either case *CrysVUn* computes them automatically.

### 6.3.1.1. Setting view factor parameters

On the View factors tab in the Numerical parameters dialog you determine the precision
of the view factors and the threshold for the Gebhardt matrix.

1. Select **Computation > Numerical parameters**. The dialog will open with the **View factors** tab active:

   ![View factors tab in Numerical parameters dialog](image)

   *Figure 6.9. View factors tab in Numerical parameters dialog*

2. Change the default values only, if necessary, because they usually produce a reasonable result.
   Overwrite the precision value, if appropriate.

3. If the threshold for Gebhardt matrix is > 0, only Gebhardt factors above a certain value are taken into account. For more information on the Gebhardt matrix see the PhD thesis by M. Kurz 1998, p. 71.
   Overwrite the threshold value.

4. Click on **Apply** to apply the changes, but leave the dialog open.

5. Select **Computation > Compute View Factors**.

6. Wait until the computation is finished and then:
   Select **Computation > Show Solver Information > Rowsums**.
   The view factor graph, the rowsum minimum (recommended: 0.98) and the rowsum maximum (recommended: 1.02) will be displayed.
   In the following example the view factors should be improved:

   ![Row sums of view factors](image)

   *Figure 6.10. Row sums of view factors*
The view factors are satisfying, if the difference between minimum and maximum is acceptable for you. Based on our experience we suggest to accept deviations which are smaller than 10 K.

7. **Warning**

Renormation is not reversible. You can renorm the $\Gamma$ matrix only once!

As soon as you checked the renormation button, it will be inactive forever!

Be definitely sure that the quality of the view factors is sufficient, before you check the renormation button.

Go back to the view factors tab in the Numerical parameters dialog and check the Renormation box.

The Gebhardt matrix will be renormed and this file can be used as input file for future computations based on this grid.

**Related Dialogs**

View factors (page234)

**6.3.1.2. Testing the view factor quality**

This test is based on the maximum temperature in the furnace, e.g. 1500 K. No heaters should be defined.

1. If heaters are defined, you have to delete them first or set existing heaters to a fixed power of 0 Watt.:
   - Select Settings > Heaters to open the Heaters dialog.

2. Delete one heater after the other by selecting it and clicking on delete heater.
   - or
   - Set the power of all heaters to a fixed power of 0 Watt.

3. Click on Apply and Close.
   - or
   - Click on OK to apply the changes and to close the dialog.

4. Select all furnace boundary lines by pressing and holding the CTRL key and clicking the middle mouse button.

5. Select Settings > Boundaries.

6. Select variable Temperature.

7. Check the Dirichlet boundary check box.

8. Type 1500 (respectively the maximum temperature in the furnace) in the Value input field.

9. Click on Apply and Close.
   - or
   - Click on OK to apply the changes and to close the dialog.

10. Select Computation > Start Computation.
or
Click on \( \text{ } \) in the tool bar.

You can follow the computation of the view factors, if not yet done and the solving process for the variable \textbf{Temperature} in the right corner of the status bar and in the terminal window.

11. In theory, the temperature field should be uniformly at 1500 K. In practice there will be some deviations from this temperature. The minimum and maximum values for temperature can be examined by checking the isolines:

Select \textbf{Visualization > Options for Scalar fields} to examine.

If the deviation between minimum and maximum value is 10 K or less, the view factors are good.

6.3.2. Setting parameters for forward simulation

On the \textbf{Forward} tab you can select the solver for the forward simulation and specify the parameters for the solving process.

A detailed description of parameters is given in Forward (page235) section.

1. Select \textbf{Computation > Numerical parameter > Forward} tab.

The \textbf{Forward} dialog opens:

![Forward tab in Numerical parameters dialog](image)

Figure 6.11. Forward tab in Numerical parameters dialog

2. The default values were gained from experience and produce satisfactory results. Change the defaults only if inevitable.

If necessary change the defaults for the forward solver, the preconditioner, the numbers of allowed inner and outer iterations, the desired residuum, the residuum improvement factor and the forward relaxation factor.

3. Click on \textbf{Apply} and \textbf{Close}.

or
Click on \textbf{OK} to apply the changes and to close the dialog.
In the Other section some special parameters can be set by the user:

- **Track interface:**
  
  If this option is activated, the grid will be adjusted to the phase boundary in a two phase material when calculating temperature. The vertices next to the phase boundary are moved in order to match with the melting isothermal with a given accuracy. This approach is analogous to the interface tracking in case of multiphase convection calculations. The parameters for the interface tracking can be found in the multiphase tab of convection parameters menu. See Multiphase (page 242) for information of the parameters to set.

  This option is only needed if the Write interface option is used or point defects calculation shall be performed. There is no influence on the behavior of the interface tracking for convection or stress calculations by this checkbox.

  Related tasks: Setting multiphase parameters (page 85)

- **Point defects ramp:**
  
  Turns on the coupling between interstitial and vacancy concentration smoothly in order to improve the numerical stability. This option can be used if convergence problems during point defect calculations occur.

**Related Dialogs**

Forward (page 235)

### 6.3.3. Setting parameters for inverse simulation

On the Inverse tab you select the solver for the inverse simulation and specify the parameters for the solving process. Before computing inverse simulation you need to define controlled power heaters, see Heaters (page 61), and control points, see Control Points for Inverse Simulation (page 64).

A detailed description of parameters is given in Inverse (page 237) section.

1. Select Computation > Numerical parameter > Inverse tab.

   The Inverse dialog opens:

   ![Inverse tab in Numerical parameters dialog](image)

   **Figure 6.12. Inverse tab in Numerical parameters dialog**

2. The default values were gained from experience and produce satisfactory results. Change the defaults only if inevitable.
If necessary, change the inverse solver, the preconditioner, the parameters, the controller and the conditions for updating the sensitivity matrix.

3. Click on **Apply** and **Close**.
   or
   Click on **OK** to apply the changes and to close the dialog.

**Related Procedures**
- Running an Inverse Simulation (page 140)

**Related Dialogs**
- Inverse (page 237)

**6.3.4. Setting parameters for species transport simulation.**

In the **Species** tab the parameters and discretization schema for species transport are set.

It is possible to define a reference concentration for the Boissinesq-approximation the solutal bouancy term in the Navier-Stokes equations. By default this value is 0. In the most cases this is convenient. Only changes this value if you no what you are doing.

In **CrysVUn** two alternative discretization schema are available for species transport: A central schema and a up-winding technique with deferred correction. For details of the used numerical methods please refer to the text book J.H. Ferziger and M. Peric: "Computational methods for fluid dynamics", Springer, 1999 (ISBN 3-540-42074-6) or in the PHD-thesis of M.Hainke (reference given in the **Bibliography** (page 277)). The usage of the parameters is described in the following table:

<table>
<thead>
<tr>
<th>Parameters</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>upwinding (donor cell)</td>
<td>If the discretization schema is switched to upwinding, this stable but less accurate (discretization-error of first order) technique is used. This is the recommended setting for convection dominated problems with high solutal pectlet numbers (Pe&gt;10). Use this setting whenever unphysical fluctuations in the species field occur during the calculation of the convective/diffusive transport. In order to improve accuracy for moderate solute Peclet numbers the solution obtained with the upwinding schema can be combined with the one of central difference technique (see below). The weight factor is given by the parameter <strong>Deferred correction</strong>.</td>
</tr>
<tr>
<td>central schema</td>
<td>The central schema is more accurate alternative (discretization-error of second order) but suffers from stability problems in convection dominated flows (Pe &gt;10). If unphysical fluctuations occur during calculations, there are two possibilities: Refine the grid or switch to the upwinding schema (details described above). If central differences are used the parameter <strong>Deferred correction</strong> is ignored.</td>
</tr>
<tr>
<td>Deferred correction</td>
<td>This represents the weight factor for combining the central difference and the upwinding solution. 0 corresponds to the full-upwind solution while 1 is equivalent to switch to the central schema with radio bottom. Please note: Not only the accuracy is improved with the a</td>
</tr>
<tr>
<td>Parameters</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>-------------</td>
</tr>
<tr>
<td>growing fraction of the central difference solution in the results, but also the susceptibility to instabilities is increased.</td>
<td></td>
</tr>
</tbody>
</table>

1. Select **Computation > Numerical parameter > Species** tab.

   The *Species* dialog opens:

   ![Species tab in Numerical parameters dialog](image)

   *Figure 6.13. Species tab in Numerical parameters dialog*

2. The default values were gained from experience and produce satisfactory results. Change the defaults only if inevitable.

   If necessary, change the discretization schema, deferred correction parameter etc..

3. Click on **Apply** and **Close**.

   or

   Click on **OK** to apply the changes and to close the dialog.

**Related Procedures**

Specifying settings and parameters for computing concentration (page 183)

**Related Dialogs**

Species (page 239)

**6.3.5. Setting stress parameters**

1. Select **Computation > Numerical parameter > Stress** tab.
2. The default values were gained from experience and produce satisfactory results. Change the defaults only if inevitable. If necessary, change the desired residuum.

3. Click on Apply and Close.

Related Dialogs
Stress (page240 )

6.4. Setting Convection parameters

The parameters for computing convection are set in the Convection parameters dialog. Computing convection can be very time-consuming and these parameters help to minimize computation time by providing the opportunity to define abortion criteria, updating intervals, ramps and solvers.

6.4.1. Setting abortion parameters

The parameters in this window give some control over the strategy to be used when solving buoyancy driven convection. Buoyancy driven convection is the default, but you can turn it off by clicking on the box in front of with buoyancy.

The defaults were gained from experience and should only be changed, if necessary. In practice, the only parameters frequently adapted are the underrelaxation velocity factors.

1. Select Computation \textgreater{} Convection parameters.

The Convection parameters dialog opens with the Abortion tab:
2. The **Inner iteration limits** define the solving process: First the equations for pressure and momentum are solved and as soon as the momentum norm has reached the value specified in Momentum 1, the temperature equation is solved. When the result is close to **Temperature 1**, the next iteration will be started. The number of iteration loops is limited to 5.

Set the convergence criteria **Momentum 1** and **Temperature 1**.

3. The computation will stop in two cases: Either both final values, **Momentum 2** and **Temperature 2**, are reached or the solution does not change anymore (**max. solution change**), although the values for momentum and temperature have not been reached.

Set the criteria for stopping the computation.

4. You should specify a linear dependency of the underrelaxation factors for the velocity equation.

Example: **inc. from 0.1 to 0.75 between 1 and 0.01** will result in an underrelaxation factor of 0.1 (0.75), if the residuum is higher (lower) than 1 (0.01), and in a linearly increasing factor from 0.1 to 0.75 between 1 and 0.01.

For constant underrelaxation factors set upper and lower limits to the same value.

Set the **Underrelaxation velocity factors**.

5. Click on **Apply** and **Close**.

or

Click on **OK** to apply the changes and to close the dialog.

**Related Dialogs**

Abortion (page 241)

### 6.4.2. Setting multiphase parameters

When convection is computed, the interface between solid and liquid phase of the sample moves and the shape of the interface changes. On the **Multiphase** tab of the **Convection parameters** dialog you can specify, when the interface shall be updated and the grid should be tracked to the interface.
1. Select **Computation > Convection parameters**.

   The **Convection parameters** dialog opens.

2. Click on the **Multiphase** tab.

   The **Multiphase** tab in the **Convection parameters** dialog opens:

   ![Figure 6.16. Multiphase tab in the Convection parameters dialog](image)

3. The values specified in **Momentum** (accuracy of impulse equation solution) and **Temperature** (accuracy of temperature equation) determine, when the interface will be adjusted:

   - Set the values for adjusting the interface.

4. Further interface updates are only done, if the difference between melt and interface is smaller than the value for **Max. difference from melting point**. Controller steps are only done, if the criteria for updating the interface are also fulfilled in order to keep the interface position synchronized. The smaller the value, the higher the conformity between melt and interface.

   - Set the **Max. difference from melting point**.

5. Click on **Apply** and **Close**.

   or

   - Click on **OK** to apply the changes and to close the dialog.

**Related Dialogs**

- Multiphase (page242)

**6.4.3. Setting ramp parameters**

Ramps allow a successive approximation to real material property values, if you start from scratch and do not want to change the properties in the **Materials** dialog. You can specify ramps for density, heat capacity and viscosity for an incremental variation of these material properties in pseudo-stationary computation. Usually, the viscosity value is increased in the beginning and then it is gradually reduced. Ramps for density and heat capacity start with a low value and are gradually increased. Again you define convergence criteria to determine when ramp steps shall be performed.
1. Select **Computation > Convection parameters**. The **Convection parameters** dialog opens.

2. Click on the **Ramps** tab. The **Ramps** tab in the **Convection parameters** dialog opens:

![Figure 6.17. Ramps tab in Convection parameter dialog](image)

3. Activate the ramp(s) you want to run by clicking on the box in front of the respective ramp.

4. Set the start factors for density, capacity, and viscosity as well as the multiplying factor.

5. Ramp steps are performed, when the results are lower than the convergence criteria specified here:
   - Set the convergence criteria for **Momentum** and **Temperature**.

6. Click on **Apply** and **Close**.
   - or
   - Click on **OK** to apply the changes and to close the dialog.

**Related Procedures**

- Setting convection parameters (page 159)

**Related Dialogs**

- Ramps (page 242)

**6.4.4. Selecting solvers**

*CrysVU*n makes simulations by repeated solution of linear equation systems. For velocity and pressure equations, the same solvers as for forward and inverse simulation are available, see Forward (page 235) and Inverse (page 237).

Default solvers should not be changed, because, by experience, they produce satisfactory results. You may, however, change the parameters for pressure and velocity.
1. Select **Computation > Convection parameters**. The **Convection parameters** dialog opens.

2. Click on the **Solver** tab. The **Solver** tab in the **Convection parameters** dialog opens:

![Figure 6.18. Solver tab in the Convection parameters dialog](image)

3. The velocity solver default is the STABBiCG, the same iterative solver as for forward simulation. The pressure solver default is the direct solver GSSV, the same as for inverse simulation.

   Change the default solvers and preconditioners for velocity and pressure, if necessary.

4. Set the convergence criteria **Max. inner iterations** and **Desired residuum**, if desired.

5. Click on **Apply** and **Close**.

   or

   Click on **OK** to apply the changes and to close the dialog.

**Related Dialogs**

Solvers (page243)

**6.4.5. Setting turbulent convection parameters**

Special numerical parameters are required by computation of turbulent gas convection. They influence the solving of k-ε model equations.

1. Select **Computation > Convection parameters > Turbulence** tab. The **Turbulence** tab in the **Convection parameters** dialog opens:
2. The underrelaxation factors for turbulent energy and eddy dissipation equations are applied separately, obvious both linearized equations are solved together in the same matrix equation. The recommended value for both underrelaxation factors is 0.1. Change the underrelaxation of turbulent energy and eddy dissipation, if necessary.

3. Set the underrelaxation for turbulent viscosity to a small value ( < 0.1 ). Because of the strong underrelaxation the calculated turbulent viscosity will be changed iteratively very slowly. But in case of weaker underrelaxation, the turbulence equations might diverge. Change the underrelaxation of turbulent viscosity, if necessary. The recommended value is 0.08.

4. Set the convergence criteria Max. inner iterations and Desired residuum, if desired.

5. The computation of the turbulent viscosity in the triangles laying at the boundary fluid-solid is avoided at the beginning of the calculation because of the numerical stability reasons. The turbulent viscosity will be updated everywhere after the residuum of the k-ε turbulence equations has achieved some critical value. This value is prescribed in the Set last triangle at parameter. By setting of the larger residuum value the calculation of the turbulent viscosity in the last triangles begins earlier. Adjust Set last triangle at parameter, if desired.

6. Click on Apply and Close. or
   Click on OK to apply the changes and to close the dialog.

Related Procedures
Computing Turbulent Gas Convection (page163 )

Related Dialogs
Turbulence (page244 )

6.5. Setting the parameters for alloy solidification
The model for alloy solidification

The physical background is described in the PhD thesis of M. Hainke (see Bibliography (page 277)), thus only a very short introduction is given. The model uses the volume average approach to describe the complex interface structure of the dendritic growth in alloy solidification. Thus the interface in not resolved in all details but represented as a phase fraction in a two phase system, containing solid and liquid phase. The main task of the models implemented is to calculate the liquid fraction. In principle, there are two different cases of treating alloy solidification in CrysVu:

- **Without macrosegregation**

  If macrosegregation is neglected the analytic solution for the liquid fraction, based on the Scheil's equation or the lever-rule respectively, can be used (see Setting of numerical parameters for the alloy model (page 94)). In the Physical Phenomena dialog only temperature and alloy have to be selected. The liquidus temperature and the partition coefficient is required as parameters (see Defining a phase diagram (page 91) and Materials (page 213)). Stationary and time dependent calculations can be taken out.

  Even this simple model needs additional iterations for adjusting the liquid fraction. The release of latent heat is spread over the mushy zone, thus the change in liquid fraction will lead to changes in the latent heat release. This affects the temperature field. As the liquid fraction in this model is (only) a function of the temperature the resulting liquid fraction changes, also. The procedure is continued until convergence. The changes applied in one iteration can be multiplied with an underrelaxation factor (see Setting of numerical parameters for the alloy model (page 94)).

- **With macrosegregation**

  Considering macrosegregation requires additional physical phenomena to solve. In addition to temperature and the alloy model itself, convection and species transport has to be calculated. The calculations are always time dependent.

  For the phase diagram coupling the enthalpy or the matrix based method can be used (see Setting of numerical parameters for the alloy model (page 94)). The phase diagram itself is represent in a linearized form for a binary eutectic system. The parameters for that model are set in phase diagram tab (see Defining a phase diagram (page ?)). The initial concentration of the alloy is set with the Initial Value dialog. The desired value is assigned to the variable concentration in the region where macrosegregation shall be computed.

  As quite a number of physical phenomena are solved coupled for this computation, the system require several convoluted iteration.

- The first inner loop corrects the liquid fraction, concentration and temperature field. The abortion criteria for this loop are set in Abortion tab. The iteration can be stopped either if a certain accuracy or a defined number of steps is reached.

- In the second inner loop the Navier-Stokes equation are solved. The abortion criteria is set in the Convection Parameters dialog with the parameters in the Inner iteration limits section (Abortion tab). The residual error can be specified, which shall be reached before again switching to the first inner loop computing the liquid fraction.

- The outer loop around the two inner ones will stop as soon as the criteria specified in the Stop of computation field (located in Convection Parameters dialog Abortion tab) and the parameters in first inner loop are fulfilled. If this happen a time step is finished and the next time step will be computed. This proceeds till the stop time is reached.

As all physical properties are coupled for this calculation (the liquid fraction affects the flow field via the permeability, the species field with the solutal buoyancy term, ...), in most cases underrelaxation must be used to obtain a converged solution.
Remark: Due to the high computational effort, macrosegregation calculations are very time consuming. Be sure that you have optimize your thermal model for speed before you start such a calculation.

Overview of the variables of the alloy model

The alloy model uses the volume averaging technique, thus additional variables appear if this model is used for calculations. An overview is given in the following:

- **liquid fraction**
  The fraction of the liquid phase in the control volume

- **VeloU\_Volav, VeloV\_Volav, VeloW\_Volav, Press\_Volav**
  The volume averaged velocity components and pressure

- **MixtureConcentration**
  The mixture concentration in the control volume. If this value change from the initial composition of the alloy one speak of macrosegregation.

- **Solid\_Volav, Liquid\_Volav**
  Volume averaged concentration in the solid and liquid phase, respectively.

- **Concentration**
  The intrinsic concentration of the liquid phase. This value is coupled to the temperature via the phase diagram

- **VelocityU, VelocityV ...**
  The intrinsic velocity components and pressure of the liquid phase

- **Temperature**
  The temperature is assumed to be equal in both phases, thus only the volume average is given.

Related dialogs

Alloy parameters (page245 )

Related procedures

Setting Convection parameters (page 84)
Setting parameters for forward simulation (page 80)

6.5.1. Defining a phase diagram

In the Phase diagram tab, the linearized phase diagram and the microsegregation model is specified. The following parameters can be defined:

<table>
<thead>
<tr>
<th>Parameters</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsegregation relation</td>
<td>Two models for microsegregation are available, representing two extreme case:</td>
</tr>
<tr>
<td></td>
<td>• Lever rule: Thermo dynamic equilibrium between solid and liquid phase exists. This means that the rate of back diffusion (solid-liquid) is fast compared to the solidification rate (infinite back diffusion). This is a usu-</td>
</tr>
<tr>
<td>Parameters</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>ally good approximation for interstitial solid solute (example: carbon in steel).</td>
<td></td>
</tr>
<tr>
<td>Scheil's equation: The microscopic diffusion in the solid is neglected. Thus the rate of back diffusion is 0. Most alloys can be described with that approximation, because of big the differences of the diffusion coefficients in solid and liquid phase.</td>
<td></td>
</tr>
<tr>
<td>Melting point of pure substance</td>
<td>Here the melting point of the pure solvent is specified. This parameter is only needed when macrosegregation is taken into account.</td>
</tr>
<tr>
<td>Liquidus line slope</td>
<td>The slope of the liquidus line of the used alloy around the initial concentration. This parameter is only needed when macrosegregation is taken into account.</td>
</tr>
<tr>
<td>Liquidus temperature</td>
<td>The liquidus temperature for used alloy at the initial composition. This parameter is used by pure diffusive alloy model (neglecting any macrosegregation).</td>
</tr>
</tbody>
</table>

1. Select **Computation > Alloy Parameter >**
   The **Alloy Parameter** dialog opens with the **Phase diagram** tab activated:

   ![Alloy Parameters dialog](image)

   *Figure 6.20. Phase diagram tab in Alloy Parameters dialog*

2. Choose a microsegregation model which is appropriate for your system under investigation.
   Type in the parameters of the phase diagram of the system.

3. Click on **Apply** and **Close**.
   or
   Click on **OK** to apply the changes and to close the dialog.
Related dialogs

Phase diagram (page245)

6.5.2. Define the permeability law

In the Permeability tab the permeability relation can be selected and the microstructural parameters can be defined.

<table>
<thead>
<tr>
<th>Parameters</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Permeability law</td>
<td>Three relations for the permeability as a function of the liquid fraction and microstructure are available:</td>
</tr>
<tr>
<td></td>
<td>• The Carman-Kozeny equation: Standard relation only taking the primary arm spacing as a parameter. The permeability tensor term is isotropic.</td>
</tr>
<tr>
<td></td>
<td>• Schneider-Beckermann: The model of these authors is developed to described the situation in dendritic alloy solidification. It needs both parameters and leads to a anisotropic permeability tensor. The principal axis are defined by the local temperature gradient.</td>
</tr>
<tr>
<td></td>
<td>• Heinrich-Poirier: Has the same properties as the model (Schneider-Beckermann) mentioned in before. Uses different fit function.</td>
</tr>
<tr>
<td>Primary dendrite arm spacing</td>
<td>Distance between the primary stems of the dendrites. This parameter is mandatory for all permeability laws.</td>
</tr>
<tr>
<td>Secondary dendrite arm spacing</td>
<td>Distance between the side arms of the dendrites. The Carman-Kozeny equation does not use this parameter.</td>
</tr>
</tbody>
</table>

1. Select Computation > Alloy Parameter >

The Alloy Parameter dialog opens with the Phase diagram tab activated.

Select the Permeability tab:

![Figure 6.21. Permeability tab in Alloy Parameters dialog](image)

93
2. Choose a permeability law.
   Define the microstructural parameters for the permeability law.

3. Click on **Apply** and **Close**.
   or
   Click on **OK** to apply the changes and to close the dialog.

**Related dialogs**
Permeability (page246)

**6.5.3. Setting of numerical parameters for the alloy model**

In the **Numerical** tab the phase diagram coupling schema and the numerical parameters can be defined:

<table>
<thead>
<tr>
<th>Parameters</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Coupling schema</strong></td>
<td>Three coupling schemas are available:</td>
</tr>
<tr>
<td></td>
<td>• Analytical: Uses Scheil's equation or the lever rule respectively to calculate the liquid fraction directly from the temperature. Only valid for the pure diffusive case, that means without macrosegregation.</td>
</tr>
<tr>
<td></td>
<td>• Enthalpy based: Iterative schema, which compute the correction for the liquid fraction based on the definition of the enthalpy. It is the first choice when computing macrosegregation.</td>
</tr>
<tr>
<td></td>
<td>• Matrix based: Iterative schema, which compute the correction of the liquid fraction using the reformulated conservation equations in matrix notation. Under certain conditions it can give a better performance than the Enthalpy based schema. It does not include the eutectic reaction. Use with care!</td>
</tr>
<tr>
<td><strong>Liquid fraction underrelaxation</strong></td>
<td>Underrelaxation factor for the correction of the liquid fraction in the first inner iterative loop (phase diagram correction). Only the specified value times the calculated correction will be applied as actual correction. Values close to 0 enhance stability and prevent oscillations. Values close to one reduce the calculation time. This parameter is strongly problem dependent. Suitable range for this parameter: 0.1-1.</td>
</tr>
<tr>
<td><strong>Minimum factor for dedT</strong></td>
<td>Minimum underrelaxation factor for the approximated latent heat source term in the temperature equation. The actual used value depends on the norm of the residual of the temperature equation. Background: at the beginning of the time step the value for time derivative of the liquid fraction is not known. A possible approximation is to use the value from the old time step.</td>
</tr>
<tr>
<td><strong>Maximum factor for dedT</strong></td>
<td>Minimum underrelaxation factor for the approximated latent heat source term in the temperature equation. If minimum</td>
</tr>
</tbody>
</table>
Parameters | Description
---|---
(see above) and maximum factor are set to 0, no approximate source term will be used (default).
Second liquid fraction correction | If this option is activated a post correction (after correcting temperature and concentration) of the liquid fraction will be applied in each iteration step of the phase diagram coupling loop.
Temperature correction relaxation | Underrelaxation factor for the temperature equation in the post correction step.
Concentration correction relaxation | Underrelaxation factor for the species equation in the post correction step.

1. Select **Computation > Alloy Parameter** >
The **Alloy Parameter** dialog opens with the **Phase diagram** tab activated.
Select the **Numerical** tab:

![Figure 6.22. Numerical tab in Alloy Parameters dialog](image)

2. Choose a phase diagram coupling schema which is appropriate for your system under investigation.
3. Define a value for the liquid fraction underrelaxation. Keep the minimum and maximum factor for \( \text{d}T \) at their default value of 0.
4. Switch of the **second liquid fraction correction**
5. Click on **Apply** and **Close**.
   or
   Click on **OK** to apply the changes and to close the dialog.

**Related dialogs**
Numerical (page 247)
6.5.4. Setting abortion parameters

In the Abortion tab the criteria for leaving the inner phase diagram correction loop are defined.

<table>
<thead>
<tr>
<th>Parameters</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maximum number of iterations</td>
<td>The maximum number of iteration in the inner phase diagram coupling loop.</td>
</tr>
<tr>
<td>Required phase diagram consistence</td>
<td>Average deviation in Kelvin of the temperature at the nodes in the mushy zone from the value given by the phase diagram and the concentration at this node.</td>
</tr>
<tr>
<td>Minimum liquid fraction change</td>
<td>Minimum value of the applied correction of the liquid fraction per iteration step. The second value specifies the minimum required change summed up over 5 iterations.</td>
</tr>
</tbody>
</table>

1. Select Computation > Alloy Parameter >
   The Alloy Parameter dialog opens with the Phase diagram tab activated.
   Select the Abortion tab:

   ![Figure 6.23. Abortion tab in Alloy Parameters dialog](image)

2. Set the number of iteration to 30.
3. Leave the remaining parameters at their default values.
4. Click on Apply and Close.
   or
   Click on OK to apply the changes and to close the dialog.

Related dialogs
Abortion (page248)

6.6. Display of Solver Information

The Show Solver Information dialog enables you to monitor the solution procedure. De-
pending on the variable solved, you can choose between monitoring the Residuals (Temperature) or the Other information (Convection). The third kind of solver information displayed are the Rowsums of the view factors, see View factors (page 77).

**Monitoring residuals**

Before you open the dialog the *.crys file should be ready for starting the computation, i.e. all settings and relevant parameters are set.

1. Select **Computation > Show Solver Information**.

   The Show Solver Information dialog opens with the Residuals option active:

   ![Figure 6.24. Show Solver Information: Residuals](image)

2. Select **Computation > Start Computation**.
   or
   
   Click on the Button in the tool bar.

   The computation process starts either with computing the view factors or immediately with solving the variable. Stage and progress are indicated in the status bar. A short time after solving has begun, the equation residuum will be displayed in the Show Solver Information dialog window:

   ![Figure 6.25. Show Solver Information dialog: equation residuals](image)

   If you computed convection and switch to Others, the solving progress for the momentum, the temperature and the interface-dT will be displayed:
3. Click on **Close**.

or

Press **Enter** to close the dialog.

**Note**

In case of convection computation, more equations are solved in the same time. In this case, the **Residuals** information mixes more residuums, so the displayed information is unusable. Select only **Others** option to monitor convection computation!

**Related Dialogs**

Show Solver Information (page248 )

**6.7. Computation Operations**

Once all relevant parameters have been set, you are ready to start computation. Running simulations can be time-consuming. The mesh size of the unstructured grid and the view factors directly influence the duration of computation time. For better controlling **CrysVUn** enables you to generate the grid and to compute view factors before starting the actual computation.

Three computation operations are necessary for a successful simulation:

- Generating grid
6.7.1. Generating Grid

On a given furnace the unstructured grid can be computed in Simulation Mode at any time. You can generate the grid as often as necessary to optimize the mesh size in each region. For details about setting grid parameters see Grid Properties (page 53).

**Note**

You will not be able to start the simulation run, before the grid has been computed by selecting Computation > Generate Grid or clicking on .

6.7.2. Adapting grid

The implementation of turbulence model in CrysVU may require a special grid at the boundary between the gas and solid regions. The normal computed grid can be adjusted in order to fit the needs.

This function does not change the number of degrees of freedom or the mesh topology. It causes a shifting of the nodes from the middle of the selected region towards the region boundary (boundary layer). It can be applied after the generation of the default mesh and either before or after the computation of the view factors.

1. Before adapting grid, set required grid parameters by generating the normal grid.

Some minimum density of the numerical mesh is required in the turbulent boundary layer in order to calculate the transport of heat, momentum and special values of the turbulence model. The required mesh density depends on the Reynolds number. A typical mesh size of 3 mm or less is advised at the boundary between convective gas region and solid body. In the center of the convective region the mesh size should be 15 mm or less and the progression denominator for the transition in the mesh density from the boundary toward the region center should be 0.15.

- set the Edge length to 0.015 and Fit slope to 0.15 for convective gas region.
- set the Edge length to 0.003 for the boundaries of convective gas region, excepting the symmetry axis.
- recompute the grid by selecting Computation > Generate Grid or clicking on tool button.

For details about setting grid parameters see Grid Properties (page 53).

2. Select Computation > Adapt grid.

The Adapt grid dialog opens and you set the grid adaption parameters.
3. Select the region for grid adaption process, e.g. the gas region. The adaption could be generally applied for a group of regions. You can either manually select the regions, if the adapt for selected regions option is checked, or the program automatically selects all regions involved into a physical model, if the adapt for physical phenomena option is checked. The list of the available physical models is provided in this case, the default is turbulent_energy. In this case you have to set the corresponding physical phenomena to the adapted regions before adapting the grid, see Physical Phenomena (page 56).

4. Set the strength of the mesh deformation It is defined according to two methods:

- by indicating the reduction degree for the distance of last node to the region boundary (the decrease distance by factor of should be checked).
- by indicating the absolute distance of last node to the wall (the distance last node - boundary should be checked).

Adjust parameters for grid refinement, if desired.

5. Click on Apply to adjust the grid.

Note
The mesh adaptation can be applied not only for calculation of the turbulent fluid flow but for any problem where the inhomogeneous numerical refinement in the region core and on its boundaries is necessary, for example by the species transport in the melt.

Related Procedures
Adjusting the grid (page164 )

Related Dialogs
Adapt grid (page249 )

6.7.3. Computing view factors
Because view factors have to be computed before a variable can be solved, CrysVUn will compute them automatically, if necessary. However, it makes sense, if you compute view factors independently from the variable solving by selecting Computation > Compute View Factors. In this case you can examine the quality of the rowsums in the Show Solver Information dialog, and you can improve them by changing view factor parameters on the View factors tab in the Numerical parameters dialog, see View factors (page 77), or by modifying the grid parameters, see Grid Properties (page 53).

### 6.7.4. Starting and stopping computation

For starting or stopping computation, you can either click on the button in the tool bar or you choose the respective menu item. Neither buttons nor menu items will be active, before you have generated the grid.

#### Starting computation

- Select Computation > Start Computation.
  
  or
  
  Click on the Compute variable button \[\text{\text{Compute variable}}\] in the tool bar.

#### Stopping computation

- Select Computation > Stop Computation.
  
  or
  
  Click on the Stop computation button \[\text{\text{Stop computation}}\] in the tool bar.
Chapter 7. Simulation Mode: Variables

A variable is a physical quantity that can be computed by CrysVu, like Temperature or vonMisesStress. Some of these variables are closely related to each other while others are practically independent from each other.

For instance, the two components of displacements are coupled very tight together because they are influencing each other and can be solved only together. They are also both coupled to the Temperature but the temperature is independent of them, so the relationship between the displacements and the Temperature is not very tight because the only condition that must be fulfilled is that first the temperature must be computed and afterwards the displacements.

The vonMisesStress can again be computed from the displacements. There are cases when the user must decide how strong the variables are coupled together. For instance, the user might need to compute the temperature and the magnetic field at the same time if the magnetic properties are depending on the temperature. Else, the user can choose to compute first the magnetic field and then the temperature.

This is the reason that some variables are coupled together in groups of variables.

![Figure 7.1. Variable groups list box](image)

A group of variables contains all variables which are calculated simultaneously. For instance, the variable group Temperature contains radial gradient, axial gradient, radial heat flux, axial heat flux, conductivity r and conductivity z.

After selecting the desired variable group, you must specify the region(s) where the program should calculate them. On the one hand, not every variable is of interest for all regions. On the other hand, it is not possible to calculate every variable for every region respectively material. You determine which groups of variables are of interest in a region by using the Physical Phenomena dialog invoked via Settings menu.

### 7.1. List of Variable Groups and Variables

<table>
<thead>
<tr>
<th>Variable group</th>
<th>Variable</th>
<th>Computed for planar symmetry</th>
</tr>
</thead>
<tbody>
<tr>
<td>Temperature</td>
<td>radialGradient</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>axialGradient</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>radialHeatFlux</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>axialHeatFlux</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Conductivity-r</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Conductivity-z</td>
<td>Yes</td>
</tr>
<tr>
<td>Variable group</td>
<td>Variable</td>
<td>Computed for planar symmetry</td>
</tr>
<tr>
<td>---------------------------------------</td>
<td>-------------------------------</td>
<td>------------------------------</td>
</tr>
<tr>
<td>Alloy</td>
<td>LiquidFraction</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>VeloU_Volav</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>VeloV_Volav</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>VeloW_Volav</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Press_Volav</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Mixture Concentration</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td>Solid_Volav</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td>Liquid_Volav</td>
<td>No</td>
</tr>
<tr>
<td>Thermoelastic Stress</td>
<td>vonMisesStress</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td>StressComponentrr</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td>StressComponentpp</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td>StressComponentzz</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td>StressComponenttr</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td>DisplacementU</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td>DisplacementV</td>
<td>No</td>
</tr>
<tr>
<td>Convection</td>
<td>VelocityU</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>VelocityV</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Pressure</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>StreamFunction</td>
<td>Yes</td>
</tr>
<tr>
<td>Azimuthal Flow</td>
<td>VelocityW</td>
<td>No</td>
</tr>
<tr>
<td>Inductive Heating</td>
<td>in-phase-potential</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td>out-of-phase-pot.</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td>ind-heat-source</td>
<td>No</td>
</tr>
<tr>
<td>(r,z)-Lorentz Forces</td>
<td>lorentz-r</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td>lorentz-z</td>
<td>No</td>
</tr>
<tr>
<td>Electrical Potential</td>
<td>sinus-component</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td>lorentz-r</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td>lorentz-p</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td>lorentz-z</td>
<td>No</td>
</tr>
<tr>
<td>Concentration</td>
<td>Concentration</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td>Supersaturation</td>
<td>No</td>
</tr>
<tr>
<td>Point Defects</td>
<td>InterstitialConc</td>
<td>No</td>
</tr>
<tr>
<td>Variable group</td>
<td>Variable</td>
<td>Computed for planar symmetry</td>
</tr>
<tr>
<td>-----------------------</td>
<td>------------------------</td>
<td>------------------------------</td>
</tr>
<tr>
<td></td>
<td>VacancyConc</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td>ConcDifference</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td>VoidsConc</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td>VoidsMeanRadius</td>
<td>No</td>
</tr>
<tr>
<td>Turbulent Convection</td>
<td>turbulent_energy</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td>eddy_dissipation</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td>turbulent_viscosity</td>
<td>No</td>
</tr>
</tbody>
</table>
Chapter 8. Simulation Mode: Visualization and Analysis

The Visualization menu enables you to visualize results after and even during computation. By the Analysis menu you export data for post-processing.

8.1. Visualizing results

The Visualization menu comprises three items:

<table>
<thead>
<tr>
<th>Menu item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show</td>
<td>Opens the dialog for choosing the information to be displayed on the left and on the right side of the main window, see Show results (page 105).</td>
</tr>
<tr>
<td>Options for Scalar Fields</td>
<td>Offers parameters for modifying the presentation on the screen, e.g. changing the number of isolines, see Setting options for scalar fields (page 106).</td>
</tr>
<tr>
<td>Zoom Out</td>
<td>Resets the drawing to its original size. This menu item is equivalent to the Zooming out button in the tool bar.</td>
</tr>
</tbody>
</table>

8.1.1. Show results

The Show dialog in the Visualization menu enables you to visualize results for the left and the right side of the geometry. When you load a *.crys file, the regions are displayed on both sides of the main window by default. When you open the Show dialog menu you see that the options for displaying the regions are active:

![Figure 8.1. Show dialog](image)

If you click on the regions boxes to deactivate them, the furnace will disappear from the main window, although the file is still open.

Besides the regions, you can visualize the grid, the isolines, the vector field, the scalar field and the legend for the scalar field. For temperature and the variables in this group, all features can arbitrarily and simultaneously be combined. Results for all other variables can be displayed on the right side only. But it is possible to combine the display of temperature on the left side with the display of other variables on the right side, e.g. Velocity V.
**8.1.2. Setting options for scalar fields**

The representation of the scalar field can precisely be defined by the user in the **Options for Scalar Fields** dialog.

The following parameters can be specified:

<table>
<thead>
<tr>
<th>Category</th>
<th>parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Isolines for</td>
<td>set number</td>
<td>Check, if you want to specify the <em>number</em> of equidistant isolines in the input field below.</td>
</tr>
<tr>
<td></td>
<td>set interval</td>
<td>Check, if you want to specify the <em>interval</em> desired between isolines.</td>
</tr>
<tr>
<td>Isolines</td>
<td>Number of isolines</td>
<td>Replace the default number of isolines (11) by the desired number.</td>
</tr>
<tr>
<td></td>
<td>respectively</td>
<td></td>
</tr>
<tr>
<td></td>
<td>interval</td>
<td></td>
</tr>
</tbody>
</table>

For the regions on the right side, you can also use the tool bar buttons for grid, isolines, vector field, and scalar field to toggle the displaying on and off.

For more information see the tutorial tasks Visualizing the calculated temperatures (page 127), Visualizing the results of inverse simulation (page 144) and Show (page 251).
<table>
<thead>
<tr>
<th>Category</th>
<th>parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>or</td>
<td>Replace the default interval (100 K) by the desired temperature interval.</td>
</tr>
<tr>
<td>Reference value</td>
<td></td>
<td>Specify a value as reference for the interval, i.e. a fixed isoline.</td>
</tr>
<tr>
<td>Data</td>
<td>automatic</td>
<td>Check, if you want CrysVUn to determine minimum and maximum automatically (default).</td>
</tr>
<tr>
<td></td>
<td>manually</td>
<td>Check, if you want to specify minimum and maximum manually.</td>
</tr>
<tr>
<td></td>
<td>Minimum/Maximum</td>
<td>Input fields for minimum and maximum values, if manually is checked.</td>
</tr>
<tr>
<td>Data format</td>
<td>fixed</td>
<td>Decimal representation, e.g. 123.45.</td>
</tr>
<tr>
<td></td>
<td>scientific</td>
<td>Exponential representation, e.g. 12345e+002.</td>
</tr>
<tr>
<td></td>
<td>Number of decimal digits</td>
<td>Number of digits behind the decimal point.</td>
</tr>
<tr>
<td></td>
<td>Logarithmic scale</td>
<td>Performs a logarithmic scale. Usually, the program uses a linear scale for showing calculated values. But the values of some variables spread over a large interval (more than 1.e+10), and a linear representation would not adequately visualize the information.</td>
</tr>
<tr>
<td>Paint</td>
<td>Full scale</td>
<td>Painting covering the whole range of values and colors.</td>
</tr>
<tr>
<td></td>
<td>Partial scale</td>
<td>Covering the range of values specified in the Minimum/Maximum fields.</td>
</tr>
</tbody>
</table>

For more information see the dialog Options for Scalar Fields (page252).

8.2. Analysis

The Analysis menu enables you to post-process computed results.

The menu comprises three items:

- Write isoline (page107)
- Monitor/Write Profile (page108)
- Export Data (page115)
- Write Interface (page116)

8.2.1. Write isoline

An isoline is a graphical representation of all points having the same computed value.
Therefore the **Write Isoline** dialog is very simple.

1. Select **Analysis > Write Isoline**.
   The **Write Isoline** dialog opens.

   ![Write Isoline dialog](Figure 8.4. Write isoline dialog)

2. Select the variable from the list box next to **Value of**.
3. Specify the temperature value for the isoline in the input field.
4. The system suggests to save the isoline values in a file with the identical name, but the extension *.*iso*. If you do not want this name, you can replace it manually or browse for a different file.
   Change the file name, if necessary.
5. Click on **Apply** and **Close** to save the isoline.
   or
   Click on **Apply** and specify another isoline.
   The isoline for the temperature specified will be saved to CrysVUn’s home directory.

**Related Procedures**
Writing isoline (page129)

**Related Dialogs**
Write Isoline (page254)

**8.2.2. Monitor/Write Profile**

The **Write Profile** menu item invokes the same dialog as **Monitor** in the **Computation** menu for time dependent computation: The **Monitor/Write Profile** dialog. This dialog has three tabs for writing points, polylines, and the entire file.
However, there are two dialog elements which are available only when you access the dialog via the Monitor menu item in the Computation menu:

- The field **Save every ... time step** at the bottom of points and polylines tabs
- The **Entire file** tab

The reason is that both elements require time-dependent computation.

This export dialog is the most complex one because you have three tabs for defining different data ranges. The data are saved to ASCII files with the extension *.mon and a specification for the data range.

### 8.2.2.1. Writing points

On the Points tab you specify points for which variable values shall be saved to an ASCII file. The file name for the exported data is composed of the original file name to which "_p.mon" is added.

You can add points by specifying the coordinates and clicking on Add. You change and delete a point by selecting the point and clicking on Change or Delete.

To save data at specific points proceed as follows:

1. Select **Analysis > Write Profile**.
   - The Monitor/Write Profile dialog opens, default is the **Points** tab.
2. The points are specified by their coordinates. Specify the r- and z-coordinates of the desired point in the respective input fields, e.g. \( r = 0, z = 0.2 \).

3. The check box **moving** is only to be activated, if the point belongs to a moving region. If checked, the monitoring protocol will follow the point. Select moving, if applicable.

4. Click on **Variables** button. The variables tree selector is opened and you select the variables for which the values shall be exported.

5. Click on **Add**. The point appears in the top field.

6. Specify as many points as you need by repeating steps 2 to 5. The coordinates of all points, their status (moving or not) and the variable group will be listed in the upper field of the dialog window. The computed values for the defined points will be displayed in the lower field of the dialog window (**calculated values** table).
7. Click on **Apply** and **Close**.

The data will be written to the file specified in the field in the middle of the dialog window.

The dialog will be closed and the ASCII file is ready for post-processing.

If you already saved data to the suggested file, the following message will be displayed:

![Figure 8.8. Overwrite warning](image)

You can either save the data to a different file, append the data to the existing file, overwrite the existing file, or cancel the operation and continue.

**Related Procedures**

Writing isolines and profile (page146)

**Related Dialogs**

Points (page255)

**8.2.2.2. Writing polylines**

Values of the selected variables can also be saved along polylines. A polyline can consist of one or more straight lines or one or more selected region lines, depending how it is defined.

A “profile” polyline is defined by an ordered list of at least two nodes. The polyline begins at node No. 0 and consists of straight lines from one node to the next. You can specify the coordinates of each node giving its coordinates or using the mouse (**CTRL + right mouse button**).
A “selected” polyline is defined as a list of selected region lines. In this case, the start and end points of each selected line are indicated in the bottom side list of the polylines tab.

You need to define at least two nodes to add a “profile” polyline or to select at least one region line to add a “selected” polyline.

Defining a “profile” polyline

To save data along a “profile” polyline proceed as follows:

1. Select Analysis > Write Profile > Polylines.

The Polylines tab of the Monitor/Write Profile dialog is displayed.

2. Specify the r- and z-coordinates for the first node of the polyline, e.g. \( r = 0.02, \ z = 0.32 \), in the input field at the bottom of the dialog window

or

move the mouse pointer to the desired position and press and hold down Ctrl key and click the right mouse button.

3. Click on Add Node.

The node will be displayed in the field above.

4. Add as many nodes as you need by repeating steps 2 and 3.

5. Click on Variables button.

The variables tree selector is shown and you select the variables for which the values shall be exported, e.g. Temperature, radial and axial-Gradient.

6. Determine by the No. of steps how many values you want to save along the polyline, e.g. 200.

7. All defined nodes will be included in this profile. The nodes and the lines are displayed in the drawing.

Click on Add to add the polyline(s) to the list.

The polyline profile No. 0 appears in the upper field of the dialog window.
The profile comprises 200 steps (values) for the Temperature, radial and axial-Gradient variables and the data will be saved to the file `toymodel_p10.mon`.

In time-dependent computation, the **Save every n time steps** field specifies that monitor data are written at every $n^{th}$ time step.

8. Click on **Apply** and **Close**.

**Defining a “selected” polyline**

To save data along a “selected” polyline proceed as follows:

1. Select **Analysis > Write Profile > Polylines**.
2. Select on drawing area the desired region lines (**Ctrl + left mouse button**). The selected line(s) coordinates appear in the nodes table.
3. Set the number of steps and select variables.
4. Click on **Add** to add the polyline(s) to the list.

The polyline profile No. 1 appears in the upper field of the dialog window.
5. Click on **Apply** and **Close**.

**Note**
The normalGradient and normalHeatFlux values are automatically written in case you select axial or/and radial-Gradient, respectively axial or/and radial-HeatFlux variables.

**Tip**
In case of a selected line, the sign of normal heat flux values depends on the region which is of reference. The left or right region could be by chance considered. In order to force a region to be the reference region for saving normal heat flux, you have to set **WallHeatFluxRef** label to this region, see Assigning labels (page 48).

**Related Dialogs**
- Polylines (page 256)

**8.2.2.3. Writing entire file**

This option is only available, when you open the dialog via **Monitor** in the **Computation** menu.

1. **Select Computation > Monitor > Entire file.**
   The **Entire file** tab of the **Monitor/Write Profile** dialog is displayed.
2. Specify the interval in seconds and the starting time for saving all data of the entire file.

3. Specify how often these data should be saved.

4. Click on Apply and Close.
   The data will be saved to a *.crys file the name of which is composed of the original file name and the current simulation time.

Related Dialogs
Write Entire File (page258 )

8.2.3. Export Data
In the Export data dialog you can save variables values from a rectangular area or selected furnace regions.

1. Select Analysis > Export Data.

2. If you want to save data inside a rectangular area, follow a); if you want to save data from furnace regions, follow b):
   - a) check Rectangle option and define the rectangle by specifying the coordinates: lower left corner (r and z min) and upper right corner (r and z max).
     CrysVUn will display the area selected, when you click on Show area.
• b) check Region(s) option and select on the drawing the desired region. Press and hold down Ctrl key to select more regions. If the material of selected region contains has two phases, you can select to export only data in crystal or melt zone.

3. Specify the number of rows and of columns in the output file.
4. Select the variables from the Groups and Variables tree list.
5. The system suggests to save the data to a file with the extension *.gpro. You may either accept the suggestion, change the name or browse for a different file.
   Click on **Apply**.
   The system confirms the successful saving of the data.
6. Click on **Close**.

**Related Dialogs**
Export Data (page258 )

**8.2.4. Write Interface**

In the Write Interface dialog you can save the position of the solid-liquid interface and the temperature gradients at the interface to a file.

1. Before you are able to write the interface into a file, you have to compute temperature.
once with enabled interface tracking. Select Computation > Numerical Parameters. Change to the Forward tab. Be sure the Track Interface button is checked.

2. Compute the temperature and the gradients.

3. Select Analysis > Write Interface.
   The file *-gradients.dat is now saved.

Related Dialogs
   Export Data (page258)
Chapter 9. Tutorials

Purpose of the tutorials

The tutorial section complements the program description with use cases. You find use cases for different kinds of thermal modelling specialists (cartridge designer, optimization analyst, thermal model correlation analyst etc.) and the most frequent tasks to be solved with CrysVUn.

The use cases demonstrate step by step how to work with the program and which interdependencies you have to consider when running a simulation. You find sample files in CrysVUn's EXAMPLES directory for all use cases.

Use cases

The following use cases are described:

• Running a Thermal Analysis (Quick Start) (page118)
• Modifying the Sample Cartridge Assembly (SCA) (page130)
• Handling Materials (page135)
• Running an Inverse Simulation (page140)
• Computing a Time-dependent Simulation (page147)
• Computing a Time-dependent Simulation with Moving Regions (page153)
• Computing Pseudo-stationary and Time-dependent Convection (page156)
• Computing Turbulent Gas Convection (page163)
• Computing Thermoelastic Stress (page170)
• Computing Inductive Heating (page172)
• Simulating Rotating Magnetic Fields and Computing Lorentz Forces (page178)
• Simulating Stationary Magnetic Fields and Computing Lorentz Forces (page179)
• Computing Concentration (page182)
• Running CrysVUn in Batch Mode (page193)

The first use case is a quick start for the most frequent application of CrysVUn: Computing temperature.

Note

Before you proceed with any of the use cases, you have to start the program, see Starting the program (page 5).

9.1. Running a Thermal Analysis (Quick Start)

This tutorial illustrates the basic functions of CrysVUn. Its purpose is to familiarize you with the navigational aids and the content of the menus and dialogs. Many of the tasks described in this tutorial are basic activities which need to be performed any time you run a thermal analysis.

This tutorial uses a *.crys file containing all geometry and materials data. Before starting
computation, you specify basic settings and computational parameters. During compu-
tation you follow the solving procedure, look at the results and finally write an isoline to a file.
The following tasks are involved:

- Opening the file LGF_prototype.crys (page119)
- Generating the grid (page120)
- Changing parameters in the Settings and the Computation menus (page121)
- Computing temperature (page127)
- Visualizing the calculated temperatures (page127)
- Writing isoline (page129)

9.1.1. Opening the file LGFPrototype.crys

Prerequisites

_CrysVUn_ is running.

The LGF_prototype.crys file is available in _CrysVUn_ ‘s EXAMPLES directory.

1. _CrysVUn_ always opens in Simulation Mode and therefore only *.crys files are
offered in the Open file dialog.

Select File > Open.

The Open file dialog opens.

2. Select LGF_prototype.crys from the _CrysVUn_ directory and click on Open.

The furnace stored in LGF_prototype.crys is displayed:

![Figure 9.1. LGF_prototype.crys](image)

In the status bar the position of the mouse pointer and (on the right hand side of the
drawing) the appropriate region is displayed.

For example, if you point to the base of the SCA, “Reg = 288 (Stainless Steel)” is dis-
played. This means that the material “Stainless Steel” is assigned to region number 288.
Related Dialogs
File Menu (page197)

9.1.2. Generating the grid

CrysVUn needs a grid as a mathematical basis for the simulation. The grid is unstructured and has triangular meshes.

1. Select Computation > Generate Grid.

   The program starts generating the grid. You can observe the progress of the generating process in the right field of the status bar. The Show/hide grid button becomes active as soon as the computation is finished.

2. Click on the Show/hide grid button in the tool bar.

   The grid is displayed on the right side of the furnace.

![Figure 9.2. LGF_prototype with grid on the right side](image)

3. By default, only the geometry (regions) is displayed for the left side of the furnace. You can, however, select most results to be displayed for both furnace sides via the Show dialog.

   Select Visualization > Show.

   The Show dialog is displayed:

   ![Figure 9.3. Show dialog](image)

4. Click on the check box next to Grid in the column Left.

   The grid will be displayed for the whole geometry.
5. The Show/hide grid button controls the display of the grid only for the right side of the furnace. For turning it off on the left side, you use the Show dialog. Click on the check box next to Grid in the column Left.

6. Click on Close to close the Show dialog.

7. Click on Show/hide grid button to turn the grid display off for the right side. The grid is not displayed anymore, but the Show/hide grid button remains active thus indicating that the grid has already been computed.

8. Select File > Save file. The grid will be saved to the LGF_prototype.crys file. The next time you load this file, the Show/hide grid button will be active.

Related Procedures
Grid Properties (page 53) Generating the Grid (page 55)

Related Dialogs
Grid (page219 ) Show (page251 )

9.1.3. Changing parameters in the Settings and the Computation menus
In the Settings menu and the Computation menu settings and computational parameters can be specified. In this first approach you will change only few parameters, but rather focus on the navigation and basic settings.

9.1.3.1. Opening the Physical Phenomena dialog
In the Physical Phenomena dialog you select the variables to be computed. In most cases temperature has to be computed first, because the computation of the other variables takes these results into account.

1. Select Settings > Physical Phenomena. The Physical Phenomena dialog opens:
2. As long as no region is selected, you are not able to activate any of the boxes. Move the mouse pointer to the region you want to select and press the **left mouse button**.

The region will be highlighted in the drawing. In the **Physical Phenomena** dialog the number of **region(s) selected** will change to 1 and **Temperature** will become active.

3. Depending on the region selected, the **Yes** box may be active or not. If not:
   - Click on the **Yes** box next to **Temperature** to set the prerequisite for its computation and click on **Apply** and **Close**.
   - or
   - If the box was already active and you did not change anything, click on **Close**.

---

**Related Procedures**

- Physical Phenomena (page 56)

**Related Dialogs**

- Physical Phenomena (page219 )

**9.1.3.2. Opening the Initial Values dialog**

Now we will look at some basic settings in the **Settings** menu: **Initial Values**, **Boundaries** and **Heaters**.

1. Select **Settings > Initial Values**.

The **Initial Values** dialog opens:
2. Although the initial value for temperature is more relevant for time-dependent than for pseudo-stationary computations, we ask you to change the value from 300 to 500 K. As for every change of parameters, you have to select at least one region first.

Move the mouse pointer to a region of your choice and press the left mouse button. The region will be highlighted in the drawing and the number of region(s) selected will change to 1 in the Initial Values dialog. The actual initial value is shown.

Or you can select the Select all regions button in the Initial Values dialog.

3. Select all regions by clicking on the Select all regions button in the Initial Values dialog. Then replace the default of 300 K by 500.

4. Click on Apply and Close, if you want to close the dialog.

Note
You can also click on OK to apply the change and close the dialog. But in practice you may have to change more than one value on more than one tab of the same dialog and want to keep the dialog open by clicking on Apply only.

Related Procedures
Initial Values (page 57)

Related Dialogs
Initial Values (page 57)

9.1.3.3. Opening the Boundaries dialog

1. The next dialog offers three types of temperature boundaries:
Select Settings > Boundaries.

The Boundaries dialog opens:

![Figure 9.7. Boundaries dialog for temperature](image)

2. In the LGF_prototype.crys file boundaries were set at all border lines. You can display them as follows:
Click on Show all.

Type and value of all boundaries set are displayed.
Figure 9.8. All boundaries displayed

The partial view of the furnace illustrates the kind of information you get:

Figure 9.9. Partial view of boundaries

3. Because you did not make any changes, only the **Close** button is active. Click on **Close** to close the dialog.

**Related Procedures**

- Boundary Conditions (page 58)

**Related Dialogs**

- Boundaries (page221 )

**9.1.3.4. Changing the heating power**

1. Select **Settings > Heaters**.
   The **Heaters** dialog opens:
2. Move the mouse pointer to the heater named **Booster** and press the **left mouse button** to select it.

The heater will remain highlighted and the relevant information is displayed in the dialog window: Region number 7, no fractions (1), resistance heater with an actual heating power of 70 W.

3. Replace the value 70 by 100 to raise the heating power.

4. Click on **Apply** and **Close**.

**Related Procedures**

Heaters (page 61)

**Related Dialogs**

Heaters (page 223)

### 9.1.3.5. Specifying growth rate in the Process parameters dialog

In this dialog some values relevant for particular settings are set, such as specifying the growth rate for pseudo-stationary computation or setting process parameters for travelling or rotating magnetic fields. Specifying the growth rate is necessary for pseudo-stationary simulations.

1. Select **Computation > Process parameters**.

The **Process parameters** dialog opens:
Figure 9.11. Process parameters dialog: General tab

2. The growth rate has to be specified in m/s. Replace the 0 by 0.001 for a growth rate of 1 mm per second.

3. Click on **Apply** and **Close**.

Related Procedures
Specifying growth rate in the Process parameters dialog (page 125) General process parameters (page 71)

Related Dialogs
General process parameters (page 231)

9.1.3.6. Changing the forward relaxation factor in the Numerical parameters dialog

In this dialog the convergence criteria for forward simulations are specified. One of them is the forward relaxation factor. At each iteration, when a new value is computed, only the fraction of the variation which is specified by the **forward relaxation factor**, will be taken into account.

1. Select **Computation > Numerical parameters**.
   The **Numerical parameters** dialog opens:

   Figure 9.12. Numerical parameters dialog, View factors tab
   
   The **Renormation** check box should be active for computing view factors.

2. Click on the **Forward** tab.
   The dialog for setting parameters for forward simulation opens:

   Figure 9.13. Numerical parameters dialog: Forward tab

3. Change the forward relaxation factor to 0.1.
4. Click on **Apply** and **Close**.
9.1.4. Computing temperature

View factors have already been computed and stored with this file, so you are ready to start the computation. The time required depends on the complexity of the furnace, the settings and the parameters specified.

1. Click on the **Start computation** button in the tool bar. In the status bar you can follow the progress of the computation.

2. Select **Computation > Show Solver Information**.
   The **Show Solver Information** window pops up. The current residuum is indicated and you can follow the residual curve:

   ![Figure 9.14. Show Solver Information: Residuals](image)

   3. This furnace is quite complex, so you might want to stop the computation.
      Click on the **Stop computation** button in the tool bar.

   4. Click on **Close** to close the **Show Solver Information** dialog.

9.1.5. Visualizing the calculated temperatures

You have two possibilities to visualize the temperature computation results: By scalar fields and isolines.

1. Click on **Show/hide scalar field** button. The scalar field will be displayed on the right furnace side.

2. Select **Visualization > Show**.

3. Click on **Legend** in the right column and **Scalar field** in the left column.
The scalar field will be displayed on both furnace sides and the legend showing the temperature intervals appears on the right furnace side.

![Figure 9.15. Scalar field and legend](image)

4. Now you enlarge the top part of the furnace for better recognition of the small regions in this complex LGF furnace.

Move the mouse pointer next to the top left corner of the furnace and hold in this position.

5. Press and hold the **left mouse button** and draw a rectangle which includes the complete top of the furnace.

6. Release the **left mouse button**. The cutout should look approximately like this:

![Figure 9.16. Partial view of furnace top](image)

7. Click on **Show/hide scalar field button**.

The scalar field and the legend are turned off on the right furnace side. The furnace is reset to its original size.
8. Click on the **Show/hide isolines** button \[\text{X}\].
Isolines are displayed on right furnace side, the scalar field only on the left side. For better recognition, you can enlarge the top of the furnace again.

9. Click on **Scalar field** in the **Show** dialog.

10. Click on the **Show/hide isolines** button \[\text{X}\].
Scalar field and isolines are turned off.

**Related Procedures**
- Zooming and Scrolling (page 10)
- Show results (page 105)
- Setting options for scalar fields (page 106)

**Related Dialogs**
- Show (page 251)
- Options for Scalar Fields (page 252)

**9.1.6. Writing isoline**

The **Analysis** menu offers a variety of data export facilities. The first option is writing an isoline.

1. Select **Analysis > Write Isoline**.
The **Write Isoline** dialog opens.
2. Change the temperature value for the isoline to 1000.

3. Click on **Apply** and **Close**.

   If you did not change the specification, *CrysVU*n will write the coordinates of the isoline to the file `LGF_prototype.iso` in the *CrysVU*n 's home directory.

**Related Procedures**

Write isoline (page 107)

**Related Dialogs**

Write Isoline (page254 )

### 9.2. Modifying the Sample Cartridge Assembly (SCA)

To determine the optimal thermal behavior of a cartridge during a simulation you have to modify the geometry of cartridge and sample, e.g. vary diameter and length of the sample. Furthermore, the geometry has to be modified, if you want to create additional regions for assigning more materials or to refine the mesh inside the furnace or the SCA.

In *CrysVU*n you usually change drawings rather than create them from scratch. You select elements and move them or you add points and lines. Editing geometries is only possible in Geometry Mode.

This tutorial explains the following tasks for changing geometries:

- Selecting the elements to be moved (page130 )
- Changing the sample size by entering exact values (page132 )
- Changing the sample size by drag and drop (page132 )
- Splitting a line (page133 )

#### 9.2.1. Selecting the elements to be moved

1. Select **File > Open**.

2. Select `LGF_Cartridge.crys` and click on **Open**.

   The LGF cartridge is displayed:

   ![Figure 9.19. LGF cartridge, Simulation Mode](image)

   *Figure 9.19. LGF cartridge, Simulation Mode*
When you move the mouse pointer over the SCA regions on the right side of the drawing, the material assigned to each region is displayed in the status bar. You will notice that the material assigned to the region in the middle of the tube is AlSi, which stands for the sample. If you want to enlarge the sample, you need to edit this region.

3. For editing the geometry you have to switch to Geometry Mode:
   Select **Mode > Geometry**.
   Only the right side of the furnace is now displayed in the **Main Window**, and you can see how the SCA is composed of points and lines:

   ![Image](image1.png)

   **Figure 9.20. LGF cartridge, Geometry mode**

4. Zoom in the area of interest by selecting the sample area with the **left mouse button**.

5. Now you select the points and lines you want to move. You can cancel the selection of points and lines in the same way you select them, or click **Edit > Unselect all** to cancel the selection of all selected elements.
   Select the bottom line of the sample region and the two points at the ends of the line by clicking on the points with the **right mouse button**. Your drawing should approximately look like this:

   ![Image](image2.png)

   **Figure 9.21. LGF cartridge, partial view**

   Now you are prepared to change the size of the sample.

**Related Procedures**
Related Dialogs

9.2.2. Changing the sample size by entering exact values

In CrysVuIn changing the size of a region means moving elements. You can move elements by entering exact values in the Move to dialog (this task) or by drag and drop, see Changing the sample size by drag and drop (page 132).

1. Select Edit > Copy/Move to.
   Copy/Move to dialog opens.

2. The next step is to enlarge the sample region from \( y(z) = 0.15450 \) m to \( y(z) = 0.13450 \) m with the use of the Move to dialog.
   You can do this by specifying the absolute z-coordinate (0.13450) or by specifying the relative z-difference (-0.02). The absolute entry is used here:
   Activate the absolute check box.

3. Activate the Change \( y(z) \) to check box and enter 0.13450.

4. Make sure that the Change \( x(r) \) to check box is not activated.
   Now the dialog window looks like this:

   ![Figure 9.22. Move-to dialog](image)

5. Click on OK.
   The selected points and the selected line are moved to the position with \( z = 0.13450 \) m.

Related Procedures

Moving elements via the Copy/Move-to dialog (page 17)

Related Dialogs

9.2.3. Changing the sample size by drag and drop

In CrysVuIn changing the size of a region means moving points and lines. You can move elements by drag and drop (this task) or by entering exact values in the Move to dialog, see Changing the sample size by entering exact values (page 132).
1. If the line and the two points are not selected any more: Select the line and the points with the right mouse button. If necessary, enlarge the drawing to get the same cutout as in the previous task.

2. Click in the Tolerance field, leave the mouse pointer in this field, and set the value to 0.004.

3. Confirm with Enter.
   The tolerance of the drawing has now changed to 0.004, which is 0.004 m = 4 mm

4. Click on the Toggle Raster button.
   The raster is displayed and activated with the size specified by the tolerance 0.004.

5. If you don't get the desired result while editing, select Edit > Undo.
   Click on the Move button.
   The Move button remains activated, and the function of the middle mouse button is to move selected lines and points.

6. Press and hold the middle mouse button on the selected line or points and move them to the original position at 0.15450.
   The selected line and points move with the mouse. Because the raster mode is on, they move in steps of 0.004 tolerance. As soon as you release the middle mouse button, the Move button becomes deactivated.

7. Click on the Toggle Raster button to turn the raster off, and click on the Zoom out button to reset the SCA to its original size.

Related Procedures
    Moving elements by drag and drop (page 18)

Related Dialogs
    Edit Menu (page209 )

9.2.4. Splitting a line
    If you want to divide a region or to compute different grids for line segments, you need to split one or more lines. For the purpose of this tutorial, we are going to divide the tube sec-
tion above the sample.

1. Move the mouse pointer to approximately \( r = 0.03 \) and \( z = 0.40 \) on the right side of the furnace.

2. Press and hold the **middle mouse button**.

3. Draw a horizontal line by moving the mouse to approximately \( r = 0.03 \) and \( z = 0.40 \) on the left side of the furnace.

4. Release the **middle mouse button**.
   The new line splits the tube. At the intersections new points are created which split the crossed lines automatically.

![Figure 9.24. Line intersecting the tube](image)

5. Enlarge the intersected area by drawing a rectangle with the **left mouse button**.
   You can see that the tube wall is a separate region, which was also intersected. We want only the interior of the tube to be split and no salient line segments.

![Figure 9.25. Enlarged section of the cartridge](image)

6. Select the right end point of the new line and the salient segment of the line with the **right mouse button**.

7. Click on the **Delete** button.
   The line and the end point vanish from the drawing.

8. Repeat steps 6 and 7 for the salient part of the line on the left.
9. Enlarge the section of the drawing as long as you can select the line segment inside the right region.

The drawing should look approximately like this:

![Figure 9.26. Further enlarged section of the cartridge](image)

10. Select the right end point of the line and the line intersecting the right region with the right mouse button.

11. Click on the **Delete** button.

12. Click on the **Zoom out** button to reset the SCA to its original size.

The upper tube of the SCA has been intersected.

![Figure 9.27. Intersected upper tube of SCA](image)

**Related Procedures**

- Splitting lines (page 16)

**Related Dialogs**

- Edit Menu (page209 )

**9.3. Handling Materials**

When switching to Materials Mode the points and lines turn into regions. If you have a new geometry, materials must be assigned to each of these regions, before you can start computation. If only some regions were modified in Geometry Mode, as we did in the Tutorial
Modifying the Sample Cartridge Assembly (SCA) (page 130), then only the regions changed need to be taken care of. For simulation not only assigning materials is important, but also changing material properties. Therefore the subjects of this tutorial are:

- Adding a material to the furnace (page 136)
- Assigning materials (page 138)

### 9.3.1. Adding a material to the furnace

The most important source for materials is the material database, usually supplied with CrysVuUn. The material database is loaded at program start. From this database you can copy materials to your furnace. These materials are saved into the *.crys file together with the geometry and all other settings.

1. **First you load a *.crys file:**
   Select **File > Open**.

2. **Select VGF_prototype.crys and click on Open.**
   The furnace VGF_prototype is displayed:

   ![Figure 9.28. VGF_prototype, Simulation Mode](image)

3. **The **Database** dialog is opened via the **Materials** dialog in the **Settings** menu.**
   Select **Settings > Materials**.
   The **Materials** dialog opens.
Figure 9.29. Materials dialog

4. Click on the Database button underneath the materials list. The Database dialog opens and the materials available in the material database and the furnace are displayed.

5. Select Fancy in the material database list (on the left). Fancy is highlighted in the list.

6. Click on the button to copy Fancy to your furnace. Fancy appears in the list of local materials (on the right).

7. Click on Apply.

The material Fancy is saved to the furnace’s list of materials. Its properties can be displayed in the Materials dialog, but not changed, because the material is locked.

8. Click on Close to close the Database dialog and return to the Materials dialog.

9. In case you need a material like Fancy with changed properties, you have to add a new one based on initial material. Select Fancy in the materials list (on the left). Fancy is highlighted in the list and displayed in the Material name field above the list.
10. Replace *Fancy* in the *Material name* field by *Crucible support* and press *Enter*. *Crucible support* will be added to the materials list inheriting the properties from *Fancy*.

11. You may transfer the new material to the material database. Open the *Database* dialog by clicking on the *Database* button in the *Materials* dialog.

12. Select the material *Crucible support* from the list of local materials.

13. Click on .

   The material *Crucible support* is added to the material database.

14. Click on **Apply** and **Close** to save the changes and to close the *Database* dialog.

15. Click on **Apply** and **Close** to save the changes and to close the *Materials* dialog.

**Related Procedures**

- Copying materials from the material database to the furnace (page 28)
- Modifying Materials Properties (page 32)

**Related Dialogs**

- Database (page 214)

### 9.3.2. Assigning materials

Materials have to be assigned for two reasons: Geometry is new or was changed (white regions) or a material shall be replaced, which is subject of this task.

1. For assigning materials you have to switch to Materials Mode. Select **Mode > Materials**.

   Because you opened the *VGF_prototype.crys*, the materials assigned to the regions of the VGF furnace are displayed for the right half of the geometry. Each material has a specific color, which is randomly assigned in alphabetical order. If you add a material in the beginning of the list, all following materials will change their colors in the drawing.
2. The list box in the tool bar contains all materials available. The material displayed in the tool bar is the one which will actually be assigned when you select a region and click the mouse button. But first let us have a look which materials were assigned to which region.

Click on the Show/hide legend button next to the list box to display the legend.

3. Now you replace the material Steel by Crucible support in the furnace region below the crucible.

Select Crucible support in the list box in the tool bar.

Steel is ready to be assigned.

4. Move the mouse pointer to the region of the crucible support and stay there.

The material Steel is indicated in the status bar. Pay attention to the material colors before you proceed.

5. Press and hold the CTRL key and press the left mouse button.
The material name has changed to **Crucible support** in the status bar. Crucible support has been added to the legend. The color of the crucible report has changed in correspondence with the new material.

6. The material **Fancy** is not used, so you can delete it.
   Select **Settings > Materials** to open the **Materials** dialog.

7. Select **Fancy** in the materials list.

8. Click on the **Delete Material** button. If the material is still assigned, you get a warning message, and the material is not removed.
   **Fancy** is removed from the current simulation setting.

9. Click on **Close** to close the **Materials** dialog.

10. Select **Mode > Simulation** to switch to Simulation Mode.

**Related Procedures**
- Assigning Materials to Regions (page 37)
- Deleting a material (page 30)
- Modifying Materials Properties (page 32)

**Related Dialogs**
- Materials (page 213)

**9.4. Running an Inverse Simulation**

By inverse simulation you can determine the temperature at given points in the furnace, e.g. the heating power necessary for the solid-melt interface to be in a certain position. To solve the inverse problem you need to determine one or more heaters for which **CrysVUn** shall compute the heating power and define control points.

For inverse simulations you perform the following tasks:

- Defining heaters (page 141)
- Defining control points (page 142)
- Setting computation parameters and starting inverse simulation (page 144)
9.4.1. Defining heaters

Prerequisites

*CrysVUn* is running and the file *VGF_prototype_inverse.crys* is open.

1. Select **Settings > Heaters**.
   
The **Heaters** dialog opens.

![Figure 9.35. Heaters dialog](image)

2. At first you determine the heater for which *CrysVUn* shall compute the heating power.
   
   Please note that **Heater_1** has position No. 0!
   
   Select the **Heater_2** at position 1 from the list in the **Heaters** dialog.
   
The heater at the right side of the SCA will be highlighted in the drawing.

3. Next you change the type of setting for this heater, because you want *CrysVUn* to compute the heating power required to reach a particular temperature at a particular point.
   
   Click on **Controlled power**.
   
   *CrysVUn* opens two additional fields for specifying the minimum and the maximum for the controlled power.

4. Repeat this procedure for Heater_1.

5. Click on Apply to keep the default setting.

6. For demonstration purposes start the computation now.
   Click on the Start computation button while keeping the Heaters dialog open.
   While CrysVUn computes temperature, you can follow the changing heating power for Heater_2 in the field Initial/actual value.

   ![Heaters dialog](image)

   Figure 9.37. Heaters dialog: Result for controlled heating power

   The resulting heating power for Heater_2 is 933.476 K.

7. Click on Apply and Close to close the Heaters dialog.

### Related Procedures

Heaters (page 61)

### Related Dialogs

Heaters (page 223)

### 9.4.2. Defining control points

After you have set at least one heater to Controlled power, you have to specify Control Points defining which temperature should be reached at which point(s) inside the furnace. Control points can only be defined for temperature.

1. Select Settings > Control Points.
   The Control Points dialog opens.
Three control points have been defined already by their coordinates \((r, z)\), the temperature value to be reached, and the tolerance in degree Kelvin.

2. When you click on one of the control points, its position will be indicated in the drawing by a red cross.
   
   Click on the last control point in the list.
   
   The control point is located at the SCA border immediately above the melting interface.

3. Next you define a new control point located below the last control point.
   
   Because control point No. 2 at the SCA border is still active, you only have to change the \(z\)-coordinate.
   
   Change the \(z\)-coordinate to 0.24.

4. Set the tolerance to 1.

5. Set the temperature to 1505 K.

6. Click on **Add**.
   
   The control point is added to the list.

You can add as many control points as you need and you can also define them relative to each other.

**Related Procedures**

- Control Points for Inverse Simulation (page 64)
- Control Points (page 225)
9.4.3. Setting computation parameters and starting inverse simulation

Controlled heater(s) and control points are the minimum settings for inverse simulation. In addition, you can specify computation parameters, e.g. the growth rate in the Process parameters dialog and the parameters on the Inverse tab in the Numerical parameters dialog.

1. For pseudo-stationary computation you can specify the growth rate of the crystal.
   Select Computation > Process parameters.
2. The growth rate has to be specified in m/s. If you want a growth rate of 1 mm per second, your input would be 0.001.
   Change the growth rate to 0.0001, i.e. 0.1 mm per second.
3. Click on Apply and Close to apply the changes and close the Process parameters dialog.
4. Select Computation > Numerical parameters > Inverse.
5. Replace the Controller relaxation factor default by 0.1.
6. Click on Apply and Close to apply the changes and close the Numerical parameters dialog.
7. Click on the Start computation button ⊞. 
   CrysVuN indicates the computation progress in the status bar.

Related Procedures
- General process parameters (page 71)
- Setting parameters for inverse simulation (page 81)

Related Dialogs
- Inverse (page 237)

9.4.4. Visualizing the results of inverse simulation

After computation has finished, you can visualize the results via the Show dialog.

1. Select Visualize > Show.
   The Show dialog opens.
2. Select Isolines and Scalar field in both columns of the Show dialog.
3. Select Legend in the right column.
   Isolines and scalar field are displayed for both sides of the furnace, the legend on the right hand side only.
The legend explains the exact temperature distribution inside the furnace.

4. The default number of isolines is 11. Change it to 20 to get a finer distribution of temperature values.

Select **Visualization > Options for Scalar fields.**

The **Options for Scalar Fields** dialog opens.

5. Change the number of isolines to 20 and click on **Apply.**

The display of the isolines changes in the dialog and in the main window simultaneously.
The figure shows that the graduation refinement concerns only regions outside the SCA. Therefore, increasing the number of isolines has mostly limited practical use.

6. Reset the number of isolines to 11 and click on Apply.
   The number of isolines respectively temperature intervals is reduced in the drawing and in the legend.

7. Click on Close to close the Options for Scalar Fields dialog.

Related Procedures
Setting options for scalar fields (page 106)

Related Dialogs
Options for Scalar Fields (page252)

9.4.5. Writing isolines and profile
In inverse simulation the main focus is to determine the temperature for each heater. The options in the Analysis menu allow you to save the temperature along an isoline, for points, for polylines and for rectangles.

1. Select Analysis > Write Isoline.
   The Write Isoline dialog opens.

2. Specify respectively change the default value for temperature to 1510 which is the position of the phase interface.

3. The system suggests to save the data in the File VGF_prototype_inverse.iso.
   You can change the name or browse for a different file.
   Click on Apply and Close to close the Write Isoline dialog.
   The position of the interface will be indicated in the drawing. The coordinates are written into the specified file which is saved to the CrysVUn home directory.

4. Select Analysis > Write Profile.
   The Monitor/Write Profile dialog opens.

5. The three points you are going to define belong to the heaters.
Specify the coordinates of the first point in the input fields for $r$ and $z$: $r = 0.06$, $z = 0.23$.

6. Click on **Add**.

The information for the first point is displayed in the upper field: Position No., the coordinates, the status N (not moving, because we have no moving region) and the variables.

7. Add two more points with the coordinates $r = 0.02$, $z = 0.375$ and $r = 0.06$, $z = 0.69$.

8. Click on **Apply** and **Close**.

### Related Procedures

- Write isoline (page 107)
- Monitor/Write Profile (page 108)

### Related Dialogs

- Write Isoline (page 254)
- Points (page 255)

### 9.5. Computing a Time-dependent Simulation

For computing time-dependent simulations you do not only need to select the full implicit time-model, but also to set boundaries and define heating profiles to keep the computing time in reasonable limits.

In this tutorial you perform the following tasks:

- Selecting the time-model (page 148)
- Defining boundaries (page 149)
- Defining heaters in time-dependent computation (page 150)
- Defining monitor points for writing profiles (page 151)
• Setting computation parameters and starting time-dependent simulation (page 152)

9.5.1. Selecting the time-model

1. Select File > Open.

2. Select VGF_prototype_stationary.crys and click on Open.

3. Select Computation > Time Model.
The Time Model dialog opens.

4. Select Full implicit from the list box next to Time Model.
The input fields for specifying the parameters for time-dependent computation become active.

5. Start time, stop time and the time step are obligatory and must be specified in seconds.
Type the following parameters in the respective fields: Start time: 0, Stop time: 200, Time step: 5, Max. time step: 5.

6. Click on Apply and Close.

Related Procedures
9.5.2. Defining boundaries

In time-dependent computation boundaries can have different values at different time steps. CrysVUn reads the temperature values from a profile file which has the following structure:

<table>
<thead>
<tr>
<th>col 1 (time)</th>
<th>col 2 (point 1)</th>
<th>col 3 (point 2)</th>
<th>col 4 (point 3)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0.2</td>
<td>0.5</td>
<td>0.7</td>
</tr>
<tr>
<td>3</td>
<td>300</td>
<td>350</td>
<td>370</td>
</tr>
<tr>
<td>5</td>
<td>320</td>
<td>350</td>
<td>350</td>
</tr>
<tr>
<td>8</td>
<td>350</td>
<td>350</td>
<td>330</td>
</tr>
</tbody>
</table>

The 1st column contains the time, the 1st line the position of the points. This line must be in the file, even though you do not need any points along the line. In this case set one virtual point having the position 0.

The boundary values between the time steps will be automatically calculated by interpolation.

**Tip**

If you do not know the coordinates of the start point, you can find them using the writing profile utility, see Monitor/Write Profile (page 108).

1. Select **Settings > Boundaries**.

   The **Boundaries** dialog opens.

   ![Figure 9.47. Boundaries dialog](image)

2. Move the mouse pointer to the line furthest right in the drawing and press the **middle mouse button** to select the line.

   The line will be highlighted in the drawing and the dialog window indicates: **1 line(s) selected**.

3. Click on the box next to **Dirichlet** in the field **Type**.
The input field for parameters becomes active, but you are not going to enter a value, because you want to use a profile file.

4. Click on **Profile** option.

   Now you can specify the profile file and the column where *CrysVUn* finds the boundary condition.

5. Browse for the file Profile1.pro to be found in *CrysVUn*’s DATA directory and select it.

   ![Figure 9.48. Boundaries dialog, profile file](image)

   The file name will appear in the **file name** field of the **Boundaries** dialog window.

6. Set the **column** value to 2.

7. Click on **Apply** and **Close**.

**Related Procedures**

- Boundary Conditions (page 58)

**Related Dialogs**

- Boundaries (page 221)

**9.5.3. Defining heaters in time-dependent computation**

Heaters can have different power values during the runtime. These values must be read in from a profile file which has to be specified in the **Heaters** dialog.

1. Select **Settings > Heaters**.

   The **Heaters** dialog opens.
2. Select Heater_2 (position No. 1) in the list. The heater on the right hand side will be highlighted in the drawing.

3. Click on the box next to Profile power in the field Type of heater setting. The input fields for file name and column become active.

4. Browse for the file Profile2.pro to be found in CrysVu'n's Examples directory and select it. The file name will appear in the field file name of the Heaters dialog window. Set the col value to 2.

5. Click on Apply and Close.

**Related Procedures**
Heaters (page 61)

**Related Dialogs**
Heaters (page223 )

**9.5.4. Defining monitor points for writing profiles**
In time-dependent computation it is hard to follow the results on the screen. Therefore you
should define monitor points in the **Monitor/Write Profile** dialog.

1. Select **Computation > Monitor**.
   The **Monitor/Write Profile** dialog opens.

2. You will define the coordinates of the heater on the right side as monitor points.
   Specify the coordinates of the heater as monitor points, see Writing isolines and profile (page 146).
   In the lower field the point coordinates and the associated temperature values are displayed.

   ![Monitor/Write Profile dialog, heater coordinates](image)

   *Figure 9.51. Monitor/Write Profile dialog, heater coordinates*

   The results are saved every 3rd time step to the file `VGF_prototype_stationary_p.mon` in the same directory where `VGF_prototype_stationary.crys` is and specify the temperature at a certain time.

3. Click on **Apply** and **Close**.

**Related Procedures**
Monitor/Write Profile (page 108)

**Related Dialogs**
Points (page 255)

**9.5.5. Setting computation parameters and starting time-dependent simulation**

Before you can start computing, you have to check respectively set two parameters in **Computation** menu.

1. For full implicit computation you have to set the growth rate of the crystal to 0.
   Select **Computation > Process parameters**.

2. In any time-dependent computation the growth rate must be set to 0! Otherwise the results will be wrong.
   Change the growth rate to 0.
3. Click on Apply and Close to apply the changes and close the Process parameters dialog.

4. Select Computation > Numerical parameters > Inverse.

5. For time-dependent computation any relaxation factor should be set close to 1. Replace the Controller relaxation factor default by 0.9. Also replace the Forward relaxation factor by 0.8.

6. Click on Apply and Close to apply the changes and close the Numerical parameters dialog.

7. Click on the Start computation button. CrysVUn indicates the computation progress in the status bar.

Related Procedures
Specifying growth rate in the Process parameters dialog (page 125)
General process parameters (page 71)
Setting parameters for inverse simulation (page 81)

9.6. Computing a Time-dependent Simulation with Moving Regions
Moving regions belong to the Sample Cartridge Assembly (SCA). The assumption is that either the sample or the cartridge or both are moving inside the furnace.
The tutorial comprises two parts:

- Setting parameters for time-dependent simulation (page 153)
- Defining a moving region (page 154)

Most of the parameters for time-dependent computation are already set and should not be changed.

9.6.1. Setting parameters for time-dependent simulation
Except for defining the moving region(s) themselves many parts of this tutorial are identical with the tutorial Computing a Time-dependent Simulation (page 147) where the following steps are described more detailed.

1. Select File > Open.

2. Open the file Moving_region.crys in CrysVUn’s EXAMPLES directory. The LGF furnace will be displayed.

3. Select Computation > Time Model and set the time-model to Full implicit.

4. Do not change the defaults for Start time, Stop time, time step and the other parameters.

5. Click on Apply and Close.


7. Select all outer edge lines of the furnace by holding the CTRL key pressed and press-
The whole Sample Cartridge Assembly shall move. Therefore all regions have to be selected.

Press and hold the CTRL key. Move the mouse pointer to one SCA region after the other and press the left mouse button.

6 regions will be highlighted in the drawing. If there are less, enlarge the SCA and se-

![Moving Regions dialog](image)

The dialog window indicates 6 region(s) selected.

3. You have to turn the selected region(s) explicitly into moving regions by checking the Fixed velocity option in the Moving type box.

4. Next you need to specify a fixed velocity in z-direction. A positive value means that the SCA moves up, a negative value that it moves down.
   You have to specify a velocity in either direction, otherwise the property moving will not be preserved!
   Type -0.0001 in the input field for z-velocity.
   Click on Apply and Close.

5. Press the left mouse button outside the drawing to cancel the selection of the regions.

6. Now you can ascertain that all required regions have been defined as moving. This is also an easy way to find out whether moving regions have been defined or not.
   Reopen the Moving Regions dialog by selecting Settings > Moving Regions.

7. Click on select all moving regions.
   All 6 moving regions should be now highlighted in the drawing. If not, repeat steps 1 to 4.

8. Click on Apply and Close.

9. The contact line between the moving region and the fixed region has to get the label “sliding”, if a moving region is in direct contact to a fixed one which should not be distorted (e.g. a sealing). Here there is no such line, so you dont need to specify a label.

Now you are ready to start the computation as described in the tutorial Running a Thermal Analysis (Quick Start) (page 118).

**Related Procedures**
- Moving Regions (page 66)

**Related Dialogs**
- Moving Regions (page226 )
9.7. Computing Pseudo-stationary and Time-dependent Convection

Prerequisite for computing convection is that temperature has been computed before. The computation can be time-consuming, and you usually have to change parameters several times for approximating the real parameter values. This tutorial will familiarize you with the procedure in general.

The following tasks are involved in computing convection:

- Defining materials properties (page 156)
- Defining grid properties (page 157)
- Setting boundary conditions (page 158)
- Setting convection parameters (page 159)
- Setting parameters for computing time-dependent convection (page 162)
- Computing convection (page 162)

9.7.1. Defining materials properties

For computing convection you need a sample material with a fluid 2nd phase.

Prerequisites

The file Convection.crys must be open.
Temperature must have been computed.

1. Select Settings > Materials.
   The Materials dialog opens.

2. Select the material GaAs from the materials list.
   The properties of the material GaAs are displayed in the right field of the dialog window. Right now, the material has only one phase.

3. Click on Add Phase in the Materials dialog window.
   The new Phase 1 of the material GaAs is displayed and inherits the properties of Phase 0.

4. Next you specify the properties of GaAs for Phase 1.
   See Keys for editing material properties (page 261) for easy editing of the materials properties fields.
   Change the general property State by selecting Liquid from the list box.

5. Change the Conductivity -r to 17.8 in the Phase 1 column.

6. Make sure that the value for the melting point is 1511 K in Phase 0.
   Specify the Melting point by typing 1511 K in the Phase 0 column, if necessary.

7. Specify the Viscosity by typing 0.0279 in the Phase 1 column.

8. Specify the Volumetric expansion coefficient by typing 2.e-4 into the associated Phase 1 column.

9. Click on Apply and Close.
The position of the interface is indicated in the furnace drawing.

Related Procedures
Modifying Materials Properties (page 32)

Related Dialogs
Materials (page 213)

9.7.2. Defining grid properties
Convection is only computed for the region of the sample. Try to solve convection on a coarse grid in the beginning as is set for the rest of the furnace. If necessary, refine the grid for the region of the sample, in particular at the velocity boundaries.

The following grid parameters produce a reliable grid for computing convection.

1. Select the convective region of the sample with the left mouse button.
2. Select Settings > Grid.
   The Grid dialog opens.

   ![Figure 9.53: Grid dialog]

3. Replace the Edge length of the region by 0.0015.
4. Replace the Fit slope by 0.3.
5. Replace the Edge length of the line by 0.01. Since no line is selected, this is taken as the default value for all lines.
6. Click on Apply.
7. Click on the Generate grid button.
   The grid will be recomputed. Because a grid already existed, the system will ask you, whether you want to recompute the entire grid or only for the selected region.
Figure 9.54. Grid warning

If your answer is no, the grid will only be computed for the region of the sample. Before starting the actual computation, it is recommended to generate the whole grid once by clicking yes.

8. Click on the **Show/hide grid** button.

The result is a very fine grid in the region of the sample.

![Figure 9.55. Partial view of the grid in the region of the sample](image)

9. Click on **Close** to close the grid dialog.

10. Click on the **Show/hide grid** button to turn off the display of the grid.

11. Click on the **Zoom out** button to reset the furnace to its original size.

**Related Procedures**

Changing the Grid parameters (page 54)

**Related Dialogs**

Grid (page219)

### 9.7.3. Setting boundary conditions

Boundaries have to be specified for velocities, before convection is computed.

1. Press and hold the **CRTL** key and select the inner border lines of the sample (GaAs) with the **middle mouse button**.

2. Select **Settings > Boundaries**.

The Boundaries dialog opens.
3. If the boundaries for temperature are displayed, select the variable \textit{UVW} from the list box in the dialog window.
   Click on the box next to \textbf{Zero velocity} in the field \textbf{Type}.

4. Click on \textbf{Apply} to set the boundaries.

5. Click on the box next to \textbf{show} in the dialog window.
   The velocity boundaries are displayed in the drawing. If you click on the box next to \textbf{show all}, the temperature boundaries are displayed as well.

6. Click on the box next to \textbf{hide} to turn the display of the boundaries off.

7. Click on \textbf{Close}.

\textbf{Related Procedures}

Boundary Conditions (page 58)

\textbf{Related Dialogs}

Boundaries (page221 )

\subsection*{9.7.4. Setting convection parameters}

The \textbf{Convection parameters} dialog enables you to define abortion criteria, intervals for updating the grid and the view factors, ramps and solvers. The 4 tabs of this dialog correspond to these purposes: \textit{Abortion, Multiphase, Ramps} and \textit{Solver}.

1. Select \textit{Computation > Convection parameters}.
   The \textbf{Convection parameters} dialog opens.
The defaults in this dialog were obtained from experience and produce reasonable results.

2. Change the specified interval to a constant underrelaxation factor by entering the same value 0.2 in the first two input fields for Underrelaxation Velocity factors (inc. from 0.2 to 0.2 between 10 and 0.01).

3. Click on Apply.

4. Click on the Multiphase tab.

The Multiphase dialog opens.

5. On the Multiphase tab you specify the momentum when the grid should be adjusted to the position of the interface.

Change the Momentum to 0.4.

6. Click on Apply.

7. Click on the Ramps tab.

The Ramps tab opens.
8. If you start from scratch and do not want to change the properties in the Materials dialog every time, you can run a ramp to approximate the real values. It is possible to run density, capacity and viscosity ramps.
   Click on the box in front of run a viscosity ramp to activate this function.

9. Now you have to define steps for lowering viscosity.
   Replace the default start factor viscosity by 40 and the multiply factor per step by 0.8.

10. Click on Apply.

11. Click on the Solver tab.
    The Solver dialog opens.

12. computation by clicking the Start computation button.
    Click on Close.

Related Procedures
Setting Convection parameters (page 84)

Related Dialogs
Convection parameters (page240)
9.7.5. Setting parameters for computing time-dependent convection

The settings concerning sample material, grid, boundaries as well as most of the convection parameters are identical for pseudo-stationary and for time-dependent convection. However, the general settings for time-dependent simulation have to be specified.

1. Specify parameters for viscosity, grid and boundaries as described for pseudo-stationary computation in the previous tasks of this tutorial.
2. Select the full implicit time model from the list box in the Time Model dialog in the Computation menu.
3. Select Settings > Heaters and specify the controlled heater setting.
4. Click on Apply and Close.
5. Select Control Points > Settings menu and specify control points, if necessary.
6. Click on Apply and Close.
7. Select Computation > Monitor and specify monitor points or polylines, if necessary.
8. Click on Apply and Close.
9. The only convection parameter to be especially adapted for time-dependent computation is the underrelaxation factor. It should be closer to 1. Specifying ramps in time-dependent computation does not make any sense and the solver defaults should not be changed.
   Select Computation > Convection parameters > Abortion tab.
10. Define the interval for Underrelaxation Velocity factors by typing 0.6 in the first and 0.8 in the second input field.
11. Click on Apply and Close.

Now you are ready to compute time-dependent convection.

Related Procedures
Computing a Time-dependent Simulation (page 147)

9.7.6. Computing convection

The computation process is the same for pseudo-stationary and time-dependent computation.

1. Select the region of the sample in the drawing.
2. Select Settings > Physical Phenomena.
   The Physical Phenomena dialog opens and indicates 1 region(s) selected.
3. In the Physical Phenomena dialog CrysVUln offers all variables which can be computed with the current settings, if temperature has been computed already. You have to select the variables you want to be computed in this dialog!
   In this case Convection and Azimuthal Flow can be selected, but we only want to compute Convection.
   Set Convection to Yes by clicking on the associated box, if it is not preselected.
4. Click on **Apply** and **Close**.

5. Select **Convection** from the variable group list box in the tool bar. The default variable for visualizing results is **VelocityU**.

6. Select **Computation > Start Computation**.  
   or  
   Click on the **Start computation** button in the tool bar.  
   You can follow the solving process in the status bar. When computing is finished, you can visualize the results.  
   If the solving takes longer than you expected, you can stop computation by clicking on the **Stop computation** button.

7. Select **Convection** from the **Variable group** list box and **VelocityV** from the variable list box.

8. Select **Visualization > Show** and click on the box next to **Legend**.

9. Click on the **Show/hide scalar field** button to display the scalar field.

10. Click on the **Show/hide vector field** button to display the vector field.

11. Click on the **Zoom out** button to reset the furnace to its original size.

12. Click on the **Show/hide scalar field** button and on the **Show/hide vector field** button to turn off the display of both.

13. Select **File > Close** to close the file.

### 9.8. Computing Turbulent Gas Convection

Besides setting general parameters, like boundaries or material properties, for computing turbulent gas convection you also need to adjust the numerical mesh.

---

*Figure 9.61. Visualizing Velocity V, upper right corner of the crucible*
This tutorial uses turbulence.crys file in order to simulate turbulent gas convection in a Czochralski furnace containing argon at the pressure of 3 atmospheres.

### 9.8.1. Adjusting the grid

For computing turbulent convection you need a special numerical mesh in the turbulent boundary layer.

**Prerequisites**

The default mesh must have been generated before starting this procedure.

1. Select **Settings > Grid**.
   The Grid dialog opens. You have to set the recommended grid parameters.

2. Set grid properties inside the gas region.
   - Select the gas region with the **left mouse button**.
   - Replace the **Edge length** of the region by 0.015.
   - Replace the **Fit slope** by 0.15.
   - Click on **Apply**.

   Set grid properties for gas-solid boundary lines.
   - Select all gas-solid boundary lines with the **Ctrl + middle mouse button**.
   - Replace the **Edge length** of the lines by 0.003.
   - Click on **Apply** and **Close**.

   ![Figure 9.62. Grid dialog, recommended parameters.](image)

3. Click on the **Generate grid** button.
   The grid will be recomputed. Because a grid is already existing, the system will ask you, whether you want to recompute the entire grid or only for the selected region. Before starting the actual computation, it is always recommended to compute the entire grid. Click on **Yes**.

4. Select **Settings > Physical Phenomena**.
   The **Physical Phenomena** dialog opens.
5. Activate the computation of turbulent convection in the gas region.
   - Select the gas region with the left mouse button.
   - Check Yes option for Convection and Turbulent Convection.
   - Click on Apply and Close.

6. Select Computation > Adapt Grid.
   The Adapt Grid dialog opens.
   
   ![Adapt Grid dialog](image)
   
   Figure 9.63. Adapt Grid dialog

7. Select adapt for physical phenomena option and choose turbulent_energy.
   Select distance last node - boundary and set the value to 0.001.

8. Click on the Show/hide grid button to show the grid.

9. Click on Apply and Close.
   The result is a deformed grid at the gas-solid boundary.

![Figure 9.64. The grid before adaption](image)

![Figure 9.65. The grid after adaption](image)

Related Procedures
The present turbulence model is appropriate for an ideal gas flow. The density of the ma-
terial will be calculated locally from the actual process pressure, nodal temperature and
the molecular weight using the ideal gas law. The density value prescribed directly for the
material will be not used in case of the ideal gas any longer.

1. Select **Settings > Materials**.
The **Materials** dialog opens.

2. Select the material **argon** from the materials list.
The properties of the material **argon** are displayed in the right field of the dialog win-
dow.

3. Change the **Ideal gas** property to **Yes**.

4. Set the **Molar weight** to 0.03788 kg/mol.

5. Click on **Apply** and **Close**.

6. Select **Computation > Process Parameters**.
The **Process Parameters** dialog opens.

7. Set the **Gas pressure** to 300000 N/m².

8. Click on **Apply** and **Close**.

**Note**
The gas material should consist of the single phase.

**Related Procedures**
Changing fluid properties (page 36)

**Related Dialogs**
Materials (page213 )

### 9.8.3. Setting initial values
Default values for initialization of the turbulent energy and eddy dissipation fields are avail-
able and will be applied at the beginning of a new calculation. The initial values may be
overridden by the user at the beginning of the calculation.

1. Select **Settings > Initial Values**.
The **Initial Values** dialog opens.

2. Select the gas region with the **left mouse button**.
3. Select **turbulent_energy** from **Variables** list.

4. Set the **Initial value** to 0.001.

5. Select **selected variable** from **Refresh** group.

![Figure 9.66. The grid before adaption](image)

6. Click on **Apply**.

7. Select **eddy_dissipation** from **Variables** list.

8. Set the **Initial value** to 1e-06.

9. Click on **Apply** and **Close**.

**Related Dialogs**

Initial Values (page 220)

**9.8.4. Setting boundary conditions**

All usual boundary conditions for the fluid flow calculation should be set also by the calculation of the turbulent convection. Typical settings are **UVW = Zero velocity**, that means that a no slip boundary condition for the velocity is applied. No additional boundary conditions for the turbulence values are necessary by the calculation of the turbulent flow. The turbulence model of CrysVUn finds and sets all necessary data for the turbulence boundary conditions on the basis of the existing boundary conditions for the momentum transport automatically. The normal types of the boundary conditions are zero value and zero flux correspondingly for the eddy dissipation and the turbulent energy at all gas-solid boundaries.

1. Select all boundary lines of the argon region, excepting the symmetry axis, with the **Ctrl + right mouse button**.

2. Set **Zero velocity** boundary type for **UVW** variable to all selected lines as described for convection computation, see Setting boundary conditions (page 158).

**9.8.5. Setting numerical parameters**

Besides the specific convection parameters, the gas flow computation also requires special settings for temperature equation.
1. Select **Computation > Numerical Parameters > Forward**.

2. A typical turbulent flow can be calculated with the underrelaxation factor for the temperature equation less or equal to 0.1.
   Set the **Forward relaxation factor** to 0.1.
   Click on **Apply** and **Close**.

3. Select **Computation > Convection Parameters**.

4. Set the **Underrelaxation Velocity factors: inc.from 0.1 to 0.2**.
   Click on **Apply**.

5. Select the **Turbulence** tab.

6. Set the turbulence underrelaxation factors.
   - set **Turbulent energy** to 0.1.
   - set **Eddy dissipation** to 0.1.
   - set **Turbulent viscosity** to 0.08.

7. Set the linear equations parameters.
   - set **Max. inner iterations** to 100.
   - set **Desired residuum** to 1e-05.
   - set **Set last triangle** to 0.5.

8. Click on **Apply** and **Close**.

**Related Procedures**

Setting turbulent convection parameters (page 88)

**Related Dialogs**

Turbulence (page244 )

**9.8.6. Computing turbulent convection**

The turbulent flow will be computed if turbulence model is activated at least in one region and either **Convection** or **Turbulent Convection** is selected to be currently computed in CrysVUn.

**Prerequisites**

The computation of the turbulent flow requires any start solution. The temperature distribution without account of the turbulent convection should be calculated. This start solution should not necessarily fully converge.

A short run with the laminar gas flow should be done before the turbulence modeling begins. At the beginning of the laminar fluid flow calculation the edge values of the temperature in the gas region will be allocated. These values are used also in the turbulent gas flow.
Start computation

1. Select the argon region in the drawing.
2. Select Settings > Physical Phenomena.
   The Physical Phenomena dialog opens and indicates 1 region(s) selected.
3. Set Turbulent Convection to Yes by clicking on the associated box, if it is not preselected.
4. Click on Apply and Close.
5. Select Turbulent Convection from the variable group list box in the tool bar.
   The default variable for visualizing results is turbulent_energy.
   or
   Click on the Start computation button in the tool bar.
   You can follow the solving process in the status bar. When computing is finished, you can visualize the results.
   If the solving takes longer than you expected, you can stop the computation by clicking on the Stop computation button.

Visualizing results

The variables of the turbulent flow can be shown by selecting them, as usual, from Turbulent Convection group. They are shown by isolines and/or by the colored filled polygons.

![Figure 9.67. Showing turbulent energy](image1)
![Figure 9.68. Showing turbulent viscosity](image2)

All variables which are distributed over the triangle by quadratic shape functions are visualized using additionally the variables allocated in the middles of the edges. In this case each triangle is subdivided into 4 sub-triangles virtually. The field distribution is assumed to be linear within each sub-triangle created by the middle points of the edges and the triangle corners.
9.9. Computing Thermoelastic Stress

Once temperature has been computed, CrysVUn can compute von Mises stress and other stress coefficients. Prerequisite is that stress constants have been specified for the material of the sample.

The following tutorial task exemplifies the procedure:

- Setting parameters and starting the computation of stress (page 170)

The stress-strain relationship for a Thermoelastic anisotropic solid body in cylindrical coordinates and for the axisymmetrical case is defined as follows:

\[
\begin{bmatrix}
\sigma_{rr} \\
\sigma_{\phi\phi} \\
\sigma_{zz} \\
\sigma_{rz}
\end{bmatrix}
= 
\begin{bmatrix}
c_{11} & c_{12} & c_{13} & 0 \\
c_{21} & c_{22} & c_{23} & 0 \\
c_{31} & c_{32} & c_{33} & 0 \\
0 & 0 & 0 & c_{44}
\end{bmatrix}
\begin{bmatrix}
\varepsilon_{rr} - \alpha(T - T_{\text{ref}}) \\
\varepsilon_{\phi\phi} - \alpha(T - T_{\text{ref}}) \\
\varepsilon_{zz} - \alpha(T - T_{\text{ref}}) \\
\varepsilon_{rz}
\end{bmatrix}
\]

*Figure 9.69. stress-strain relationship*

1. \(\alpha\) = Thermal expansion coefficient
2. \(T_{\text{ref}}\) = Reference temperature for the relaxed body
3. \(\varepsilon_{rr}, \varepsilon_{\phi\phi}, \varepsilon_{zz}, \varepsilon_{rr}, \varepsilon_{rz}\) = Strain components
4. \(c_{ij}\) = Elastic material constants in the Voigt notation

An important scalar for the discussion of stress in solid bodies, especially for crystal growth, is the von Mises Stress \(\sigma_{\text{Mises}}\), which is computed from the distinct stress components. In cylindrical coordinates it is defined as:

\[
\sigma_{\text{Mises}} = \sqrt{\frac{(\sigma_{rr} - \sigma_{zz})^2 + (\sigma_{\phi\phi} - \sigma_{rr})^2 \cdot (\sigma_{\phi\phi} - \sigma_{zz})^2 + 6\sigma_{rz}^2}{2}}
\]

*Figure 9.70. Definition of the von Mises stress*

Further details can be found in M. Kurz, Development of CrysVUn, 1998, see Bibliography (page 277).

9.9.1. Setting parameters and starting the computation of stress

Prerequisites

Temperature has been computed.

1. Select File > Open.
2. Open the file Stress.crys.

3. Select **Settings > Materials**.
   The Materials dialog opens.

4. Select the material **GaAsSolid** from the materials list.
   The properties of **GaAsSolid** are displayed in the right field of the dialog window.

5. Scroll down until mechanical properties are displayed.

6. Enter the appropriate values for the thermal expansion coefficient and the stress coefficients, if not already specified.

7. Select the region of the sample in the drawing with the left mouse button.

8. Select **Settings > Physical Phenomena**.

9. Because temperature has already been computed and the fluid properties for Phase 1 have been specified for the material of the sample, CrysVUn offers to compute **Thermoelastic Stress**, **Convection** and **Azimuthal Flow**.
   Activate **Thermoelastic Stress** (Yes) and deactivate **Convection** and **Azimuthal Flow** (No), if necessary.

10. Click on **Apply and Close**.

11. Select the **Thermoelastic Stress** from the variable group list box in the tool bar.
    The default variable for visualizing results is **vonMisesStress**.

12. Click on the **Start computation** button.
    After computation is finished, you can visualize the von Mises stress, for instance.

---

**Figure 9.71. Mechanical properties**

**Figure 9.72. Von Mises Stress**
9.10. Computing Inductive Heating

*CrysVUn* can compute magnetic fields produced by an alternating current through a coil (alternating field) and also inductive heat produced by the magnetic fields in materials with non-zero electric conductivity.

An arbitrary number of coils can be handled with fixed frequency and current. Furthermore, *CrysVUn* offers the possibility to control one inductive heating element (that may consist of several coils) by adjusting the current of the coils to fix the temperature at a chosen control point. The restriction to one controlled heater in contrast to resistance heating is based on the fact that heat is not released in the regions of the heaters themselves, but in any electrically conducting region of the furnace model. This does not affect the number of induction heaters with fixed or prescribed currents; there may also be an arbitrary number of controlled resistance heaters.

You can compute inductive heating not only for pseudo-stationary, but also for time-dependent simulation by providing profile files. The heater setting, however, is more important, because fixed power and controlled power effect the proceeding.

At first the assumptions and prerequisites used by *CrysVUn* and in this tutorial are explained and subsequently the following tutorial tasks are addressed:

- Physical background (page 172)
- Prerequisites and Tasks (page 173)
- Computing inductive heating for fixed power (page 174)
- Computing inductive heating for controlled power (page 177)

9.10.1. Physical background

In inductive heating an alternating current is passed through the coils. This azimuthal current produces an approximately orthogonal time-varying magnetic field outside the coils (Ampère's law) which in turn generates (induces) an oscillating azimuthal electric field (Faraday's law). Both fields penetrate electrical conductive regions to an extent that depends in part on the electrical conductivity itself. The electric field within the conductive region causes a parallel current flow (Ohm's law). The product of the electric field strength with the current describes the rate of energy dissipation in the conductive region - the familiar $I^2 R$ heating - in the form of temporal and spatial volumetric heating.

In *CrysVUn* the effects of an alternating magnetic field are described by a vector potential defined as:

\[ \vec{A} = C \cos(\omega t) + S \sin(\omega t) \]

*Figure 9.73. Definition of the vector potential*
• $C(r, z) =$ In-phase component
• $S(r, z) =$ Out-of-phase component

Once $C(r, z)$ and $S(r, z)$ are known, the induced heat sources can be computed by the following formula:

$$q(r, z) = \frac{\sigma \omega}{2} \cdot \left( C^2(r, z) + S^2(r, z) \right)$$

*Figure 9.74. Description of the heat sources*

• $\sigma =$ electrical conductivity
• $\omega =$ frequency of the current ($\omega = 2\pi f$)

The interaction of matter and the electromagnetic field is described by the skin depth $\delta$:

$$\delta = \sqrt{\frac{2}{\mu \sigma \omega}}$$

*Figure 9.75. Definition of the skin depth*

• $\sigma =$ electrical conductivity
• $\omega =$ frequency of the current ($\omega = 2\pi f$)
• $\mu =$ magnetic permeability

The skin depth $\delta$ is an important parameter for the treatment of alternating magnetic fields. It reflects the length at which the amplitude of the magnetic field is reduced to $1/c$ of its initial value.

### 9.10.2. Prerequisites and Tasks

Geometry, materials and parameters have to comply with particular requirements for computing temperature in an inductive heating setting.

#### 9.10.2.1. Prerequisites for calculations with inductive heating

• The inductive heating system must be enclosed in an ambient block for defining the boundary conditions.
• If radiation is computed in the block containing the coils, there must be a separate ambient block which is opaque. Details about the in-phase potential and the out-of-phase potential are to be found in B. Fischer, Ph.D. thesis, Erlangen 2001, see Bibliography (page 277).
• The materials which are intended to be heated must have an electric conductivity different from 0.
• The material of the induction coils must have 0 for electric conductivity.
9.10.2.2. Specification of the furnace used in this tutorial

The furnace in the file Inductive_heating.crys has the following features:

- Graphite crucible with cap
- Sample material is silicon
- Insulation with a graphite felt
- Ceramic rod as support of the crucible
- Stainless steel as flange
- Water-cooled quartz glass reactor filled with argon gas at 1 bar
- Inductive heating using a coil with 7 windings at 10,000 Hz

Because of the water cooling of the quartz tube the block containing the coil and the quartz glass tube itself is set to opaque. There will be no influence of ambience, so there is no reason to waste computing time for view factors.

9.10.2.3. Additional Notes

The following notes apply to special use cases:

- Both a linear and a quadratic interpolation of the in-phase potential and the out-of-phase potential are implemented in CrystVUn. By default the linear interpolation is chosen. If you want to switch to quadratic interpolation, you have to manually edit the *.crys file and change the line interpolation potential: 1 to interpolation potential: 2.

- In the case of a temperature-dependent electrical conductivity, iterations between temperature and potential calculation become also necessary for forward simulations.

- So far, the inductive heating is only implemented for axisymmetric geometries in CrystVUn. The treatment of two-dimensional furnaces is not possible.

- The usage of the GSSV solver for the controller is recommended.

- In the case of very small skin depths, it might be useful to introduce additional regions to get a better control on the grid generation.

9.10.2.4. Computing inductive heating for fixed power

1. Select File > Open.
2. Open the file Inductive_heating.crys. The furnace specified will be displayed.
3. Select **Settings > Heater**.

4. Select the 7 square regions (coils) at the right side of the SCA using **CTRL** key and **left mouse button** to define the heater.

   The heater **noname** will be listed in the left field of the dialog window. The 7 regions (coils) are listed by region number and material assigned in the right field of the dialog window. Because the heater consists of 7 regions and the type of heater is still **Resistance**, each region gets the same fraction (0.14287).

5. Replace **noname** in the field name by **Coils** and confirm by pressing the **Enter** key.

   The name of the heater is changed to **Coils** in the list.

6. Click on the box next to **Induction** to change the type of heater and specify a frequency of 10 000 Hz in the neighboring field.

7. Type 250 in the field **Current (A)**.

   The heater specification should look like this:

   ![Heaters dialog, inductive heating](image)

   Note that the **Fraction** has changed to 1 when changing to inductive heating!

8. Click on **Apply** and **Close**.

9. Select **Settings > Physical Phenomena**.

10. Click on **select all regions**.

    The dialog window indicates **21 region(s) selected**. **Temperature** and **Inductive**
Heating are available for computation.

11. Activate Inductive Heating by clicking on the box in the Yes column.

If you want to continue with resistance heating only, you have to deactivate Inductive Heating in the Physical Phenomena dialog. Otherwise the results will be falsified.

12. Click on Apply and Close.


14. Select the 3 border lines of the furnace in the drawing using the CTRL key and the middle mouse button.

   The dialog window indicates 3 line(s) selected.

15. Select in-phase-potential from the Variable list box.

16. Select the boundary type Dirichlet.

17. Type 0 in the field Value.

18. Click on Apply and Close.

19. Select Inductive Heating from the variable group list box in the tool bar.

   The default variable for visualizing the results is in-phase-potential.

20. At first the total induced heating power in Watt will be computed. It is used as a heat source for computing temperature.

   Click on the Start computation button.

   Monitor the protocol in the terminal window during computation because only here CrysVUn will specify the calculated total induced heating power (698.093 W). The changed values for the current can be looked up in the Heaters dialog. Whenever you change the heater, you have to repeat the computation of the induced heating.

21. You can visualize the in-phase-potential, the out-of-phase-potential and the inductive heating source.

   For visualizing the induced heating power it is helpful to choose the Logarithmic scale in the Options for Scalar Fields dialog.

   Select ind.-heat-source from the variable list box and click on the Show/hide scalar field button.

   For the inductive heating source, the regions in the furnace are displayed where most heat is dissipated: In the crucible.

   ![Figure 9.78. Induced heat](image)
22. Click on the **Show/hide scalar field** button to turn the scalar field off.

Now you are ready to compute temperature.

**Related Procedures**

- Heaters (page 61)
- Boundary Conditions (page 58)
- Physical Phenomena (page 56)
- Setting options for scalar fields (page 106)

**Related Dialogs**

- Heaters (page 223)
- Boundaries (page 221)
- Physical Phenomena (page 219)
- Options for Scalar Fields (page 252)

**9.10.2.5. Computing inductive heating for controlled power**

In the case of controlled power you do not have to compute the induced heating power in advance, because iterations between temperature and potential calculation are necessary anyway. You can directly start computing temperature.

1. Select **File > Open**.

2. Open the file *Inductive_heating2.crys*.

3. Specify the heater regions and the heater as for fixed power, see Computing inductive heating for fixed power (page 174).

4. Change the type of heater to **Induction** and specify a **Frequency** of 10 000 Hz.

5. Click on the box next to **Controlled power**.

6. Specify 300 as **initial/actual value** for the currency, a minimum of 100 and a maximum of 8 000 A as interval.

7. Click on **Apply and Close**.

8. Select **Settings > Physical Phenomena**.

9. Click on **select all regions**.

   The dialog window indicates **21 region(s) selected. Temperature and Inductive Heating** are available for computation.

10. Activate **Inductive Heating** by clicking on the box in the **Yes** column.

11. Click on **Apply and Close**.

12. Click on the **Start computation** button to compute **Temperature**.

   Monitor the protocol in the terminal window during computation because only here *CrysVUn* will specify the calculated total induced heating power. The changed values for the current can be looked up in the **Heaters** dialog.
9.11. Simulating Rotating Magnetic Fields and Computing Lorentz Forces

While Inductive Heating considers alternating magnetic fields, a particular variable applies to Rotating Magnetic Field.

- Specifying settings and parameters for computing rotating magnetic fields (page 178)

9.11.1. Specifying settings and parameters for computing rotating magnetic fields

Prerequisites
Temperature has been computed.

1. Select File > Open.
2. Open the file rotating.crys.
4. Select the material GaAsSolid.
5. You have to define the electrical conductivity for the sample material. Type 1.2e6 for Electrical conductivity into the Phase 0 and Phase 1 columns.
6. Click on Apply and Close.
7. Select Settings > Physical Phenomena.
8. Select the region of the sample. (No. 10, GaAsSolid).
9. CrysVIN can compute all related variables simultaneously. Temperature is automatically active.
   Check the boxes next to Convection, Azimuthal Flow, Lorentz Forces and Electrical Potential.
10. Click on Apply and Close.
    The Electrical Potential dialog opens.
12. All 4 parameters for rotating magnetic fields have to be specified. Type the following values in the associated lines: Magnetic induction in Tesla: 0.001, Sample radius in m: 0.003, Pole pairs: 1, Rotating frequency in Hz: 400.

13. Click on Apply and Close.


15. If you start a complex computation like this, running ramps is useful. You may leave the ramp defaults or change them. Click on the boxes next to run a capacity ramp and run a viscosity ramp.

16. Click on Apply and Close.

17. Click on the Start computation button.

After the computation is finished you can visualize the distribution of lorentz-p in the variable group Electrical Potential, for instance.

![Figure 9.80. lorentz-p](image)

Related Procedures
- Process parameters: Rotating magnetic field (page 72)

Related Dialogs
- Electrical Potential (page 232)


There are two different types of stationary magnetic fields that can be computed in Crys-VUn. The one is an axial field, and the other one is the so called CUSP field. Also, two different models can be used for computation, named MHD1 and MHD2.

- Computing an axial field with the MHD1 model (page 180)
- Computing a CUSP field with the MHD2 model (page 180)
- Computing an axial field with the MHD2 model (page 181)
Further details can be found in J. Kastl, Implementierung von Modellen fuer stationaere Magnetfelder in das Softwarepaket CrysVUn, 2004, see Bibliography (page 277).

Prerequisites

Temperature and Convection have been computed.

9.12.1. Computing an axial field with the MHD1 model

1. To compute an axial field with the MHD1 model, select File > Open.
2. Open the file StatmagFields.crys.
   The Electrical Potential dialog opens.

4. All parameters for computing stationary magnetic fields are already specified with valid values.
   Magnetic induction in Tesla: 0.1, Model is MHD1, Configuration is axial in this case.
5. Click on Close.
6. Click on the Start computation button.
   After the computation is finished you can visualize the distribution of lorentz-r in the variable group Electrical Potential, for instance.

9.12.2. Computing a CUSP field with the MHD2 model
1. To compute a cusp field with the MHD2 model, select **File > Open**.

2. Open the file `StatMagEPot_cusp.crys`.


4. All parameters for computing stationary magnetic fields are already specified with valid values.
   - **Magnetic induction** in Tesla: 0.1, **Sample Radius** in meters: 0.01 **Model** is MHD2 **Configuration** is cusp **Cusp Origin** in meters: 0.01

5. Click on **Close**.

6. Click on the **Start computation** button.

   After the computation is finished you can visualize the distribution of the **sinus component** and the components of the Lorentz-Force in the variable group **Electrical Potential**, for instance.

---

### 9.12.3. Computing an axial field with the MHD2 model

1. To compute an axial field with the MHD2 model, select **File > Open**.

2. Open the file `StatMagEPot_axial.crys`.

3. Select **Computation > Process parameters > Electrical Potential**.
The **Electrical Potential** dialog opens.

![Electrical Potential dialog](image)

*Figure 9.85. Process parameters dialog, Magnetic Fields tab*

4. All parameters for computing stationary magnetic fields are already specified with valid values. **Sample Radius** and **Cusp Origin** are grayed out, since they are not used for axial configurations.

   **Magnetic induction** in Tesla: 0.1, **Model** is MHD2, **Configuration** is axial.

5. Click on **Close**.

6. Click on the **Start computation** button.

   After the computation is finished you can visualize the distribution of the **sinus component** and the components of the Lorentz-Force in the variable group **Electrical Potential**, for instance.

![Distribution of the sinus component](image)

*Figure 9.86. lorentz-p*

---

### Related Procedures

Process parameters: Stationary magnetic field (page 75)

### Related Dialogs

**Electrical Potential** (page 232)

---

### 9.13. Computing Concentration

*CrysVUn* offers the possibility to calculate the spatial distribution of a chemical species. You can compute stationary and time-dependent calculations and solve axisymmetric as well as translational problems.

In this tutorial the species transport is exemplified by a CVD reactor.
The following tutorial task explains the procedure:

- Specifying settings and parameters for computing concentration (page 183)

9.13.1. Equation and boundaries
The species transport is described by the following conservation equation:

\[
\frac{\partial}{\partial t} \cdot (\rho C) + \nabla \cdot (\rho \kappa \nabla C) = \nabla \cdot (\rho D \nabla C)
\]

Figure 9.87. The conservation equation for one solute element

- \( C \) = concentration
- \( D \) = diffusion coefficient
- \( \rho \) = density (temperature dependent)

Three boundary types are available for the variable Concentration:

- **Dirichlet**: A fixed value for the concentration along a certain line: \( C = \) constant.

- **Neumann**: A fixed species flux along a certain line: \( q = \) constant.

- **Poincaré**: A flux dependent on the value of the concentration itself at the boundary line:
  \[
  q = k \left( C - C_0 \right)
  \]
  This condition might be taken to describe a species reaction along a line. In this case \( k \)
  is some kind of reaction rate.

- **Temperature dependent Dirichlet**: The same as Dirichlet, but the value is specified as a
  function of the temperature on the line \( C(t) \).

- **Temperature dependent Poincaré**: A flux dependent on the value of the concentration
  itself at the boundary line:
  \[
  q = k(T) \left( C - C_0(T) \right)
  \]
  The transfer-coefficient \( K(T) \) and the reference concentration \( C_0(T) \) can be specified as functions of the temperature. A typical application is evaporation of a species on the line where \( k(T) \) corresponds to the sticking coefficient and \( C_0(T) \) is the equilibrium partial pressure of the species
  (Hertz-Knudsen-equation).

9.13.2. Specifying settings and parameters for computing concentration
Temperature and flow field for this CVD reactor have already been computed.

1. Select **File > Open**.
2. Open file Concentration.crys.
   The simplified CVD reactor will be displayed.
3. Select **Settings > Physical Phenomena**.

4. Activate **Concentration** by clicking on the box in the **Yes** column.

5. Click on **Apply** and **Close**.

6. Select **Settings > Boundaries**.

7. Boundaries for temperature and velocity must also be specified for computing concentration. In this tutorial the Dirichlet boundaries for temperature and the velocity boundaries for inflow and outflow at the vertical lines as well as boundaries for the remaining border lines have already been specified. You can look at them by selecting the respective variable and clicking on **show** in the **Boundaries** dialog.

   But you do have to set the boundaries for concentration.

   Select **Concentration** from the variable list box.

8. Select the inclined line in the middle of the reactor by pressing the **middle mouse button**.

9. Select the **Poincaré** boundary condition.

10. Type the reference value 0 and the coefficient 5*x in the respective fields.

11. Click on **Apply**.

12. Select the left vertical line (inflow) by pressing the **middle mouse button**.

13. Select the **Dirichlet** boundary condition.

14. Type 1 into the **Value** field.

15. Click on **Apply** and **Close**.

16. Select the variable group **Concentration** from the list box in the tool bar. Since you did not compute convection this far, only the diffusive field will be computed.

17. Click on the **Start computation** button.

18. You can visualize the results by clicking the buttons for showing isolines and scalar field.

   Click on the **Show/hide isolines** button and the **Show/hide scalar field** button.

   The isolines and the scalar field for the **Concentration** are displayed.
You can as well visualize the scalar field and the isolines for the temperature by selecting the variable in the list box.

19. Select the variable group **Convection** from the list box in the tool bar. Compute the convection, and afterwards compute the concentration as described above. You can visualize the results like you did before, this time you will recognize that the results look different.

20.

**Related Dialogs**

Boundaries (page221)
Species (page239)
Related Procedures

Setting parameters for species transport simulation. (page 82)

9.13.3. Performing a calculation of the supersaturation

As a post process of a concentration calculation the supersaturation can be computed. The value displayed is the difference between the solubility limit, defined in materials dialog, and the concentration at the node.

1. Select File > Open.
2. Open file Concentration.crys.
   The simplified CVD reactor will be displayed.

   ![CVD reactor](image)

   *Figure 9.92. CVD reactor for species transport*

3. Perform a calculation of the temperature and the species field (see Computing Concentration (page 182)).
4. Open the Materials dialog.
5. Go to the Species transport section.
   Insert the following relation in the equilibrium solubility field:
   \[ \frac{2}{T} \]
6. Click on Apply and Close.
7. Select the variable group Concentration from the list box in the tool bar.
8. Select the variable Supersaturation in the variable group Concentration from the list box in the tool bar.
9. Click on the Start computation button.
10. You can visualize the results by clicking the buttons for showing isolines, scalar field and vector field. Like for the concentration, the computing of the convection has an influence on the supersaturation.
    Click on the Show/hide isolines button.
    The isolines for Supersaturation are displayed in the CVD reactor.

This tutorial contains two parts. The first one treats the usage of the alloy model for pure diffusive condition. In this case the liquid fraction is calculated from an analytical relation. The second part explains the usage of the alloy model if macrosegregation is taken into account. This requires a number of physical phenomena solved coupled. It is assumed that the user has a good knowledge in using CrysVUn for calculating temperature and convection in order to keep the chapter short.

Warning:

As the alloy model combines most of the physical phenomena available in CrysVUn it is highly recommended that the user shall gain as much experience as possible with standard e.g. thermal calculations before trying to compute macrosegregation. The developers also recommend to optimize the thermal model, which shall serve as a base for this calculation, for speed before using it.

Related Procedures

- Setting the parameters for alloy solidification (page 89)
- Setting Convection parameters (page 84)
- Setting Numerical parameters (page 76)

Related Dialogs

- Alloy parameters (page 245)
- Convection parameters (page 240)
- Numerical parameters (page 234)

9.14.1. Overview of the need input parameters for the alloy model

In this chapter an overview of need input parameters for the alloy model is given. This includes material parameters and numerical settings.

Without macrosegregation

- Thermal conductivity, Heat capacity, Density
- Partition coefficient
• Liquidus temperature
• Choose lever rule or Scheil's equation
• Coupling scheme: Analytical
• Required phase diagram consistence
• Initial conditions: temperature

With macrosegregation

• Thermal conductivity, heat capacity, density
• Partition coefficient, diffusion coefficient, solutal expansion coefficient
• Viscosity, Volumetric expansion coefficient,
• Melting point of pure substance, liquidus line slope
• Choose lever rule or Scheil's equation
• Permeability law, primary and secondary arm spacing
• Coupling scheme: Enthalpy or matrix based, liquid fraction underrelaxation...
• Maximum number of iterations, required phase diagram consistence, minimum liquid fraction change
• Numerical parameters for convection..
• Initial conditions: concentration, temperature

Warning: Do not forget to set all boundary conditions for all physical phenomena (temperature, convection and concentration) involved. For the variables of the alloy group itself no boundary conditions are needed.

9.14.2. Alloy solidification under pure diffusive conditions

In this tutorial the pure diffusive alloy model will be used. In this case the liquid fraction is computed with an analytical relation given by Scheil's equation or the lever rule. It will be explained how to perform a time-dependent calculation with the alloy model. The procedures for stationary calculation are in principle the same.

1. Select File > Open.
2. Open file alloy_tutorial.crys.
   The simple rectangular geometry will be displayed.
   The Physical Phenomena dialog opens.
4. Press the Select all regions button.
5. Switch Alloy to Yes.
6. Click on **Apply** and **Close**.

7. Select **Computation > Alloy Parameters**.
   The **Alloy Parameters** dialog opens with the **Phase diagram** tab activated.

8. Set the **Liquidus temperature** to 498 Kelvin.

9. Switch to the **Numerical** tab.
   The **Coupling scheme** is set to analytical as wanted.

10. Click on **Close**.

11. Select the variable group **Temperature** from the list box in the tool bar.

12. Select the variable **Temperature** in the variable group **Temperature** from the list box in the tool bar.

13. Click on the **Start computation** button.
   The evolution of the liquid fraction can be displayed while the time-dependent calculation proceeds.

14. Select the variable group **Alloy** from the list box in the tool bar.

15. Select the variable **LiquidFraction** in the variable group **Alloy** from the list box in the tool bar.

16. You can visualize the results by clicking the buttons for showing isolines, scalar field and vector field.
   Click on the **Show/hide isolines** button.
   The isolines for **Liquid fraction** are displayed in the region. If the calculation is still running, the isolines are moving from the left side to right side of the rectangle.
Related Dialogs
Alloy parameters (page245 )
Physical Phenomena (page219 )

9.14.3. Alloy solidification under the influence of convection
In this tutorial the pure diffusive alloy model will be used.

1. Select File > Open.
2. Open file alloy_tutorial.crys.
The simple rectangular geometry will be displayed.
The Physical Phenomena dialog opens.
4. Press the Select all regions button.
5. Switch Alloy, Convection and Concentration to Yes.

6. Click on Apply and Close.
7. Select Settings > Initial values.
The Initial values dialog opens.
8. Select the variable concentration from Variable drop-down list.
9. Type the value 5 in the field Initial value.
10. Switch Refresh to selected variable.
11. Click on **Apply** and **Close**.

12. Select **Settings > Boundaries**.
   
The **Boundary** dialog opens.

13. Switch to **Show all**.
   
   As the boundaries are already defined nothing is to do.
   
   Take look at the defined boundaries. It it typical setup for computing alloy solidification.

14. Click on **Close**.

15. Select **Computation > Time Model**.
   
The **Time Model** dialog opens.

16. Set the **Time step** to 0.05.
   
   Set the **Max. Time step** to 0.05.
   
   Set the **Stop time** to 10.

17. Click on **Apply** and **Close**.

18. Select **Computation > Alloy Parameters**.
   
The **Alloy Parameters** dialog opens with the **Phase diagram** tab activated.

19. Set the **Melting point of pure substance** to 505 Kelvin.
   
   Set the **Liquidus line slope** to -1.286K/wt.pct.

20. Switch to the **Numerical** tab.
Set the **Coupling scheme** to Enthalpy based.
Set the **Liquid fraction underrelaxation** to 0.8.

![Image of Alloy dialog](image1)

*Figure 9.99. The Phase diagram tab of the Alloy dialog*

21. Click on **Apply** and **Close**.

22. Select **Computation > Convection Parameters**.
   The **Convection Parameter** dialog opens with the **Abortion** tab activated.

23. For **Inner iteration limits** set the parameter as follows:
   - Momentum 1 to: 1
   - Temperature 1 to: 0.01

   For **Stop of computation** set the parameter as follows:
   - Momentum 2 to: 0.0001
   - Temperature 2 to: 1e-6

   Set the **Underrelaxation Velocity factor** to 0.8 to 0.8 between 1 and 0.01.

![Image of Convection Parameter dialog](image2)

*Figure 9.100. The Phase diagram tab of the Alloy dialog*

24. Click on **Apply** and **Close**.

25. Select the variable group **Convection** from the list box in the tool bar.

26. Select the variable **VelocityU** in the variable group **Convection** from the list box in the tool bar.
27. Click on the **Start computation** button.
   The evolution of the liquid fraction can be displayed while the time dependent calculation proceeds.

28. Select the variable group **Alloy** from the list box in the tool bar.

29. Select the variable **LiquidFraction** in the variable group **Alloy** from the list box in the tool bar.

30. You can visualize the results by clicking the buttons for showing isolines, scalar field and vector field.
   Click on the **Show/hide isolines** button.
   The isolines for **Liquid fraction** are displayed in the region. If the calculation is still running, the isolines are moving from the left side to right side of the rectangle.

![Isolines of liquid fraction at the end of the computation](image)

*Figure 9.101. Isolines of liquid fraction at the end of the computation*

---

**Related Dialogs**

- Initial Values (page220)
- Physical Phenomena (page219)
- Alloy parameters (page245)
- Convection parameters (page240)
- Numerical parameters (page234)

---

**9.15. Running CrysVUn in Batch Mode**

The batch version of CrysVUn, **crysvun_onl**, enables you to run simulations using pre-processed input files without employing the graphical user interface (GUI) of CrysVUn. Additionally, some basic post-processing routines are only possible with the online version of CrysVUn, like the profiling of computed values.

A typical application of the CrysVUn batch mode is the usage for a sensitivity analysis with a large number of thermal analysis runs. The performance of the batch mode is normally better than for the CrysVUn with GUI, especially for complex computations like convection simulations.

But of course there are also limitations for the user. For example no numerical parameters like under-relaxation factors or convergence criteria can be defined or changed using the batch version of CrysVUn. All these parameters have to be defined using the GUI version of CrysVUn.

The CrysVUn batch mode is run in a terminal window. The program is called typing the program name **crysvun_onl** followed by a number of parameters specifying what the user wants to do and defining input and output files. In case that no additional parameters are
given by the user, a help text is provided in the terminal window. The same information is obtained by calling the program with the option -h. The help information for the current Linux online version 2.8.04 looks like this:

This is the online version of CrysVUn 2.8.04 - i686 Linux version

**USAGE:** cvonl [options]

**possible options:**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-z</td>
<td>Set compress option (to load and save .crys files)</td>
</tr>
<tr>
<td>-l</td>
<td>Load file.</td>
</tr>
<tr>
<td>-c</td>
<td>Save file.</td>
</tr>
<tr>
<td>-i</td>
<td>Interpolate values from file to the present grid.</td>
</tr>
<tr>
<td>-cF</td>
<td>Stream-Function.</td>
</tr>
<tr>
<td>-l [variable name, value, file]</td>
<td>Write the profile of an isoline or Temperature (or T), radial gradient etc.</td>
</tr>
<tr>
<td>-p</td>
<td>Make a linear profile</td>
</tr>
<tr>
<td>• -p &lt;x0, y0, x1, y1&gt;</td>
<td>• Set start/end points.</td>
</tr>
<tr>
<td>• -a</td>
<td>• Axial plot start/end point = (0, y_min/max).</td>
</tr>
<tr>
<td>• -r &lt;y&gt;</td>
<td>• Radial plot start/end point = (x_min/max, r).</td>
</tr>
<tr>
<td>-q</td>
<td>Make list profile</td>
</tr>
<tr>
<td>• -p &lt;x, y&gt;</td>
<td>• Add point to list.</td>
</tr>
<tr>
<td>• -f &lt;file&gt;</td>
<td>• Use points from file (use tabs and new lines to separate coordinates and points).</td>
</tr>
<tr>
<td>• -X</td>
<td>• Close and save list profile.</td>
</tr>
<tr>
<td>-P</td>
<td>Prepare PS for printing image</td>
</tr>
<tr>
<td>• -r &lt;x0, y0, x1, y1&gt;</td>
<td>• Set image region.</td>
</tr>
<tr>
<td>• -f</td>
<td>• Set image region to full size.</td>
</tr>
<tr>
<td>• -CT, -CS, &lt;v0, vM&gt;</td>
<td>• Insert colors for Temperature/Stress (first plot color, then isolines!).</td>
</tr>
<tr>
<td>• -LT, LS, &lt;V0, vM, n&gt;</td>
<td>• Insert Isolines for Temperature/Stress.</td>
</tr>
<tr>
<td>• -X</td>
<td>• Finish and save ps-file.</td>
</tr>
<tr>
<td>-S</td>
<td>Change settings for...</td>
</tr>
<tr>
<td>• -i</td>
<td>• cvonl internals.</td>
</tr>
</tbody>
</table>

194
Nevertheless, we have to keep in mind that we are dealing with complex numerical techniques, whereby wrong numerical parameters may lead to divergence of the computations. Thus, it is in any case recommended to make first calculations with the GUI version of CrysVUn to identify the optimal numerical parameters. Afterwards, the user can start to run dozens of thermal analysis cases using the batch mode of CrysVUn.

**Example 1**

It may seem complex at first glance, but it is actually quite simple.

You want to perform the following tasks:

- Generate a grid
- Compute view factors
- Save intermediate results
- Compute the temperature
- Save the results

Simply type the following information into the command line:

```
crysvun_onl -l VGF_prototype.crys -cg -cv -s viewVGF_prototype.crys -cT -s calc_VGF_prototype.crys
```

**Example 2**

Besides running the simulations, the CrysVUn batch mode also offers basic post-processing routines.

You want to perform the following task:

- Make a profile along the axis of symmetry using an already finished calculation as an input file.

Type the following information into the command line:

```
crysvun_onl -l VGF_prototype.crys -p the_data.pr -a
```

**Example 3**

It is also possible to use the interpolation routine of CrysVUn in the batch mode.

You want to perform the following tasks:

- Interpolate the results of a finished calculation in another file
• Compute the temperature
• Save the results
• Make a linear profile

Type the following information into the command line:

```
crysvun_onl -l VGF Prototype.crys -i finished_calc.crys -cT -s
calc_VGF Prototype.crys -p profile.pr -p 0.01,0.01,0.03,0.03
```

**Example 4**

As already mentioned, the standard application of `crysvun_onl` is the usage of the program for a sensitivity analysis. If you intend to study the influence of the thermal conductivity of a certain material used in his furnace, all you have to do is to prepare the input (.crys) files in which you have changed the material properties using the GUI version of CrysVUn.

The thermal analysis is performed in the batch mode by running a script, reading for instance:

```
crysvun_onl -l file1.crys -cT -s calc_file1.crys
crysvun_onl -l file2.crys -cT -s calc_file2.crys
crysvun_onl -l file3.crys -cT -s calc_file3.crys
```
Chapter 10. Menus and Dialogs

You operate CrysVUn by selecting menu items which open dialog windows. In this section all menus and the associated dialogs are described in order of their appearance in the software.

10.1. File Menu

In the file menu, you find all options related to file and process management.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open</td>
<td>Opens a file and closes the actual file if necessary. In the different modes you can open the following file types:</td>
</tr>
<tr>
<td></td>
<td>• Geometry Mode: *.pcs: Containing geometry data only.</td>
</tr>
<tr>
<td></td>
<td>• Materials Mode: *.mat: Containing material data only.</td>
</tr>
<tr>
<td></td>
<td>• Simulation Mode: *.crys ; or *.crys.gz: A *.crys file or a compressed *.crys.gz file contains all data available for a simulation model, including geometry and materials data. You can open a *.crys file by loading the Entire file or Without View factors.</td>
</tr>
<tr>
<td></td>
<td>This item is not available during the computation.</td>
</tr>
<tr>
<td>Save</td>
<td>Saves data into the opened file, or opens the Save as... dialog. If no file is defined, see Save as ... (page198 ). This item is not available during the computation.</td>
</tr>
<tr>
<td>Save as ...</td>
<td>Opens Save as ... dialog for specifying a file for saving the actual data, see Save as ... (page198 ). This item is not available during the computation.</td>
</tr>
<tr>
<td>Close</td>
<td>Closes the opened file.</td>
</tr>
<tr>
<td>Import File</td>
<td>Opens the Import File dialog for importing a *.dxf file with geometric data of the furnace, see Importing a CAD File (dxf-Format) (page 23) and Import File (page199 ).</td>
</tr>
<tr>
<td>Item</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Interpolate</td>
<td>Overwrites the values of all variables in the actual *.crys file with the variables already calculated from another *.crys file. This function is useful when you make more calculations on the same geometry and the geometry with a refined grid. This item is only available in Simulation Mode.</td>
</tr>
<tr>
<td>Join</td>
<td>Opens the dialog for joining cartridge and furnace, see Join (page200).</td>
</tr>
<tr>
<td>File Info</td>
<td>Provides information about the actual *.crys file, see File Info (page202). This item is only available in Simulation Mode.</td>
</tr>
<tr>
<td>Print</td>
<td>Opens the Print dialog which depends on the installed printer. You can print the image visible in the window into a file or directly on the printer.</td>
</tr>
<tr>
<td>Screenshots</td>
<td>Opens the dialog for saving the visible image into a picture file, see Screenshots (page203).</td>
</tr>
<tr>
<td>Preferences</td>
<td>Opens the Preferences dialog, see Preferences (page204).</td>
</tr>
<tr>
<td>Exit</td>
<td>Closes the file and exits the program. This item is not available during computation.</td>
</tr>
</tbody>
</table>

### 10.1.1. Save as ...

This dialog is opened via File Menu (page 197).

In Save as... dialog you store the actual data into a file you specify.

![Save as... dialog](image)

*Figure 10.2. Save as... dialog*

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File type</td>
<td>You can save the following file types:</td>
</tr>
<tr>
<td></td>
<td>• Geometry Mode: *.pcs:&lt;br&gt;Only geometry data is stored in a *.pcs file.</td>
</tr>
<tr>
<td></td>
<td>• Materials Mode: *.mat:&lt;br&gt;Only material data is stored in a *.mat file. The assignment of materials to the regions is not saved here!</td>
</tr>
</tbody>
</table>
10.1.2. Import File

This dialog is opened via File Menu (page 197).

With the help of the **Import File** dialog you can import *.dxf files in Geometry Mode.

![Figure 10.3. Import File dialog](image)

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Look in</td>
<td>Browse to the wanted directory for file selection.</td>
</tr>
</tbody>
</table>
**Related Procedures**

Importing a CAD File (dxl-Format) (page 23)

**10.1.3. Join**

This dialog is opened via File Menu (page 197).

In this dialog you join a sample cartridge assembly and a furnace insert. The **Cartridge manager** and the **Furnace insert manager** assist you in administering the lists of cartridges and furnaces. Cartridge files and furnace insert files are always *.crys* files.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>Display selected file (dxl only)</td>
</tr>
</tbody>
</table>

**10.1.3.1. Join tab**

In this dialog the user joins a cartridge with a furnace insert (FI). Both files are *.crys* files and contain the complete file information, not only geometry data.

![Join dialog, Join tab](image)

**Figure 10.4. Join dialog, Join tab**

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Cartridge</strong></td>
<td>List of cartridges available for selection.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>If no cartridge is listed yet, you can browse for a cartridge file. Click on <strong>Advanced</strong> for displaying the browsing fields, if necessary.</td>
</tr>
<tr>
<td><strong>Furnace insert</strong></td>
<td>List box for selecting the furnace insert.</td>
</tr>
</tbody>
</table>
If no furnace insert is in the list box, because no configuration list has been saved yet, you can browse for a furnace insert. Click on Advanced for displaying the browsing fields.

**Offset**
Defines the initial position of the cartridge in the furnace. The joiner assumes that cartridge and furnace have the same symmetry axis.

**Preview files**
If active, CrysVu will display the chosen cartridge respectively open the file.

**Advanced**
Provides the browsing functionality for cartridges and furnace inserts.

**Output file**
Defines the file to which the complete furnace shall be saved. This file is a *.crys file containing all information, not only geometry data.

**Join**
Joins the selected cartridge with the selected furnace insert and saves the result to the output file specified.

### Related Procedures
Joining cartridge and furnace insert (page 49)

#### 10.1.3.2. Configure tab
This dialog contains lists of predefined SCAs and FIs. You can edit the two lists and save the configurations.

**Figure 10.5. Join dialog, Configure tab**

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Note</strong></td>
<td>If no furnace insert is in the list box, because no configuration list has</td>
</tr>
<tr>
<td></td>
<td>been saved yet, you can browse for a furnace insert. Click on Advanced for</td>
</tr>
<tr>
<td></td>
<td>displaying the browsing fields.</td>
</tr>
<tr>
<td><strong>Offset</strong></td>
<td>Defines the initial position of the cartridge in the furnace. The joiner</td>
</tr>
<tr>
<td></td>
<td>assumes that cartridge and furnace have the same symmetry axis.</td>
</tr>
<tr>
<td><strong>Preview files</strong></td>
<td>If active, CrysVu will display the chosen cartridge respectively open the file.</td>
</tr>
<tr>
<td><strong>Advanced</strong></td>
<td>Provides the browsing functionality for cartridges and furnace inserts.</td>
</tr>
<tr>
<td><strong>Output file</strong></td>
<td>Defines the file to which the complete furnace shall be saved. This file is</td>
</tr>
<tr>
<td></td>
<td>a *.crys file containing all information, not only geometry data.</td>
</tr>
<tr>
<td><strong>Join</strong></td>
<td>Joins the selected cartridge with the selected furnace insert and saves the</td>
</tr>
<tr>
<td></td>
<td>result to the output file specified.</td>
</tr>
</tbody>
</table>

**Cartridge manager**
Lists cartridges and the associated path information and supports administering the cartridge list by providing the following functions:

- **Add**: Adds the cartridge selected by browsing or typed in the
### Furnace insert manager
Lists furnace inserts and the associated path information and supports administering the list by providing the following functions:

- **Add**: Adds the cartridge selected by browsing or typed in the input field to the list.
- **Delete**: Deletes the selected cartridge from the list.
- **Browse**: Browses for a furnace insert file.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default offset</td>
<td>Defines the initial position of the cartridge in the furnace.</td>
</tr>
<tr>
<td>Save configuration</td>
<td>Once you finished editing both lists, you can save the configurations by clicking on this button.</td>
</tr>
</tbody>
</table>

### Related Procedures
Joining cartridge and furnace insert (page 49)

#### 10.1.4. File Info
This dialog is opened via File Menu (page 197).

In File Info dialog you get some information about the actual `.crys` file.

![File Info dialog](image)

_Figure 10.6. File Info dialog_
Item | Description
--- | ---
 | Additional information, internally managed by CrysVUn, e.g. the initial cartridge and furnace insert files used by joiner to generate the thermal simulation model (*.crys file). The field might not exist if there is no additional information managed by CrysVUn.

Comments | Input field which allows to the user to add own comments about the file. These comments are saved into *.crys file.

10.1.5. Screenshots

This dialog is opened via File Menu (page 197).

In **Screenshots** dialog you can easily save the main window picture in an image file. The following formats are supported: PNG (Portable Network Graphics), JPEG (Joint Photographic Experts Group) and PS (PostScript).

![Screenshot dialog](image)

*Figure 10.7. Screenshots dialog*

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zooming</td>
<td>If you want to zoom in a part of the furnace, besides using the mouse buttons (zooming with <strong>left mouse button</strong>), you can specify the desired area by giving its coordinates:</td>
</tr>
<tr>
<td></td>
<td><strong>From left (m), to right (m)</strong>: specifies the left and right margins of desired area.</td>
</tr>
<tr>
<td></td>
<td><strong>From top (m), to bottom (m)</strong>: specifies the top and bottom margins of desired area.</td>
</tr>
<tr>
<td></td>
<td><strong>Force value</strong>: even if you specify the desired area, it is automatically adjusted in order to keep the furnace aspect, so it is possible that the given margins are not exactly set. In case you really want to have the given margins, you can force them by using <strong>Force value</strong> options.</td>
</tr>
</tbody>
</table>

**Note**

If all constrains can not be set, they are applied in the
10.1.6. Preferences

This dialog is opened via File Menu (page 197). In Preferences dialog, the global CrysVUn's parameters are managed. You can set the output files preferences, the looking and behavior of the graphical user interface and determine the program global data, like material database or the user manual.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data storage</td>
<td>Sets the output file preferences.</td>
</tr>
<tr>
<td>Paths</td>
<td>Specifies the location of the common files used by CrysVUn.</td>
</tr>
<tr>
<td>GUI</td>
<td>Sets the looking of the GUI and manages the log messages.</td>
</tr>
<tr>
<td>Maintenance</td>
<td>Performs the maintenance tasks. Currently, only the update of the material database is provided.</td>
</tr>
</tbody>
</table>

10.1.6.1. Data storage tab

In the Data storage tab you set the preferences of *.crys files and the output files saved by analysis dialogs.
<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output file (*.crys)</td>
<td>Sets the options for saving *.crys files.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Output precision</strong></td>
</tr>
<tr>
<td></td>
<td>Sets the precision of the calculated values (number of calculated digits). The default value is 15.</td>
</tr>
<tr>
<td></td>
<td>• <strong>store view, not Gebhardt factors</strong></td>
</tr>
<tr>
<td></td>
<td>If you choose to store Gebhardt factors (default, check box is inactive), view factors have to be recomputed when emissivities change.</td>
</tr>
<tr>
<td></td>
<td>If you choose to store view factors, more memory is required, because view and Gebhardt factors remain in memory.</td>
</tr>
<tr>
<td></td>
<td>Gebhardt factors are recomputed when reading in view factors, but this is usually fast.</td>
</tr>
<tr>
<td></td>
<td>• <strong>use compressing by default</strong></td>
</tr>
<tr>
<td></td>
<td>If you choose this option, the Open/Save as/Interpolate dialogs automatically select *.crys.gz as default File type.</td>
</tr>
<tr>
<td>Analysis files</td>
<td>Sets the options for saving auxiliary files, e.g. monitor data files.</td>
</tr>
<tr>
<td></td>
<td>• <strong>adjust monitor file names</strong></td>
</tr>
<tr>
<td></td>
<td>Usually, the names of monitor files have as prefix the name of *.crys file. In case you save the file with other name, might happen that</td>
</tr>
<tr>
<td></td>
<td>more than one *.crys file to use the same monitor files to save results, so the monitor files could be damaged.</td>
</tr>
<tr>
<td></td>
<td>If you choose to adjust monitor file names, when you save the *.crys file with other name, the files defined in monitor section are</td>
</tr>
<tr>
<td></td>
<td>automatically renamed to have the new *.crys file name as prefix.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong></td>
</tr>
<tr>
<td></td>
<td>The adjustment is only done for monitor file names containing *.crys file name as prefix.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Column separator</strong></td>
</tr>
<tr>
<td></td>
<td>The computation results are written in auxiliary files in a table format. The separator between columns can be set in this</td>
</tr>
</tbody>
</table>
10.1.6.2. Paths tab

In the **Paths** tab you set the location of *CrysVUn*'s common files like material database and the user manual.

![Figure 10.9. Preferences dialog, Paths tab](image)

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Databases</strong></td>
<td></td>
</tr>
<tr>
<td>• <strong>Material database</strong></td>
<td>Indicates the file containing materials available to the users in order to set their furnaces. If no file is listed, you either type the file name and the path information or you click on the button to select the file. <em>CrysVUn</em> loads the material database specified in this dialog automatically at program start.</td>
</tr>
<tr>
<td>• <strong>Joiner config. file</strong></td>
<td>The <strong>Joiner configuration file</strong> lists furnaces and cartridges available for joining. By default, all files requested by joining process belong to the <em>CrysVUn</em>'s <strong>Data</strong> directory. You can also select a different configuration file by clicking on the button.</td>
</tr>
<tr>
<td><strong>Help System</strong></td>
<td><em>CrysVUn</em> has built-in a context sensitive help. Any time you press F1 key or button from a dialog, the help page of the dialog is displayed in a browser application. In order to activate the context sensitive help, two elements are required:</td>
</tr>
<tr>
<td>• <strong>User manual path</strong></td>
<td>The help system uses the on-line version of the user manual, so the path to the Manual should be specified here. By default, the <em>CrysVUn</em>'s <strong>Doc/Manual</strong> directory is considered.</td>
</tr>
<tr>
<td>• <strong>Help browser</strong></td>
<td></td>
</tr>
</tbody>
</table>
Related Procedures

Copying materials from the material database to the furnace (page 28)

10.1.6.3. GUI tab

In the GUI tab the interface's look and feel is set. Additionally, it manages the log messages behavior.

![Figure 10.10. Preferences dialog, GUI tab]

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Appearance</td>
<td>Set the look and feel of the GUI.</td>
</tr>
<tr>
<td></td>
<td>• Theme</td>
</tr>
<tr>
<td></td>
<td>Selects the style of GUI elements independent of operating system.</td>
</tr>
<tr>
<td>Log messages</td>
<td>In addition to the messages in the GUI, a lot of log messages are displayed, e.g. when loading a file or computing a variable. Some of these messages are classified according to their importance or seriousness. You can control the display of the following messages:</td>
</tr>
<tr>
<td></td>
<td>• Warnings</td>
</tr>
<tr>
<td></td>
<td>• Info</td>
</tr>
<tr>
<td></td>
<td>• Debug</td>
</tr>
<tr>
<td></td>
<td>The log messages could be displayed in a tool bar window (near the drawing) or in a separate window.</td>
</tr>
<tr>
<td></td>
<td>• show in terminal</td>
</tr>
<tr>
<td></td>
<td>If you choose show in terminal the log messages are dis-</td>
</tr>
</tbody>
</table>
played in the terminal window. Under Linux, this is the terminal window whence the program starts. Under Windows, a new console window is created on the program start.

10.1.6.4. Maintenance tab

The program maintenance is done in this tab. Currently, only updating of the material database is available.

![Figure 10.11. Preferences dialog, Maintenance tab](image)

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Material database</td>
<td>The materials stored in an external *.mat file can be automatically added to the material database.</td>
</tr>
<tr>
<td></td>
<td>• Updates file</td>
</tr>
<tr>
<td></td>
<td>Indicates the file containing new materials. You either type the file name or you click on the **button to select the file.</td>
</tr>
<tr>
<td></td>
<td>• Update database</td>
</tr>
<tr>
<td></td>
<td>Loads materials from the *.mat file into the material database. The updated database is saved on disk only after clicking Apply button.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong></td>
</tr>
<tr>
<td></td>
<td>The added materials will get CentralDB status and are automatically locked in the material database (their properties cannot be changed).</td>
</tr>
</tbody>
</table>

Related Procedures

Updating the database from an external source (page 43).

10.2. Mode Menu

With the items in the **Mode** menu you change the mode of the program. When starting a new project, you follow the given order: You change from Geometry Mode to Materials Mode and then to Simulation Mode. You cannot switch to Simulation Mode from Geometry Mode. From Material Mode or Simulation Mode, however, you can change to any other...
mode.

### Mode

<table>
<thead>
<tr>
<th>Mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Switches to Geometry Mode. In Geometry Mode you draw and change the furnace using the options in edit menu, see Geometry Mode (page 10).</td>
</tr>
<tr>
<td>Materials</td>
<td>Switches to Materials Mode. In Materials Mode you can define materials and assign materials to regions, see Materials Mode (page 26). The regions are automatically calculated from the geometry.</td>
</tr>
<tr>
<td>Simulation</td>
<td>Switches to Simulation Mode. You can only change to Simulation Mode from Materials Mode. Simulation Mode is the pivotal mode. You can also change the properties of the materials in the Simulation Mode. See Simulation Mode: Computation (page 70), Simulation Mode: Settings (page 47) and Simulation Mode: Variables (page 102).</td>
</tr>
</tbody>
</table>

#### 10.3. Edit Menu

With the items in the Edit menu you draw and change the geometry of the furnace. The Edit menu is only available in Geometry Mode.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Cancels the last action.</td>
</tr>
<tr>
<td>Redo</td>
<td>Cancels the last Undo.</td>
</tr>
<tr>
<td>Item</td>
<td>Description</td>
</tr>
<tr>
<td>------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Unselect All</td>
<td>Unselects all points, lines and blocks, see Cancelling selection (page 14).</td>
</tr>
<tr>
<td>Select All</td>
<td>Selects all points and lines, see Selecting all elements (page 14).</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the selected points and lines, see Deleting elements (page 19).</td>
</tr>
<tr>
<td>Merge Points</td>
<td>Merges selected points being closer to one another than the tolerance. You need this option e.g. to connect two line ends. For information about using the tolerance, see Using Tolerance and Raster (page 14).</td>
</tr>
<tr>
<td>Split Lines</td>
<td>Moves selected points to the closest selected line by normal projection, if the point is closer to the line than the tolerance. The result is split lines. For information about using the tolerance, see Using Tolerance and Raster (page 14).</td>
</tr>
<tr>
<td>Intersect Lines</td>
<td>Generates points at all crosses of the selected lines. You can select many lines at once. For information about using the tolerance, see Intersecting lines (page 16).</td>
</tr>
<tr>
<td>Grid Alignment</td>
<td>Moves all selected points to the closest raster point, even if the raster is off, see Using grid alignment (page 20).</td>
</tr>
<tr>
<td>Copy/Move To</td>
<td>Dialog for copying or moving selected elements, see Copy/Move to (page 211).</td>
</tr>
<tr>
<td>Create Block</td>
<td>Groups all selected lines to a block. Each line can belong to one single block at a time. Each block has an associated color, see Working with blocks (page 20).</td>
</tr>
<tr>
<td>Rotate Selection</td>
<td>Rotates all selected elements, see Rotate selection (page 211) dialog.</td>
</tr>
<tr>
<td>Flip</td>
<td>Turns over the geometry. To get the primary state select the option again, see Applying Flip (page 22).</td>
</tr>
<tr>
<td>Mirror</td>
<td>Swaps the geometry left/right (changes x to -x), see Applying Mirror (page 22).</td>
</tr>
<tr>
<td>scale</td>
<td>Multiplies the coordinates of all points with the scale factor, see Scale (page 212) dialog.</td>
</tr>
<tr>
<td>Align Left</td>
<td>Moves the whole drawing so that the point with the smallest x coordinate is on the symmetry axis. This is useful e.g. for imported *.dxf files, see Importing a CAD File (dxf-Format) (page 23).</td>
</tr>
<tr>
<td>Align Origin</td>
<td>Moves the whole drawing so that the point with the smallest x and y coordinate is on the origin (x = y = 0). This is useful e.g. for imported *.dxf files, see Importing a CAD File (dxf-Format) (page 23).</td>
</tr>
</tbody>
</table>
For more details see *Geometry Mode* (page 10) and *Modifying the Sample Cartridge Assembly (SCA)* (page 130).

### 10.3.1. Copy/Move to

This dialog is opened via Edit Menu (page 209).

In *Copy/Move to* dialog you can move or create a copy of selected points and lines.

![Copy/Move to dialog](image)

*Figure 10.14. Copy/Move to dialog*

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>copy/move</td>
<td>Selects the copy or move operation.</td>
</tr>
<tr>
<td>absolute/relative</td>
<td>The selected elements could be moved to an absolute position or relative to the current position. The selector is disabled for copy operation; the selected elements are copied always relative to the current position.</td>
</tr>
<tr>
<td>Change x(r) to:</td>
<td>If option is selected, the associated numeric field specifies the new x (or r) position or displacement of the copied/moved elements.</td>
</tr>
<tr>
<td>Change y(z) to:</td>
<td>If option is selected, the associated numeric field specifies the new y (or z) position or displacement of the copied/moved elements.</td>
</tr>
</tbody>
</table>

**Related Procedures**

- Copying elements via the Copy/Move-to dialog (page 18)
- Moving elements via the Copy/Move-to dialog (page 17)

### 10.3.2. Rotate selection

This dialog is opened via Edit Menu (page 209).

In *Rotate selection* dialog you can rotate all selected elements counterclockwise. The rotation center is the center of the rectangle containing all selected elements.

![Rotate selection dialog](image)

*Figure 10.15. Rotate selection dialog*
**Related Procedures**

Rotating elements (page 21)

**10.3.3. Scale**

This dialog is opened via Edit Menu (page 209).

In **Scale** dialog you can apply a scale factor to all points.

This is useful for *.dxf* files which are usually given in millimeters, so that a scaling factor 0.001 is needed to prepare the drawing for *CrysVUn* using meters.

![Scale dialog](image)

*Figure 10.16. Scale dialog*

**Related Procedures**

Applying scale (page 22)

**10.4. Settings Menu**

In the **Settings** menu in Simulation Mode you set parameters which serve as a basis for the simulation, e.g. materials and heaters properties, initial values, boundary conditions, grid properties and parameters for inverse or time-dependent simulation.

The menu item **Symmetry** is also available in Geometry mode, the menu item **Materials** is also available in Materials Mode.

![Settings menu](image)

*Figure 10.17. Settings menu*

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Materials</strong></td>
<td>Opens <strong>Materials dialog</strong> window for adding and modifying materials and their properties, see Materials (page 213).</td>
</tr>
<tr>
<td><strong>Labels</strong></td>
<td>Opens <strong>Labels</strong> dialog window for labelling regions and lines, see Labels (page 217).</td>
</tr>
<tr>
<td><strong>Symmetry</strong></td>
<td>Opens <strong>Symmetry</strong> dialog window for switching between axial and translational symmetry, see Symmetry (page 218).</td>
</tr>
<tr>
<td>Item</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Grid</td>
<td>Opens <strong>Grid</strong> properties dialog window for defining the grid, see Grid Properties (page 53).</td>
</tr>
<tr>
<td>Physical Phenomena</td>
<td>Opens <strong>Physical Phenomena</strong> dialog window for selecting the variables, which have to be solved, see Physical Phenomena (page 219).</td>
</tr>
<tr>
<td>Initial Values</td>
<td>Opens <strong>Initial Values</strong> dialog window for specifying initial values for the variables, which have to be computed, see Initial Values (page 220).</td>
</tr>
<tr>
<td>Boundaries</td>
<td>Opens <strong>Boundaries</strong> dialog window for specifying boundary conditions for the variables, which have to be computed, see Boundaries (page 221).</td>
</tr>
<tr>
<td>Heaters</td>
<td>Opens <strong>Heaters</strong> dialog for specifying the heaters of the furnace, see Heaters (page 223).</td>
</tr>
<tr>
<td>Control Points</td>
<td>Opens <strong>Control Points</strong> dialog window for inverse simulation, see Control Points (page 225).</td>
</tr>
<tr>
<td>Moving Regions</td>
<td>Opens <strong>Moving Regions</strong> properties dialog window for specifying regions and their velocity, see Moving Regions (page 226). Only available in time-dependent computation.</td>
</tr>
</tbody>
</table>

### 10.4.1. Materials

This dialog is opened via Settings Menu (page 212).

In the **Materials** dialog you can add, delete or change the properties of materials and provides the access to the material database. It is available in Materials Mode and in Simulation Mode.

![Materials dialog](Image)

*Figure 10.18. Materials dialog*

Fields, which you cannot edit, are disabled for logical or physical reasons. You cannot specify stress constants for liquids, for example.
<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Material name</td>
<td>Shows the name of the selected material from the list or adds a new material.</td>
</tr>
<tr>
<td>Delete Material</td>
<td>Deletes the selected material including all values (no undo).</td>
</tr>
<tr>
<td>Database</td>
<td>Opens the database dialog, see Database (page 214).</td>
</tr>
<tr>
<td>Add phase</td>
<td>Adds a phase to the selected material.</td>
</tr>
<tr>
<td>Delete phase</td>
<td>Deletes the selected phase of the selected material (no undo).</td>
</tr>
<tr>
<td></td>
<td>You cannot delete the last remaining phase of a material.</td>
</tr>
<tr>
<td>Plot property</td>
<td>Opens X-Y Plot dialog, see X-Y Plot (page 216), which shows a plot of the</td>
</tr>
<tr>
<td></td>
<td>numerical expression in the selected field. The cursor must be positioned</td>
</tr>
<tr>
<td></td>
<td>in field that contains a numerical function.</td>
</tr>
<tr>
<td>Characteristic numbers</td>
<td>Calculates useful numbers for convection computation, see Characteristic</td>
</tr>
<tr>
<td></td>
<td>Numbers (page 216)</td>
</tr>
<tr>
<td></td>
<td>Only available, if the material has a liquid phase.</td>
</tr>
<tr>
<td>Revision</td>
<td>Revision number of material.</td>
</tr>
<tr>
<td>Status</td>
<td>Status of the material compared to the matching material in the database.</td>
</tr>
<tr>
<td>Critical T (K)</td>
<td>Represents the maximal temperature that this material can endure (in K).</td>
</tr>
<tr>
<td>Mushy zone (K)</td>
<td>Represents half the interval in which the latent heat of this material is</td>
</tr>
<tr>
<td></td>
<td>released (in K).</td>
</tr>
<tr>
<td>Comments</td>
<td>For each material you can enter a comment in the box, e.g. on the state or</td>
</tr>
<tr>
<td></td>
<td>on doubtful values.</td>
</tr>
<tr>
<td>[Numerical fields]</td>
<td>In the numerical fields of the phase columns you can select one of the</td>
</tr>
<tr>
<td></td>
<td>options in the list boxes or enter constant values for the material</td>
</tr>
<tr>
<td></td>
<td>property as well as numerical expressions for functions dependent on the</td>
</tr>
<tr>
<td></td>
<td>temperature T, e.g. 98.5+T*(-0.064+T*1.4e-05).</td>
</tr>
<tr>
<td></td>
<td>For key functions and shortcuts for entering values and functions see Key</td>
</tr>
<tr>
<td></td>
<td>Functions and Shortcuts (page 260).</td>
</tr>
</tbody>
</table>

**Tip**

You can plot the specified function with **Plot property**, see X-Y Plot (page 216).

**Related Procedures**

- Adding, Replacing and Deleting Materials (page 27)
- Modifying Materials Properties (page 32)
- Assigning Materials to Regions (page 37)

**10.4.1.1. Database**

This dialog is opened via Materials (page 213).

In this dialog the material database and furnace’s materials are set up and maintained.
Figure 10.19. Database dialog

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Material database</td>
<td>List of materials in the CrysVUn material database. The materials coming from a central source, e.g. the software provider or a central administrator, are automatically loaded during the “Update database” procedure. These materials have the status <strong>CentralDb</strong> and are locked. Materials added by user (via Database dialog) have the status <strong>LocallyAdded</strong>.</td>
</tr>
<tr>
<td>Local materials</td>
<td>List of materials in the current furnace which can contain materials from the material database and locally added materials. These materials feature the following states:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Up_to_date</strong></td>
</tr>
<tr>
<td></td>
<td>The material properties are in accordance with properties of the matching material from the database.</td>
</tr>
<tr>
<td></td>
<td>• <strong>NeedsPatch</strong></td>
</tr>
<tr>
<td></td>
<td>The material needs to be patched against the material database, because a new revision of the material is available.</td>
</tr>
<tr>
<td></td>
<td>• <strong>LocallyModified</strong></td>
</tr>
<tr>
<td></td>
<td>The properties of the material differ from the properties of the matching material in the database.</td>
</tr>
<tr>
<td></td>
<td>• <strong>LocallyAdded</strong></td>
</tr>
<tr>
<td></td>
<td>The material was manually added to the furnace in the Materials dialog.</td>
</tr>
<tr>
<td>→</td>
<td>Copies a material from the database to the furnace's material list or updates the material properties in the furnace according to the selected material in the database.</td>
</tr>
<tr>
<td>←</td>
<td>Copies a locally added material from the furnace's material list to the database or adds a new revision of this material into the database in case that the database already contains the material.</td>
</tr>
<tr>
<td>Update all</td>
<td>Updates the properties of all furnace's materials which need patch.</td>
</tr>
<tr>
<td>Save all</td>
<td>Saves all locally added or changed materials from the furnace to the database.</td>
</tr>
</tbody>
</table>
Locks and unlocks the selected material in the material database. If it has more revisions, all of them are locked. If the furnace uses the material, it is locked also inside the furnace.

**Note**
Materials in the database cannot be locked or unlocked by the user, if they have the status **CentralDb**.

Deletes the selected material from the database. If the material has more revisions, only the selected one is deleted.

**Properties status**
For the material selected the properties and the values in which the database and the current furnace differ are listed in this field.

- **database value**: property value in the material database
- **local value**: property value in the current furnace.

**Related Procedures**
Copying materials from the material database to the furnace (page 28)

10.4.1.2. X-Y Plot

The **X-Y Plot** dialog shows a plot of the numerical function, which is selected in the **Materials** dialog.

![Figure 10.20. X-Y plot](image)

**Item** | **Description**
--- | ---
xmin | Specifies the x-range for the plot.
ymax | respectively
expr | Shows the numerical expression for the plotted function. You can edit the expression only in the according numerical field in the **Materials** dialog.

10.4.1.3. Characteristic Numbers
This dialog is opened via Materials (page 213).

In **Characteristic Numbers** dialog some useful numbers for convection are calculated.
Only available, if the material has a liquid phase.

*Figure 10.21. Characteristic Numbers dialog*

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Input parameters</strong></td>
<td></td>
</tr>
<tr>
<td>• T (K): temperature</td>
<td></td>
</tr>
<tr>
<td>• ( \Delta T ) (K): temperature difference</td>
<td></td>
</tr>
<tr>
<td>• L (m): characteristic length</td>
<td></td>
</tr>
<tr>
<td>• v (m/s): velocity</td>
<td></td>
</tr>
<tr>
<td><strong>Prandtl</strong></td>
<td>Prandtl number</td>
</tr>
<tr>
<td><strong>Grashof</strong></td>
<td>Grashof number</td>
</tr>
<tr>
<td><strong>Rayleigh</strong></td>
<td>Rayleigh number</td>
</tr>
<tr>
<td><strong>Reynolds</strong></td>
<td>Reynolds number</td>
</tr>
<tr>
<td><strong>Lewis</strong></td>
<td>Lewis number</td>
</tr>
<tr>
<td><strong>solutal Peclet</strong></td>
<td>solutal Peclet number</td>
</tr>
<tr>
<td><strong>thermal Peclet</strong></td>
<td>thermal Peclet number</td>
</tr>
<tr>
<td><strong>Schmidt</strong></td>
<td>Schmidt number</td>
</tr>
<tr>
<td><strong>magnetic Taylor</strong></td>
<td>magnetic Taylor number</td>
</tr>
<tr>
<td><strong>Hartmann</strong></td>
<td>Hartmann number</td>
</tr>
</tbody>
</table>

**Related Procedures**
Using the Characteristic Numbers Dialog (page 44).

**10.4.2. Labels**
This dialog is opened via Settings Menu (page 212).

The labels dialog enables you to assign labels to regions and lines. For instance, before joining a cartridge with a furnace insert in a SQF configuration the contact region and the contact line need to be labelled.

*Figure 10.22. Labels dialog*
### Regions

Sets a label to all selected regions:

- **Label**  
  Input field used to specify the label.

- **Keywords**  
  List of predefined labels:
  - **WallHeatFluxRef**: names a region to be considered as reference region in heat flux monitoring across a line from this region.
  - **LMR**: names a region which belong to the cartridge's LMR.

### Lines

Sets a label to all selected lines:

- **Label**  
  Input field used to specify the label.

- **Keywords**  
  List of predefined labels:
  - **Sliding**: names a sliding line of a moving region in order to not distort their neighbors during moving operation.
  - **Contact**: names the contact line between cartridge and furnace insert requested by joining process.

### Related Procedures

- Moving Regions (page 66)
- Labels and Joiner (page 48)

#### 10.4.3. Symmetry

This dialog is opened via Settings Menu (page 212).

In the **Symmetry** dialog you select the symmetry of your furnace.

*Figure 10.23. Symmetry dialog*
### Item Description

**Axial**
Sets the axial symmetry. This is the normal case, for which CrysVUn is designed.

**Translational**
Sets the translational symmetry (2D simulation). The furnace is treated in Cartesian coordinates \((x; y)\) and extended infinitely in the third direction \((z)\), so that there is no gradient in \(z\)-direction.

### Related Procedures

Setting Symmetry (page 25)

### 10.4.4. Grid

This dialog is opened via Settings Menu (page 212).

In **Grid** dialog you set the fineness of the unstructured grid meshes. The numerical computations in CrysVUn are based on this grid.

#### Figure 10.24. Grid dialog

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Edge length [m]</strong></td>
<td>Sets the desired edge length of the triangles in the selected regions respectively on the selected lines.</td>
</tr>
<tr>
<td><strong>Fit slope</strong></td>
<td>Sets the maximum gradient of the edge lengths in the selected regions.</td>
</tr>
<tr>
<td><strong>select all regions, select all lines</strong></td>
<td>Selects all regions respectively all lines. All settings will be applied to all regions respectively all lines.</td>
</tr>
<tr>
<td><strong>Respect edge length</strong></td>
<td>By default, if the geometrical dimensions are smaller than the specified grid parameters the grid length is reduced. In case the <strong>respect edge length</strong> button is active, the user defined values are taken.</td>
</tr>
</tbody>
</table>

### Related Procedures

Grid Properties (page 53)

### 10.4.5. Physical Phenomena

This dialog is opened via Settings Menu (page 212).

In the **Physical Phenomena** dialog you set physical variables to be solved in the selected region, e.g. temperature or stress. It is not possible to calculate any variable in all regions.
Figure 10.25. Physical Phenomena dialog

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>region(s) selected</td>
<td>Shows the number of selected regions. At least one region must be selected, before you can set a variable to be solved.</td>
</tr>
<tr>
<td>select all regions</td>
<td>Selects all regions in the whole drawing.</td>
</tr>
<tr>
<td>Yes</td>
<td>The according variable will be calculated in the selected region(s).</td>
</tr>
<tr>
<td>No</td>
<td>The relative variable will not be calculated in the selected region(s). Select this option, if the variable in the selected region(s) is not needed.</td>
</tr>
<tr>
<td>Ignore</td>
<td>Leaves the settings for the variable unchanged. Use this option, if you have selected more than one region and the variable has different settings in these regions.</td>
</tr>
</tbody>
</table>

Related Procedures
Physical Phenomena (page 56)

10.4.6. Initial Values

This dialog is opened via Settings Menu (page 212).

*CrysVUn* needs an initial value inside the regions for all variables to make computations. In the **Initial Values** dialog you set these initial values.

Figure 10.26. Initial values dialog

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>region(s) selected</td>
<td>Shows the number of selected regions.</td>
</tr>
<tr>
<td>Select all regions</td>
<td>Selects all regions in the whole drawing.</td>
</tr>
<tr>
<td>Item</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Variable</td>
<td>Selects the desired variable.</td>
</tr>
<tr>
<td>Initial value</td>
<td>Specifies the initial value of the selected variable for the selected region(s).</td>
</tr>
<tr>
<td>all variables</td>
<td>Sets all variables to the specified initial values.</td>
</tr>
<tr>
<td>selected variable</td>
<td>Sets the selected variable to the specified initial value.</td>
</tr>
</tbody>
</table>

Related Procedures
Initial Values (page 57)

10.4.7. Boundaries

This dialog is opened via Settings Menu (page 212).

In the **Boundaries** dialog you can display and define boundary conditions for a set of variables that are to be solved (e.g. temperature) and for each line in the drawing.

![Boundaries dialog](image)

**Figure 10.27. Boundaries dialog**

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>lines selected</td>
<td>Shows the number of selected lines. All settings are applied only to the selected lines.</td>
</tr>
<tr>
<td>hide</td>
<td>The boundary conditions are not shown in the drawing.</td>
</tr>
<tr>
<td>show</td>
<td>The boundary conditions are shown in the drawing for the variable selected.</td>
</tr>
<tr>
<td>show all</td>
<td>All boundary conditions are shown in the drawing for all variables.</td>
</tr>
<tr>
<td>Variable</td>
<td>Selects the variable for specifying the boundary conditions.</td>
</tr>
</tbody>
</table>
| Type           | Selects the type of boundary conditions for the selected variable and the selected line(s). Default is **No boundary**. Which boundary conditions are available depends on the variable selected. For temperature, velocity U, velocity V, velocity W, pressure, stream function, concentration, in-phase potential and out-of-phase-potential the following boundaries are available:  

- **Neumann**  
  Specifies a constant flux density of the variable normal to the
For details see Boundary Conditions (page 58).

For UVW velocities the following boundaries are available:

- **Zero velocity**
- **Normal velocity**
- **Tangential velocity**
- **Marangoni**
- **Outflow**

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>line. e.g. you can specify an adiabatic boundary condition setting flux = 0, or define a function f(l) along the line.</td>
<td></td>
</tr>
<tr>
<td><strong>Dirichlet</strong></td>
<td>Specifies a fixed value of the variable along the line. You can set a constant value along the line, a function f(l) along the line or a profile.</td>
</tr>
<tr>
<td><strong>Poincaré</strong></td>
<td>Specifies that the flux is proportional to the difference between the value of the variable on the line and a given reference value. The reference value can be specified along a chosen boundary line f(l). The coefficient can be specified as a function of the variable itself f(x).</td>
</tr>
<tr>
<td><strong>Temperature dependent Dirichlet</strong></td>
<td>Specifies a fixed value of the variable along the line. The value used is, computed from the value of the temperature variable at the line (f(T)). The usage of profile files is not supported by this boundary type. This boundary type is not available for the variable temperature and in/out phase potential.</td>
</tr>
<tr>
<td><strong>Temperature dependent Poincaré</strong></td>
<td>Specifies that the flux is proportional to the difference between the value of the variable on the line and a given reference value. The reference value can be specified as a function of the temperature at the given position f(T). The coefficient can also be specified as function of the temperature f(T). This boundary type is not available for the variable temperature and in/out phase potential. The usage of profile files is not supported by this boundary type.</td>
</tr>
</tbody>
</table>

Value | Input field for the value of the desired boundary type. |
Profile | Clicking on this check box activates the input field for a file name containing a profile of boundary conditions (*.pro file), which vary along the selected lines or are time-dependent. |
File name | Specifies a *.pro file containing the desired boundary conditions. |
Browse | Selects a *.pro file containing boundary conditions. |
Tip
You do not need to enter the path, if the *.pro file is in the same directory as the *.crys file.

**column**

- Specifies the column number of the boundary condition in the *.pro file (File name).
- Specifies which column of *.pro file contains boundary data. If more columns define a boundary, this number specifies the first column containing boundary description data.

### Related Procedures

**Boundary Conditions** (page 58)

### 10.4.8. Heaters

This dialog is opened via Settings Menu (page 212).

Each region can be defined as a heater. In the Heaters dialog you can display, add, change and delete heaters.

**Note**

- A region can be part only of one heater, but a heater can consist of one or more regions. In this case you must portion out the power of the resistance heater.

![Heaters dialog](image)

**Figure 10.28. Heaters dialog**

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Heaters</td>
<td>Shows a list of all heaters and their power respectively current in column <strong>Actual</strong>. When you select a heater from the list, the settings of the heater are displayed and the corresponding regions are selected in the Main Window. When you click on a region in the Main Window, a new heater is added respectively the corresponding heater is selected in the list. You can piece together a heater from more than one region, if you select a heater, hold the <strong>CTRL</strong> key and select further regions. To portion out the total power to the regions see Heaters (page 61).</td>
</tr>
<tr>
<td>Item</td>
<td>Description</td>
</tr>
<tr>
<td>------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Name</td>
<td>You can enter a name for the heater in this field (no spaces allowed). Confirm with Enter or click Apply to save the entry.</td>
</tr>
<tr>
<td>delete heater</td>
<td>Deletes the heater from the list. The corresponding regions remain in the drawing.</td>
</tr>
<tr>
<td>Regions of heater</td>
<td>Shows the regions of the selected heater and their fractions of the heater's total power respectively current.</td>
</tr>
<tr>
<td>Fraction</td>
<td>Specifies the fraction of the heater's power belonging to the selected region. The sum of all fractions for one resistance heater must be 1, e.g. 0.2, 0.3 and 0.5 for a heater consisting of three regions.</td>
</tr>
<tr>
<td>delete region</td>
<td>Deletes the selected region from the list, so that the region does not belong to the selected heater any more. The region in the Main Window will remain, so that you can reassign the deleted region to the heater every time. You can assign a region only to one heater at the same time.</td>
</tr>
<tr>
<td>Resistance</td>
<td>Specifies the selected heater as a resistance heater, which is defined by its power value (in W).</td>
</tr>
<tr>
<td>Induction</td>
<td>Specifies the selected heater as an induction heater, which is defined by the current through the coil (in A) and its Frequency (in Hz).</td>
</tr>
<tr>
<td>Fixed power</td>
<td>The heating power respectively current is constant during the simulation.</td>
</tr>
<tr>
<td>Profile power</td>
<td>The power respectively current is time-dependent and read from the specified file. The first column contains the time (in s) and the power respectively the current at that time in the column (col) specified by the dialog. Linear interpolation is used between the rows of the file.</td>
</tr>
<tr>
<td>Controlled power</td>
<td>The power respectively current will be calculated in an inverse simulation, see Running an Inverse Simulation (page 140). In this case, you must set the minimal allowed power respectively current (min:) and the maximal allowed power respectively current (max:).</td>
</tr>
<tr>
<td>Controlled profile</td>
<td>The power respectively current will be calculated in an inverse simulation. In this case, you must set the minimal allowed power respectively current (min) and the maximal allowed power respectively current (max). The initial values for the power respectively current of the heater are read from the specified file. After the simulation the final power (current) values will be saved to the same place. If no file exists, it will be created. Between the rows of the file linear interpolation is used.</td>
</tr>
<tr>
<td>file name</td>
<td>Specifies a *.pro file with the desired time-dependent heater profile. This is available for the options Profile power and for Controlled profile.</td>
</tr>
<tr>
<td>Column</td>
<td>Specifies the column number in the *.pro file (file name) with the heater values (power in W for resistance heaters or current in A for inductive heaters).</td>
</tr>
</tbody>
</table>
10.4.9. Control Points

This dialog is opened via Settings Menu (page 212).

In the Control Points dialog you specify points with fixed temperature for inverse simulation, in order to answer the question, what heating power you need to obtain certain temperatures at given points, see Control Points for Inverse Simulation (page 64).

In this case you have to specify at least one heater to be variable, i.e. to be a controlled heater, see Heaters (page 61).

![Control points dialog](image)

**Figure 10.29. Control points dialog**

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>List of control points</td>
<td>Shows the actual control points, i.e. points with fixed temperature. For editing you select a control point in the list. A red cross indicates the position of the selected control point in the Main Window.</td>
</tr>
<tr>
<td>State</td>
<td>Can be Relative or Absolute. The Relative state demands two arguments ref-x and ref-y; it means that the temperature must be relative to the temperature in point (ref-x; ref-y).</td>
</tr>
<tr>
<td>Toler</td>
<td>Specifies the tolerance of the temperature (in K) allowed at this point.</td>
</tr>
<tr>
<td>Value</td>
<td>Specifies the desired Temperature (K) for the control point.</td>
</tr>
<tr>
<td>Profile</td>
<td>Clicking on the check box deactivates the value input field and activates the input field for a *.ctrl file name.</td>
</tr>
<tr>
<td>file name</td>
<td>Enter name of *.ctrl file containing time-dependent values for the control point, see Control Points for Inverse Simulation (page 64). The first column of the *.ctrl file always contains the time.</td>
</tr>
<tr>
<td>Browse</td>
<td>Opens the Select File dialog to browse for a *.ctrl file.</td>
</tr>
<tr>
<td>column</td>
<td>Number of the column in which the desired values for this control point are to be found.</td>
</tr>
<tr>
<td>Change</td>
<td>Changes the settings for the selected control point. You have to enter the changes first.</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the selected control point.</td>
</tr>
</tbody>
</table>
### Item | Description
--- | ---
**Add** | Adds a new control point leaving the selected control point unchanged. You must enter the values for the new control point first.

### Related Procedures
Control Points for Inverse Simulation (page 64)

### 10.4.10. Moving Regions
This dialog is opened via Settings Menu (page 212).

In the **Moving Regions** dialog you specify moving regions and their velocity in time-dependent computation.

![Figure 10.30. Moving regions dialog, Fixed Velocity](image)

![Figure 10.31. Moving regions dialog, Variable Velocity](image)

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>n region(s) selected</td>
<td>Shows how many regions are selected. If no region is selected, the moving parameters are disabled.</td>
</tr>
</tbody>
</table>
| select all moving regions | Selects all regions, which you have already specified as a moving region. If you have not yet specified a moving region, no region will be selected.  

**Note**  
If you have defined moving regions with different parameters, a warning message is shown and No moving moving type is automatically selected. |
| Fixed velocity | The regions will move in time with a fixed velocity. The velocity components are given as **parameters**:  

- r-velocity (m/s):  
- z-velocity (m/s): |
<p>| Variable velocity | Specifies that the regions’ velocity will change in time. The velocity values are taken from an input file which contains the r and z-velocity at each desired time. |</p>
<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parameters:</td>
<td></td>
</tr>
<tr>
<td>• file name:</td>
<td>specifies the input file containing the r and z-velocity in time</td>
</tr>
<tr>
<td>• column:</td>
<td>specifies the column number of r-velocity; next column must be of z-velocity. The first columns must be the time!</td>
</tr>
<tr>
<td></td>
<td>In order to get a velocity between the defined time steps, a step-wise interpolation is used.</td>
</tr>
<tr>
<td>Position profile</td>
<td>The regions will move in time by specifying their positions. The positions are computed based on the r and z-displacement at each desired time.</td>
</tr>
<tr>
<td>Parameters:</td>
<td></td>
</tr>
<tr>
<td>• file name:</td>
<td>specifies the input file containing the r and z-displacement in time</td>
</tr>
<tr>
<td>• column:</td>
<td>specifies the column number of r-displacement; next column must be of z-displacement. The first columns must be the time!</td>
</tr>
<tr>
<td></td>
<td>The linear interpolation is used in order to get a position between the defined time steps.</td>
</tr>
<tr>
<td>No moving</td>
<td>Specifies that selected regions will not move during the time-dependent computation.</td>
</tr>
</tbody>
</table>

**Note**

Non-moving regions which are connected to a moving region will change their form accordingly. To prevent neighboring regions from being affected, you can assign the label “Sliding” to the contact line, see Assigning labels (page 48).

**Related Procedures**

- Moving Regions (page 66)
- Defining a moving region (page 154)

**10.5. Computation Menu**

The Computation menu is the core of CrysVUn. Here you set process, numerical and convection parameters, you generate the grid, compute view factors and monitor the solving process.

The Computation menu is only available in Simulation Mode.
<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Time Model</strong></td>
<td>Opens <strong>Time Model</strong> dialog window for specifying pseudo-stationary or fully implicit (time-dependent) simulation, see Time Model Choice (page 70) and Time Model (page 229).</td>
</tr>
<tr>
<td><strong>Process parameters</strong></td>
<td>Opens <strong>Process parameters</strong> dialog window for specifying parameters, when heat transport by conduction or radiation, or an external magnetic field is considered, see General process parameters (page 71) and Process parameters (page 230).</td>
</tr>
<tr>
<td><strong>Numerical parameters</strong></td>
<td>Opens <strong>Numerical parameters</strong> dialog window Setting Numerical parameters (page 76) for setting values</td>
</tr>
<tr>
<td></td>
<td>• for the computation of the <strong>View factors</strong>, see View factors (page 234).</td>
</tr>
<tr>
<td></td>
<td>• for the solver for <strong>Forward</strong> simulation, see Forward (page 235).</td>
</tr>
<tr>
<td></td>
<td>• for the solver for <strong>Inverse</strong> simulation, see Inverse (page 237).</td>
</tr>
<tr>
<td></td>
<td>For details on numerical parameters see Setting Numerical parameters (page 76).</td>
</tr>
<tr>
<td><strong>Convection parameters</strong></td>
<td>Opens <strong>Convection</strong> dialog window for setting parameters for the computation of convection</td>
</tr>
<tr>
<td></td>
<td>• for convergence criteria in the <strong>Abortion</strong> tab, see Abortion (page 241).</td>
</tr>
<tr>
<td></td>
<td>• for updating of the interface between the solid and the liquid phase in the <strong>Multiphase</strong> tab, see Multiphase (page 242).</td>
</tr>
<tr>
<td></td>
<td>• for specifying a ramp for the density, heat capacity or viscosity in the <strong>Ramps</strong> tab, see Ramps (page ?).</td>
</tr>
<tr>
<td></td>
<td>• for selecting a solver for velocity correction and for pressure correction in the <strong>Solver</strong> tab, see Solvers (page 243).</td>
</tr>
<tr>
<td>Item</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>-------------</td>
</tr>
<tr>
<td>For details on convection parameters see Convection parameters (page 240) and Setting Convection parameters (page 84).</td>
<td></td>
</tr>
</tbody>
</table>
| Alloy Parameters | Opens the dialog for setting the parameters for calculating alloy solidification:  
  - Specify the phase diagram properties: Phase diagram (page 245)  
  - Select a permeability law a set the microstructural parameters: Permeability (page 246)  
  - Define numerical parameters and phase diagram coupling method: Numerical (page 247)  
  - Set abortion criteria: Abortion (page 248) |
| Monitor | Opens Monitor/Write Profile dialog window, see Monitor/Write Profile (page 254).  
Only available in time-dependent computation. |
| Show Solver Information | Opens Show Solver Information dialog window for displaying the actual residuum, rowsums or solver information during flow computation, see Show Solver Information (page 248). |
| Generate Grid | Generates the grid. The grid defines points in the furnace, on which the computation is based. It must be generated after having modified the geometry and before view factors and variables are computed. For changing the grid see Grid Properties (page 53).  
You can also click on the generate grid button. |
| Adapt grid | Adjust the grid density inside the regions where the turbulent convection has to be solved, see Adapt grid (page 249). |
| Compute View Factors | Computes the view factors for the heat transfer by radiation. |
| Start Computation | Starts the simulation with the actual settings and parameters, i.e. the computation of the variables set in the variable list box in the tool bar of the Main Window.  
The progress is displayed in the status bar in the Main Window. When the computation is finished, “Ready” is displayed in the status bar.  
You can also click on the compute variable button. |
| Stop Computation | Stops the running computation.  
You can also click on the stop button. |

**10.5.1. Time Model**  
This dialog is opened via Computation Menu (page 227).
In the Time Model dialog you set pseudo-stationary simulation (default) or time-dependent simulation (Full implicit) and the relative parameters.

In pseudo-stationary simulation, the facility you are using is handled to be in a stationary state. But additionally some things like latent heat, which is released during solidification, are taken into account. Since these features are time-dependent, the model is called pseudo-stationary instead of stationary. All fields are gray when pseudo-stationary is selected. In time-dependent simulation, the variables are computed at every Time step between Start time and End time. If one time step is solved in less than the number of max. iterations, the following time-step is increased by the Incremental factor. This is done until the value for the max. time step is reached. If one time step takes more iterations than the max. iterations, the following time step is decreased by the decremental factor.

![Time Model dialog](image)

**Figure 10.33. Time Model dialog**

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time Model:</td>
<td></td>
</tr>
<tr>
<td>• pseudo-stationary</td>
<td></td>
</tr>
<tr>
<td>• Full Implicit</td>
<td></td>
</tr>
<tr>
<td>[parameter list]</td>
<td>All parameters are only used for the time-dependent computation (Full implicit):</td>
</tr>
<tr>
<td></td>
<td>• Start time (s)</td>
</tr>
<tr>
<td></td>
<td>• Stop time (s)</td>
</tr>
<tr>
<td></td>
<td>• Time step (s)</td>
</tr>
<tr>
<td></td>
<td>• Max. time step (s)</td>
</tr>
<tr>
<td></td>
<td>• Max. iterations</td>
</tr>
<tr>
<td></td>
<td>• Incremental factor</td>
</tr>
<tr>
<td></td>
<td>• Decremental factor</td>
</tr>
</tbody>
</table>

**Related Procedures**

Time Model Choice (page 70).

**10.5.2. Process parameters**
This dialog is opened via Computation Menu (page 227).
In this dialog general process parameters and parameters for magnetic fields can or have to be set.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>General</td>
<td>General parameters for influencing the simulation process, see General process parameters (page 231).</td>
</tr>
<tr>
<td>Electrical Potential</td>
<td>Parameters for rotating and stationary magnetic fields, see Electrical Potential (page 232).</td>
</tr>
<tr>
<td>Magnetic field</td>
<td>Parameters for travelling magnetic fields, see Travelling Fields (page 233).</td>
</tr>
</tbody>
</table>

Related Procedures
Setting Process parameters (page 71)

10.5.2.1. General process parameters

Figure 10.34. Process parameters dialog, General tab

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
</table>
| Growth rate (m/s)     | Specifies the estimated growth rate in m/s. The growth rate is defined positive, if the interface between the solid and the liquid phase is moving upwards in positive z direction (VGF furnaces). The growth rate is defined negative, if the interface is moving down as in Czochralski furnaces, see General process parameters (page 71).
| Gas pressure (N/m²)   | Specifies the gas pressure in the furnace in N/m².                                                |
| Gravity (m/s²)        | Specifies the gravity in m/s².                                                                     |
| Czochralski growth parameters | • Crystal Rotation (Hz): specifies the frequency of the crystal's rotation.   |
|                       | • Translation heat flux inside crystal: the additional heat flux due to the movement of the crystal is included as a quasi-steady approximation in the temperature computation. |
Related Procedures
General process parameters (page 71)

10.5.2.2. Electrical Potential
Specifies the parameters for rotating and stationary magnetic fields:

- **RMF**: (Rotating Magnetic Field)
- **Stationary Magnetic Fields**

The parameters for travelling magnetic fields are available in the Travelling Fields tab.

**Rotating Magnetic Field parameters**

- **Magnetic induction (T)**: Magnetic induction of the generated field in Tesla.
- **Sample radius (m)**: Radius of the sample.
- **Pole pairs**: Number of pole pairs used for generating the RMF.
- **Rotating frequency (Hz)**: Rotating frequency of the external magnetic field in Hz.

**Stationary Magnetic Field parameters**

- **Magnetic induction (T)**: Magnetic induction of the generated field in Tesla.
- **Sample radius (m)**: Radius of the sample (only for cusp configuration).
### Related Procedures

Process parameters: Rotating magnetic field (page 72)

Process parameters: Alternating magnetic fields (page 73)

Process parameters: Stationary magnetic field (page 75)

#### 10.5.2.3. Travelling Fields

In this dialog the parameters for travelling magnetic fields (TMF) can be defined. The details of the implementation and the physical background can be found in the master thesis of M. Iugam (see Bibliography (page 277)).

---

#### Item Description

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Model</td>
<td>Type of Model that is used (MHD1 or MHD2).</td>
</tr>
<tr>
<td>Configuration</td>
<td>Axial or CUSP magnetic field.</td>
</tr>
<tr>
<td>Cusp origin</td>
<td>Offset of the CUSP origin from the CrysVUn coordinate system (only for cusp configuration).</td>
</tr>
</tbody>
</table>

---

#### Item Description

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Model</td>
<td>Two different models for representing travelling magnetic fields in CrysVUn are available:</td>
</tr>
<tr>
<td></td>
<td>• <strong>continuous</strong>: Idealized model assuming a single sine magnetic wave, travelling in z-direction.</td>
</tr>
<tr>
<td></td>
<td>• <strong>discrete</strong>: In this model three coils are assumed to surround the sample.</td>
</tr>
</tbody>
</table>

#### continuous model parameters

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AC Frequency (Hz)</td>
<td>The frequency of the travelling wave (default: 50Hz).</td>
</tr>
<tr>
<td>Travelling wavelength (m)</td>
<td>Wavelength of the travelling wave</td>
</tr>
</tbody>
</table>

---

Figure 10.37. TMF: continuous model parameters

Figure 10.38. TMF: discrete model parameters
### Discrete model parameters

Specifies the following parameters:

- **AC frequency (Hz):** Frequency of the current in the induction coils (default 50Hz).
- **Coils’ radius (m):** Radius of the coil surrounding the sample (default: 0.04m).
- **Cylinder height (m):** The distance between the lower and the upper end of coil. The lowest coil is always at the lowest z-coordinate of the region in which travelling magnetic field shall be computed (default: 0.04m).
- **Current intensity (A):** The current through the coil (default: 0A).
- **Phase shift (rad):** The phase shift of the AC current between the coils (default: 2.0944).

### Related Procedures

- Setting parameters for the continuous model (page 73)
- Setting parameters for the discrete model (page 74)

### 10.5.3. Numerical parameters

This dialog is opened via Computation Menu (page 227).

In the **Numerical parameters** dialog values for computing view factors, for the solver and for inverse simulation can be set.

### Related Procedures

- Setting Numerical parameters (page 76)

### 10.5.3.1. View factors
The heat transfer by radiation is implemented in CrysVUn by view factors. Therefore you must calculate the view factors before computing the temperature.

On the View factors tab you set numerical parameters for the computation of the view factors and the renormation.

The view factors depend on the grid and some materials properties.

![Figure 10.39. Numerical parameters dialog, View factors tab](image)

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Radiation</td>
<td>The Gebhardt matrix will be renormed if the check box is active.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong></td>
</tr>
<tr>
<td></td>
<td>Renormation is not reversible! Once you computed a renormation you cannot deactivate the renormation check box.</td>
</tr>
<tr>
<td>Precision</td>
<td>Specifies the desired accuracy of the computation (real number, default 0.005).</td>
</tr>
<tr>
<td>threshold for Gebhardt-Matrix</td>
<td>If this factor is &gt; 0, only Gebhardt factors above a certain value are taken into account, see thesis M. Kurz, p. 71.</td>
</tr>
</tbody>
</table>

Related Procedures

Setting view factor parameters (page 77)

10.5.3.2. Forward

In the Forward tab the desired solver for the forward simulation can be selected and the appropriate numerical parameters can be specified. For the solver for the inverse simulation see Inverse (page 237).

**Note**

Usually the default values should not be changed.
### Item

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Forward solver and Preconditioner</strong></td>
<td>Determines which solver will be used in forward simulation, see Linear system equations solvers (page 76), default is STABBiCG. The default preconditioner is ILU.</td>
</tr>
<tr>
<td><strong>Parameters</strong></td>
<td>Specifies the parameters for the selected solver:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Maximal inner iterations</strong> &lt;br&gt;Number of maximal allowed iterations needed to solve one linear system of equations (“inner iterations”), integer number, default is 1000 (iterative solvers only).</td>
</tr>
<tr>
<td></td>
<td>• <strong>Maximal outer iterations</strong> &lt;br&gt;Number of maximal allowed re-computations of the coefficients of the system of equations for non-linear problems. This reconstruction of the matrix together with the solving is called an “outer iteration”, integer number, default is 500.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Desired residuum</strong> &lt;br&gt;Desired accuracy of the computation; must be a small real number, default is 1e-12.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Residuum improvement factor</strong> &lt;br&gt;At each “outer iteration” the solver is asked to perform inner iterations until the actual residuum has got smaller than the residuum of the previous outer iteration divided by this factor, default is 10 times.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Forward relaxation factor</strong> &lt;br&gt;At each iteration, when a new value is computed, only this fraction from the variation is taken. Real number between 0 and 1, default is 0.5.  &lt;br&gt;For time-dependent computations choose a value closer to 1. For pseudo-stationary computations choose a value closer to 0.</td>
</tr>
<tr>
<td><strong>Others</strong></td>
<td>Miscellaneous numerical options:</td>
</tr>
</tbody>
</table>

---

**Figure 10.40. Numerical parameters dialog, Forward tab**
### Item | Description
---|---

- **Track interface**
  
  Turns on the adjustment of the phase boundary in a two phase material when calculating temperature. The vertices next to the phase boundary are moved in order to match with the melting isothermal.(default: false)

- **Point defects ramp**
  
  Turns on the coupling between interstitial and vacancy concentration smoothly in order to improve the numerical stability.(default: false)

### Related Procedures

Setting parameters for forward simulation (page 80)

### 10.5.3.3. Inverse

In the **Inverse** tab the desired solver for the inverse simulation can be selected and the appropriate numerical parameters can be specified. For the solver for the forward simulation see Forward (page 235).

**Note**

Usually the default values should not be changed.

![Figure 10.41. Numerical parameters dialog, Inverse tab](image)

---

### Item | Description
---|---

**Inverse solver, Pre-conditioner**

Determines which solver will be used in inverse simulation, see Linear system equations solvers (page 76), default is **GSSV**. The default preconditioner is **ILU**.

**Parameters**

Specifies the parameters for the selected solver:

- **Maximal inner iterations**
  
  Number of maximal allowed iterations needed to solve one linear system of equations ("inner iterations"), integer number, default is 1000 (iterative solvers only).

- **Controller relaxation factor**
If the controller adjusts the power of a heater, it will apply only this fraction of all modifications. Real number between 0 and 1, default is 0.5.

- **Regularization parameter**
  This positive parameter determines how strong the heater power is taken into account in the quadratic cost function that has to be minimized in order to fulfill the temperature constraints. Real number, default is $1e^{-06}$.

- **Start controller at**
  The controller starts to work when the temperature residuum is below the given value. Real number, default is 0.005.

- **Minimum power criterion**
  This parameter is used as one abortion criterion for inverse simulations. Once the norm of the residual of the energy equation has fallen below the specified value, it is investigated whether the required values at the control points are reached. If this is not the case, the user gets the corresponding information in the terminal. Now, it is investigated whether the maximum power change is smaller than the value of the minimum power criterion. If this is the case, the computations are stopped, even the temperature values at the control points are out of the specified tolerance. The idea is that nothing is changing anymore. The default value for the minimum power criterion is $1.e-6$ and SHOULD NORMALLY NOT BE CHANGED.

<table>
<thead>
<tr>
<th>Update matrix sensitivity</th>
<th>Two conditions for updating the sensitivity matrix for the controller can be specified:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>• <strong>T-norm-change</strong> Relative change of the residuum of the temperature equation at which the sensitivity matrix will be updated. Real number, default is 0.1.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Number of steps</strong> Number of steps after which the sensitivity matrix for the controller will be in any case updated. Integer number, default is 10.</td>
</tr>
</tbody>
</table>

**Controller**
There are two controllers available in *CrysVUn*:

- **constrained**
  Selects the more recent controller which respects power limits for the heaters and allows tolerances for the control points (default).

- **unconstrained**
  Reactivates the old controller, which is more stable in some situation.
Related Procedures
Setting parameters for inverse simulation (page 81)

10.5.3.4. Species

In the *Species* tab allows to specify the numerical options for calculating the transport of a chemical species in a fluid.

![Numerical parameters dialog, Species tab](image)

Figure 10.42. Numerical parameters dialog, Species tab

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Parameters</strong></td>
<td>Specifies the parameters for solving the conservation equation for species transport</td>
</tr>
<tr>
<td>• Underrelaxation factor</td>
<td>At each iteration, when a new value is computed, only this fraction from the variation is taken. Real number between 0 and 1, default is 0.5.</td>
</tr>
<tr>
<td>• Maximal outer iterations</td>
<td>Number of maximal allowed recomputations of the coefficients of the system of equations for non-linear problems. This reconstruction of the matrix together with the solving is called an “outer iteration”. Integer number, default is 1000.</td>
</tr>
<tr>
<td>• Desired residuum</td>
<td>Desired accuracy of the computation; must be a small real number, default is 1e-12.</td>
</tr>
<tr>
<td><strong>Reference concentration</strong></td>
<td>Gives the reference concentration for the Boussinesq approximation for solutal driven convection. (Default: 0)</td>
</tr>
<tr>
<td><strong>Discretization schema</strong></td>
<td>Allows to switch between upwind and central difference discretization for the species transport (default: central).</td>
</tr>
<tr>
<td>• upwinding</td>
<td>Use the upwind discretization. The solution can be combined with the solution of the central discretization scheme using the deferred correction parameter.</td>
</tr>
<tr>
<td>• central schema</td>
<td>Use the central difference schema.</td>
</tr>
<tr>
<td>• Deferred correction</td>
<td>If the upwind discretization is used the user can specify a weight factor between the solution of the</td>
</tr>
</tbody>
</table>


**Related Procedures**

Setting parameters for species transport simulation. (page 82)
Specifying settings and parameters for computing concentration (page 183)

### 10.5.3.5. Stress

In the **Stress** tab allows to specify the numerical options for thermal stress computation.

![Figure 10.43. Numerical parameters dialog, Stress tab](image)

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Parameters</strong></td>
<td></td>
</tr>
<tr>
<td>Maximal inner iterations (default: 1000)</td>
<td></td>
</tr>
<tr>
<td>Desired residuum (default: 1e-12)</td>
<td></td>
</tr>
</tbody>
</table>

**Related Procedures**

Setting stress parameters (page 83)
Computing Thermoelastic Stress (page 170)

### 10.5.4. Convection parameters

This dialog is opened via Computation Menu (page 227).

In the **Convection parameters** dialog parameters for the computation of convection can be set.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Abortion</td>
<td>Opens the Abortion tab, see Abortion (page 241), for defining convergence criteria when solving buoyancy driven convection.</td>
</tr>
<tr>
<td>Multiphase</td>
<td>Opens the Multiphase tab, see Multiphase (page 242), for specifying the updating of the interface between the solid and the liquid</td>
</tr>
</tbody>
</table>
Item | Description
--- | ---
**Ramps** | Opens the **Ramps** tab, see Ramps (page 242), for specifying a ramp for the density, heat capacity or viscosity. This is useful when it is not possible to obtain a solution with the real material properties. E.g. the ramp starts with an increased viscosity and/or a decreased heat capacity and runs towards the final values.

**Solver** | Opens the **Solver** tab, see Solvers (page 243), for selecting a solver for velocity correction and for pressure correction. Usually the default values should not be changed.

**Turbulence** | Opens the **Turbulence** tab, see Turbulence (page 244), for selecting the numerical parameters used by turbulence model.

**Related Procedures**
Setting Convection parameters (page 84)

10.5.4.1. Abortion

The parameters in the **Abortion** tab define convergence criteria and underrelaxation when solving buoyancy driven convection, i.e. when Navier-Stokes- and Temperature-equation have to be solved.

**Figure 10.44. Convection dialog, Abortion tab**

| Item | Description
--- | ---
**Inner iteration limits** | **Momentum 1** and **Temperature 1** are convergence criteria for inner iteration loops.

**Stop of computation** | The computation shall stop when both specified values, **Momentum 2** and **Temperature 2** are reached or the solution is no longer changing (max. solution change).

**with buoyancy** | Buoyancy driven convection is solved (default).

**Underrelaxation velocity factors** | You can specify a linear dependency of the underrelaxation factors for the velocity equation.

**Related Procedures**
Setting abortion parameters (page 84)
10.5.4.2. Multiphase

If a solid-liquid transition is present, the interface is updated, when the values given on the Multiphase tab are reached, in order to keep the interface position synchronized.

![Figure 10.45. Convection dialog, Multiphase tab](image)

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adjust interface at</td>
<td>The interface between the solid and the liquid phase is updated, when the values specified by Momentum and Temperature are reached.</td>
</tr>
<tr>
<td>Max. difference from melting point</td>
<td>The interface between the solid and the liquid phase is updated, until the temperature of the calculated interface is closer to the melting point of the sample than the given maximum difference.</td>
</tr>
</tbody>
</table>

**Related Procedures**

Setting multiphase parameters (page 85)

10.5.4.3. Ramps

On the Ramps tab a ramp for density, heat capacity or viscosity can be specified. This is useful when you start from scratch and it is not possible to obtain a solution with the real material properties.

e.g. the ramp starts with an increased viscosity and/or a decreased heat capacity and runs towards the final values.

![Figure 10.46. Convection dialog, Ramps tab](image)
### Related Procedures

Setting ramp parameters (page 86)

10.5.4.4. Solvers

On the **Solver** tab different solvers for velocity and pressure correction equation can be selected.

**Note**

Usually the defaults should not be changed.

![Figure 10.47. Convection dialog, Solver tab](image)

### Table: Ramp Parameters

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>run a density ramp</td>
<td>If the check box is active, the ramp for the density is started, specified by the start factor density and multiply factor per step. The steps are defined by the values given in do steps at:.</td>
</tr>
<tr>
<td>run a capacity ramp</td>
<td>If the check box is active, the ramp for the heat capacity is started, specified by the start factor capacity and multiply factor per step. The steps are defined by the values given in do steps at:.</td>
</tr>
<tr>
<td>run a viscosity ramp</td>
<td>If the check box is active, the ramp for the viscosity is started, specified by the start factor viscosity and multiply factor per step. The steps are defined by the values given in do steps at:.</td>
</tr>
<tr>
<td>do steps at:</td>
<td>Ramp steps are performed when the norms are lower than the values given in momentum and temperature. To perform a ramp you must activate the appropriate check box and specify start and multiply factor.</td>
</tr>
</tbody>
</table>

### Table: Solver Parameters

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Velocity solver and Preconditioner</td>
<td>Determines which solver will be used, see Linear system equations solvers (page 76), default is STABBiCG. The default preconditioner is ILU.</td>
</tr>
<tr>
<td>Pressure solver and Preconditioner</td>
<td>Determines which solver will be used, see Linear system equations solvers (page 76), default is GSSV. The default preconditioner is ILU.</td>
</tr>
<tr>
<td>parameters</td>
<td>Specifies the parameters for the selected solver, left hand side for the velocity solver, right hand side for the pressure solver:</td>
</tr>
<tr>
<td>Item</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Max. inner iterations</strong></td>
<td>Number of maximum allowed iterations needed to solve one linear system of equations, integer number, default is 1000.</td>
</tr>
<tr>
<td><strong>Desired residuum</strong></td>
<td>Desired accuracy of the computation, real number, default is 1e-12.</td>
</tr>
</tbody>
</table>

**Related Procedures**

Selecting solvers (page 87)

**10.5.4.5. Turbulence**

On the **Turbulence** tab you set the special parameters required by turbulent convection computation.

![Figure 10.48. Convection dialog, Turbulence tab](image)

**Item**               | **Description**                                                                 |
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Underrelaxation</strong></td>
<td>The underrelaxation factors for k-ε turbulence transport equations.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Turbulent energy</strong>: underrelaxation factor for turbulent energy equation, recommended is 0.1.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Eddy dissipation</strong>: underrelaxation factor for eddy dissipation equation, recommended is 0.1.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Turbulent viscosity</strong>: underrelaxation for the change in the turbulent viscosity, recommended is 0.08.</td>
</tr>
</tbody>
</table>

**Parameters**

Specifies the parameters for the linear equation solvers.

- **Max. inner iterations**
- **Desired residuum**
- **Set last triangle at**

Specifies the value of k-ε equations residuum when the turbulent viscosity starts to be computed in the triangles laying at
the fluid-solid boundaries. Notice that the turbulent viscosity is not computed from the beginning, because of the numerical stability reasons.

### Related Procedures

- Setting turbulent convection parameters (page 88)

### 10.5.5. Alloy parameters

This dialog is opened via Computation Menu (page 227).

In the **Alloy parameters** dialog the options for the computation of alloy solidification are set. This includes problems with and without macrosegregation. For details of the used models please refer to the PhD thesis of M.Hainke (see Bibliography (page 277)).

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Phase diagram</td>
<td>Opens the Phase diagram tab, see Phase diagram (page 245), for specifying the properties of the phase diagram of the used material system.</td>
</tr>
<tr>
<td>Permeability</td>
<td>Opens the Permeability tab, see Permeability (page 246), for choosing one of the offered permeability models.</td>
</tr>
<tr>
<td>Numerical</td>
<td>Opens the Numerical tab, see Numerical (page 247), for specifying the numerical parameters like the underrelaxation factor</td>
</tr>
<tr>
<td>Abortion</td>
<td>Opens the Abortion tab, see Abortion (page 248), for defining the abortion criteria for the iterative solution procedure.</td>
</tr>
</tbody>
</table>

### Related Procedures

- Setting Convection parameters (page 84)
- Setting the parameters for alloy solidification (page 89)

#### 10.5.5.1. Phase diagram

The parameters in the **Phase diagram** tab describe a linearized phase diagram of a binary eutectic system and the used microsegregation model.

![Figure 10.49. Alloy dialog, Phase diagram tab](image)
**Microsegregation relation**

Approximations (default: lever-rule):

- **Lever rule**: Complete (infinite fast) back-diffusion between solid and liquid phase.
- **Scheil's relation**: No back diffusion from the solid to the liquid phase.

**Melt point of pure substance**

Defines upper left corner of the phase diagram (TP -default: 0))

**Liquidus line slope**

The liquidus line slope (ml) defines the liquidus temperature (TL) with the formula (default: 0)

\[ TL = TP + ml \degree C \]

**Liquidus temperature**

Defines the liquidus temperature of the initial composition of the used alloy (default: 0)

---

**Related Procedures**

Setting the parameters for alloy solidification (page 89)

10.5.5.2. Permeability

The parameters in the **Permeability** tab the desired permeability law for representing the interaction of the mushy zone with the melt flow is defined. The actual permeability of the mushy zone is compute based on the given microstructural parameters.

![Figure 10.50. Alloy dialog, Permeability tab](image)

---

**Item** | **Description**
---|---
**Permeability law** | Three relations are available:
  - Carman - Kozeny (default)
  - Schneider - Beckermann
  - Heinrich - Poirier

**Primary dendrite arm spacing** | Mean distance between the stem of the dendrites (default: 0).
### Related Procedures

Setting the parameters for alloy solidification (page 89)

### 10.5.5.3. Numerical

The parameters in the **Numerical** contains the parameters for controlling the iterative algorithm for solving problems including alloy solidification.

![Figure 10.51. Alloy dialog, Numerical tab](image)

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Secondary dendrite arm spacing</strong></td>
<td>Mean distance between the side branches of the dendrites. This parameter is ignored when the Carman-Kozeny equation is used (default: 0).</td>
</tr>
<tr>
<td><strong>Coupling scheme</strong></td>
<td>Three possibilities (default: analytical):</td>
</tr>
<tr>
<td></td>
<td>- <strong>Analytical</strong>: Relation for the liquid fraction based on the lever rule or Scheil's reaction. Only valid if no macrosegregation occur.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Enthalpy based</strong>: Iterative schema base on the definition of the enthalpy. Capable of handling macrosegregation.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Matrix based</strong>: Purely matrix based schema. Can handle macrosegregation but not the eutectic reaction of a system</td>
</tr>
<tr>
<td><strong>Liquidus fraction underrelaxation</strong></td>
<td>Underrelaxation factor for the correction of the liquid fraction (default: 0.1)</td>
</tr>
<tr>
<td><strong>Minimum factor for ( \frac{d\varepsilon}{dt} )</strong></td>
<td>Minimum relaxation factor (depending on the norm of the residual of the temperature equation) for taking an approximate ( \frac{d\varepsilon}{dt} ) value in the temperature equation as long as it is not known during the iterative solving procedure (default:0). If the value is 0, no approximated values are used.</td>
</tr>
<tr>
<td><strong>Maximum factor for ( \frac{d\varepsilon}{dt} )</strong></td>
<td>The same as above, but the maximum relaxation factor for the approximated ( \frac{d\varepsilon}{dt} ) (default: 0).</td>
</tr>
<tr>
<td><strong>Second liquid fraction correction</strong></td>
<td>Switch on second correction of the liquid fraction after correcting species and temperature field.</td>
</tr>
<tr>
<td>Item</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------------------------</td>
<td>------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Temperature correction relaxation</strong></td>
<td>Underrelaxation parameter for temperature in the second correction step (default: 0.5)</td>
</tr>
<tr>
<td><strong>Concentration correction relaxation</strong></td>
<td>Underrelaxation parameter for the species in the second correction step (default: 0.95)</td>
</tr>
</tbody>
</table>

**Related Procedures**

Setting the parameters for alloy solidification (page 89)

**10.5.5.4. Abortion**

The parameters in the Abortion tab defines the criteria for leaving the inner loop of correcting the the liquid fraction, temperature and species equation and compute the coupled flow field.

![Figure 10.52. Alloy dialog, Abortion tab](image)

**Item**

- **Maximum number of iterations**: Defines the maximum number of correction steps to perform before the flow field is computed again (default: 20).
- **Required phase diagram consistence**: Specifies the maximum averaged deviation in Kelvin of the nodes in the mushy zone from the phase diagram (default: 0.1).
- **Minimum liquid fraction change**: The phase diagram loop is left if the change in liquid fraction is smaller then the value specified in this field. Two values can be set: The value per iteration (default: 1e-5) and an cumulative change over five iterations (default: 0.0001).

**Related Procedures**

Setting the parameters for alloy solidification (page 89)

**10.5.6. Show Solver Information**

This dialog is opened via Computation Menu (page 227).

The Show Solver Information dialog shows the evolution of the solution procedure. Depending on the variable you are computing, you can choose between following the evolution of the residuum, of the row sums, or of the flow.
### Related Procedures

Display of Solver Information (page 96)

### 10.5.7. Adapt grid

This dialog is opened via Computation Menu (page 227).

The **Adapt Grid** dialog assists you in the adaptation of grid density in the regions by stretching of triangles in the vicinity of the region boundaries. The mesh nodes are shifted towards the boundary, the number of nodes remains unchanged.

The adapted grid is only required by turbulent convection computation. Some minimum grid density near the region boundary should be available before the procedure begins.

![Figure 10.54. Adapt Grid dialog](image)

**Item** | **Description**
---|---
Regions for Grid Adaption | Selects the regions for the grid stretching. Two methods are used to select them:

- **adapt for physical phenomena**
  
  Automatically selects all regions involved into the computation of a physical model. The available physical models are provided in the models selector - **turbulent energy** - and the user should select one of them. The default model is **turbulent energy**.
Related Procedures
Adapting grid (page 99)

10.6. Visualization Menu

With the Visualization menu you visualize the results of the simulation. The Visualization menu is only available in Simulation Mode.

![Figure 10.55. Visualization menu](image)

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show</td>
<td>Opens the Show dialog window, see Show (page251 ), for visualizing the results of the simulation in the right respectively the left side of the furnace in the Main Window.</td>
</tr>
<tr>
<td>Options for Scalar Fields</td>
<td>Opens Options for Scalar Fields dialog window, see Options for Scalar Fields (page252 ).</td>
</tr>
<tr>
<td>Zoom Out</td>
<td>Zooms out from any scale to the overview, in which all elements are displayed in the Main Window.</td>
</tr>
</tbody>
</table>
10.6.1. **Show**

This dialog is opened via Visualization Menu (page 250).

With the **Show** dialog you can visualize in the **Main Window** the grid, the temperature values (left and right side of the furnace) and the values of any other variable (only right side).

![Show dialog](image)

**Figure 10.56. Show**

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Left** | If a check box in the **left** column is activated, the grid, regions and/or **temperature** are visualized on the left side of the furnace in the **Main Window**.  

**Tip**  
Apart from grid and regions, on the left side you can only visualize the temperature, but you can do this independently from the variable selected in the **variable list box**.  
So you can display the temperature at any time on the left side and another variable on the right side. |
| **Right** | If a check box in the **right** column is activated, the grid, regions and/or computed values of the variable selected in the **variable list box** are visualized on the right side of the furnace in the **Main Window**. |
| **Regions** | Shows the regions. This option is set by default for the left and the right side.  
To show respectively hide the regions in the **right** side you can also click on the **show/hide geometry** button. |
| **Grid** | Shows the grid.  
To show respectively hide the grid in the **right** side you can also click on the **show/hide grid** button. |
| **Isolines** | Shows isolines of the computed values of the scalar variable selected in the **variable list box**.  
The properties of the isolines can be specified in the **Isolines** dialog, which you call by selecting **Visualization > Options for Scalar Fields**, see Options for Scalar Fields (page 252).  
To show respectively hide the isolines in the **right** side you can also click the **Show/hide isolines** button. |
| **Vector field** | Shows a representation of the computed values of the vector-valued variable selected in the **variable list box**, with arrows. The arrow length is proportional to the value of the current variable at the point given by the tail of the vector. |
You can double (halve) the arrow length by pressing the greater (less) key (i.e. the key with “>” (“<”) on it) and reset the length by pressing the space key.

**Scalar field**

Shows a color representation of the computed values of the variable selected in the variable list box.

The properties of this representation can be specified in the **Isolines** dialog, which you call by selecting **Visualization > Options for Scalar Fields**, see Options for Scalar Fields (page 252).

To show respectively hide the color representation in the right side you can also click the **Show/hide scalar field** button.

**Legend**

Shows the legend for the Scalar field. The properties of the legend can be specified in the **Isolines** dialog, which you call by selecting **Visualization > Options for Scalar Fields**, see Options for Scalar Fields (page 252).

### Related Procedures

Show results (page 105)

### 10.6.2. Options for Scalar Fields

This dialog is opened via Visualization Menu (page 250).

In **Options for Scalar Fields** dialog you set the properties for the visualization of isolines, the color representation of scalar fields and legend.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Isolines for</td>
<td>Selects the variable for the settings. You can save different settings for each variable separately.</td>
</tr>
<tr>
<td>Isolines</td>
<td>Isolines can be specified in two ways, by number and by distance:</td>
</tr>
<tr>
<td></td>
<td>• If the <strong>set number</strong> check box is activated (default), <strong>Number of isolines</strong> specifies the number of equidistant intervals over the range of values and the interval is computed.</td>
</tr>
<tr>
<td></td>
<td>To get rounded values for the isolines, you must enlarge the <strong>Data interval manually</strong> to round values and adapt the num-</td>
</tr>
</tbody>
</table>

![Figure 10.57. Options for Scalar Fields dialog](image-url)
<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>ber of isolines.</td>
</tr>
<tr>
<td></td>
<td>• If the <strong>set interval</strong> check box is activated, the <strong>isolines interval</strong> specifies the distance between the isolines in the dimension unit of the variable.</td>
</tr>
<tr>
<td></td>
<td><strong>Reference value</strong> specifies a certain value you want to be an isoline value, e.g. if you want to visualize all points with a certain temperature. The isolines will be shifted accordingly.</td>
</tr>
<tr>
<td>Data</td>
<td>Sets the range of values of the variable.</td>
</tr>
<tr>
<td></td>
<td>• If the <strong>automatic</strong> check box is activated (default), the minimum and the maximum values are taken for the range automatically.</td>
</tr>
<tr>
<td></td>
<td>• If the <strong>manually</strong> check box is activated, you can enter a range of values for which the isolines are visualized.</td>
</tr>
<tr>
<td></td>
<td>To restrict also the colors to this range, activate the <strong>partial scale</strong> check box.</td>
</tr>
<tr>
<td>Data format</td>
<td>Specifies the format of the values in the legend. <strong>Fixed</strong> is the decimal representation, e.g. 123.45, <strong>scientific</strong> is the exponential representation, e.g. 1.2345e+002.</td>
</tr>
<tr>
<td></td>
<td>You can specify the <strong>number of digits</strong> behind the point, and perform a <strong>logarithmic scale</strong>.</td>
</tr>
<tr>
<td>Paint</td>
<td>If the <strong>full scale</strong> check box is activated, the colors cover the whole range of current values, so that the regions are completely filled out with the colors from blue to red.</td>
</tr>
<tr>
<td></td>
<td>If the <strong>partial scale</strong> check box is activated, the colors from blue to red cover the range of values specified in <strong>data</strong>.</td>
</tr>
</tbody>
</table>

**Related Procedures**

Setting options for scalar fields (page 106)

**10.7. Analysis Menu**

With the **Analysis** menu you can save the computed results in text files which can be post-processed later by other software. You can save the results along an isoline, in points, along lines and from rectangles.

The **Analysis** menu is only available in Simulation Mode.

_Figure 10.58. Analysis menu_
### Item Description

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Write Isoline</td>
<td>Opens the Write Isoline dialog window, see Write Isoline (page 254), for saving an isoline of a defined variable and a defined value into a text file.</td>
</tr>
<tr>
<td>Write Profile</td>
<td>Opens Monitor/Write Profile dialog window, see Monitor/Write Profile (page 254), for saving the computed values of a variable into a text file. You can save the values in points, along polylines, or of the entire file for the selected variable.</td>
</tr>
<tr>
<td>Export Data</td>
<td>Opens Export Data dialog window, see Export Data (page 258), for saving the computed values of a variable in a rectangle into a text file.</td>
</tr>
<tr>
<td>Write Interface</td>
<td>Saves the position of the interface and the gradients at the interface to a file, Write Interface (page 259).</td>
</tr>
</tbody>
</table>

#### 10.7.1. Write Isoline

This dialog is opened via Analysis Menu (page 253).

In the Write Isoline dialog you can save an isoline of a defined variable and a defined value into a text file. The isoline is saved by its coordinates (in two columns), the resolution is set automatically.

![Write Isoline dialog](image)

*Figure 10.59. Write Isoline dialog*

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Value of</td>
<td>Specifies the variable from the pull-down menu and the value for the isoline in the dimension unit of the variable, see Units of Measurement (page 263).</td>
</tr>
<tr>
<td>File name</td>
<td>Specifies the file name of the text file, in which the information is to be saved. The default file name extension is *.iso. The file contains the rz coordinates for the specified value.</td>
</tr>
</tbody>
</table>

#### Related Procedures

Write isoline (page 107)

#### 10.7.2. Monitor/Write Profile

This dialog is opened via Analysis Menu (page 253).

In the Monitor/Write Profile dialog you can save the values of a set of variables into a text file. You can save the values in points, along polylines, and in case of time-dependent computation the entire file. To save values from a rectangular area or some regions see Export Data (page 258).
Note

In case of a time-dependent computation the same dialog is invoked via Computation > Monitor.

![Monitor/Write Profile dialog, Points tab](image)

**Figure 10.60. Monitor/Write Profile dialog, Points tab**

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Points</td>
<td>Opens the Points tab for saving the values of variables computed in defined points into a text file, see Points (page255 ).</td>
</tr>
<tr>
<td>Polylines</td>
<td>Opens the polylines tab for saving the values of variables computed along defined lines into a text file, see Polylines (page256 ).</td>
</tr>
<tr>
<td>Entire file</td>
<td>Opens the entire file tab for saving the entire file at time intervals during a time-dependent simulation, see Write Entire File (page258 ).</td>
</tr>
<tr>
<td>Save every ... time step</td>
<td>Specifies the interval for the monitoring in number of time steps. It is available only when the dialog is opened via Computation &gt; Monitor. menu.</td>
</tr>
</tbody>
</table>

Tip

The data saved in text files is written in a table format with a fixed separator between columns. The separator could be specified in Preferences dialog, see Data storage tab (page 204).

**Related Procedures**

Monitor/Write Profile (page 108)

**10.7.2.1. Points**

On the Points tab you define points for saving the values of variables in these points into a text file.

A point is defined by its coordinates and the variables for which values are to be saved.
### Item Description

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>r respectively z</td>
<td>Specifies the coordinates of the current point.</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Variables</td>
<td>Opens the variables’ tree selector in order to select the variables for which the values are to be saved.</td>
</tr>
<tr>
<td>moving</td>
<td>If active, the monitor point will be translated with the moving region.</td>
</tr>
<tr>
<td>file name</td>
<td>Specifies the file name of the text file, in which the values are to be saved. All points are saved in the same file!</td>
</tr>
</tbody>
</table>

**Note**
The file is automatically named based on the *.crys* file name adding _p_mon extension.

**Tip**
You might want to change the monitor file name when you save the *.crys* file with different name. This is automatically done if you set adjust monitor file names option in Preferences dialog, see Data storage tab (page 204).

<table>
<thead>
<tr>
<th>Change</th>
<th>Changes the settings of the selected point with the current settings. You can select a point in the list.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete</td>
<td>Deletes the selected point from the list.</td>
</tr>
<tr>
<td>Add</td>
<td>Adds a new point with the current settings to the list.</td>
</tr>
<tr>
<td>Calculated values</td>
<td>Displays the values of all points (coordinates and values of the variables) as they will be saved to the text file after having applied the settings with Apply or with OK.</td>
</tr>
</tbody>
</table>

### Related Procedures

Writing points (page 109)

### 10.7.2.2. Polylines

On the Polylines tab you define polylines for saving the values of variables along these lines into a text file. A polyline can consist of one or more straight lines or one or more se-
lected region lines, depending how it is defined.

![Figure 10.62. Monitor/Write Profile dialog, Polylines tab](image)

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change</td>
<td>Changes the settings of the selected polyline with the current settings. You can select a polyline in the list.</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the selected polyline from the list.</td>
</tr>
<tr>
<td>Add</td>
<td>Adds a new polyline with the current settings to the list.</td>
</tr>
<tr>
<td>No. of steps</td>
<td>Specifies, how many values are to be saved along the polyline.</td>
</tr>
<tr>
<td>moving</td>
<td>If active, the monitor polyline will be translated with the moving region. It can be only activated if it belongs on moving regions.</td>
</tr>
<tr>
<td>Variables tree selector</td>
<td>Opens the variables' tree selector in order to select the variables for which the values are to be saved.</td>
</tr>
<tr>
<td>file name</td>
<td>Specifies the name of the text file, in which the values along this polyline are to be saved. You can save more polylines into the same file. The file is automatically named based on the *cry* file name adding _pl{no}.mon extension, where {no} is the number of polyline.</td>
</tr>
<tr>
<td><strong>Tip</strong></td>
<td>You might want to change the monitor files when you save the *cry* file with different name. This is automatically done if you set adjust monitor file names option in Preferences dialog, see Data storage tab (page 204).</td>
</tr>
<tr>
<td>Change Node</td>
<td>Changes the coordinates of the selected node with the current coordinates, given in \textit{r} respectively \textit{z}. You can select a node in the list.</td>
</tr>
<tr>
<td>Delete Node</td>
<td>Deletes the selected node from the list.</td>
</tr>
<tr>
<td>Add Node</td>
<td>Adds a new node with the current settings to the end of the list.</td>
</tr>
<tr>
<td>X respectively Y</td>
<td>Specifies the coordinates of the current node.</td>
</tr>
</tbody>
</table>

**Related Procedures**
Writing polylines (page 111)

10.7.2.3. Write Entire File

On the Entire file tab you can save all data available in a *.crys file in certain intervals.

![Figure 10.63. Monitor/Write Profile dialog, Entire file tab](image)

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save every (s)</td>
<td>Specifies in which intervals the entire file should be saved.</td>
</tr>
<tr>
<td>starting at (s)</td>
<td>Start time for saving the entire file.</td>
</tr>
</tbody>
</table>

Related Procedures

Write Entire File (page 258)

10.7.3. Export Data

This dialog is opened via Analysis Menu (page 253).

In the Export Data dialog you can specify a rectangular area or select some regions whence the results are saved into text files. A matrix of points is automatically defined inside this area based on a given number of rows and columns.

![Figure 10.64. Export Data dialog, Rectangle selection](image)

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rectangle</td>
<td>Defines a rectangular area where the results are saved.</td>
</tr>
<tr>
<td>Item</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------</td>
<td>-------------</td>
</tr>
<tr>
<td>• r min, z min</td>
<td>sets the bottom-left corner of the rectangle.</td>
</tr>
<tr>
<td>• r max, z max</td>
<td>sets the top-right corner of the rectangle.</td>
</tr>
<tr>
<td>• Show area...</td>
<td>displays the defined area.</td>
</tr>
</tbody>
</table>

**Region(s)**

Defines an area based on selected regions. You have to select the region(s) first.

The area is defined according to **Save** option:

• **All**: selects a rectangular area which encloses all selected regions.
• **Crystal**: selects only the crystal part from selected regions.
• **Melt**: selects only the melt part from selected regions.

In case of **Crystal** or **Melt** option, you can specify a **density factor** which increases the density of rows in the vicinity of the solid-liquid interface.

**No. of rows**

Number of rows of points inside the rectangle.

**columns**

Number of columns of points inside the rectangle.

The variables' tree used to select the variables for which the values are to be saved.

**file name**

Specifies the file name of the text file, in which the values are to be saved. The default file name extension is ".gpro".

**Tip**

The data saved in text files is written in a table format with a fixed separator between columns. The separator could be specified in **Preferences** dialog, see Data storage tab (page 204).

**Related Procedures**

Export Data (page 115)

10.7.4. Write Interface

This function is opened via Analysis Menu (page 253).

With the **Write Interface** option you can save the position of the interface and the gradients at the interface to a file.

**Tip**

The format of the saved file is explained in Files generated during post processing (page267 )

**Related Procedures**

Write Interface (page 116)
Appendix A. Navigational Aids and Key Functions

A.1. Tool Bar Buttons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
<th>Availability</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Open file</td>
<td>All modes</td>
</tr>
<tr>
<td></td>
<td>Save file</td>
<td>All modes</td>
</tr>
<tr>
<td></td>
<td>Exit</td>
<td>All modes</td>
</tr>
<tr>
<td></td>
<td>Zoom out</td>
<td>All modes</td>
</tr>
<tr>
<td></td>
<td>Delete selected objects</td>
<td>Geometry Mode</td>
</tr>
<tr>
<td></td>
<td>Copy selected objects</td>
<td>Geometry Mode</td>
</tr>
<tr>
<td></td>
<td>Move selected objects</td>
<td>Geometry Mode</td>
</tr>
<tr>
<td></td>
<td>Raster Toggle</td>
<td>Geometry Mode</td>
</tr>
<tr>
<td></td>
<td>Block Toggle</td>
<td>Geometry Mode</td>
</tr>
<tr>
<td></td>
<td>Show/hide legend</td>
<td>Materials Mode</td>
</tr>
<tr>
<td></td>
<td>Generate grid</td>
<td>Simulation Mode</td>
</tr>
<tr>
<td></td>
<td>Show/hide grid</td>
<td>Simulation Mode</td>
</tr>
<tr>
<td></td>
<td>Show/hide geometry</td>
<td>Simulation Mode</td>
</tr>
<tr>
<td></td>
<td>Show/hide isolines</td>
<td>Simulation Mode</td>
</tr>
<tr>
<td></td>
<td>Show/hide vector field</td>
<td>Simulation Mode</td>
</tr>
<tr>
<td></td>
<td>Show/hide scalar field</td>
<td>Simulation Mode</td>
</tr>
<tr>
<td></td>
<td>Compute variable</td>
<td>Simulation Mode</td>
</tr>
<tr>
<td></td>
<td>Stop computation</td>
<td>Simulation Mode</td>
</tr>
</tbody>
</table>

A.2. Key Functions and Shortcuts

A.2.1. General keys

<table>
<thead>
<tr>
<th>Key(s)</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>Zooms in gradually.</td>
</tr>
<tr>
<td>-</td>
<td>Zooms out gradually.</td>
</tr>
<tr>
<td>*</td>
<td>Increases the zooming factor.</td>
</tr>
<tr>
<td>/</td>
<td>Decreases the zooming factor.</td>
</tr>
<tr>
<td>&gt;</td>
<td>Increases the arrow length of a vector field.</td>
</tr>
</tbody>
</table>
### Navigational Aids and Key Functions

<table>
<thead>
<tr>
<th>Key(s)</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;</td>
<td>Decreases the arrow length of a vector field.</td>
</tr>
<tr>
<td>Space key</td>
<td>Sets arrow length of a vector field to the normal length.</td>
</tr>
<tr>
<td>Arrow keys</td>
<td>Move the object view left, right, up, down.</td>
</tr>
<tr>
<td>PgUp</td>
<td>Moves the view one page up.</td>
</tr>
<tr>
<td>PgDn</td>
<td>Moves the view one page down.</td>
</tr>
<tr>
<td>5 (Numeric key block)</td>
<td>Zooms out to normal size.</td>
</tr>
<tr>
<td>ALT + O</td>
<td>Opens the Open file dialog.</td>
</tr>
<tr>
<td>ALT + S</td>
<td>Open the Save as file dialog.</td>
</tr>
<tr>
<td>ALT + X</td>
<td>Exits the program.</td>
</tr>
<tr>
<td>ALT + U or ESC</td>
<td>Cancels the last operation (undo, only in Geometry Mode).</td>
</tr>
<tr>
<td>ALT + R</td>
<td>Restores the previous undo operation (redo, only in Geometry Mode).</td>
</tr>
</tbody>
</table>

**A.2.2. Keys for editing material properties**

<table>
<thead>
<tr>
<th>Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left Arrow</td>
<td>Moves the cursor one character to the left.</td>
</tr>
<tr>
<td>Right Arrow</td>
<td>Moves the cursor one character to the right.</td>
</tr>
<tr>
<td>Home</td>
<td>Moves the cursor to the beginning of the line.</td>
</tr>
<tr>
<td>End</td>
<td>Moves the cursor one character to the end of the line.</td>
</tr>
<tr>
<td>Backspace</td>
<td>Deletes the character to the left of the cursor.</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the character to the right of the cursor.</td>
</tr>
<tr>
<td>CTRL + K</td>
<td>Deletes the characters to the end of the line.</td>
</tr>
<tr>
<td>CTRL + X</td>
<td>Deletes the selected text and copies it to the clipboard.</td>
</tr>
<tr>
<td>CTRL + C</td>
<td>Copies the selected text to the clipboard.</td>
</tr>
<tr>
<td>CTRL + V</td>
<td>Pastes the clipboard text into line edit.</td>
</tr>
<tr>
<td>CTRL + Z</td>
<td>Cancels the last operation (undo).</td>
</tr>
<tr>
<td>CTRL + Y</td>
<td>Restores the previous undo operation (redo).</td>
</tr>
<tr>
<td>+, −, *, /</td>
<td>Allowed operators in algebraic operations.</td>
</tr>
</tbody>
</table>
Navigational Aids and Key Functions

<table>
<thead>
<tr>
<th>Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>sin, cos, tan, tanh, exp, log, sqrt, abs</td>
<td>Allowed functions in algebraic operations.</td>
</tr>
<tr>
<td>1e3</td>
<td>is the right notation for $1 \times 10^3$.</td>
</tr>
</tbody>
</table>

A.2.3. Mouse buttons

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
<th>Mode</th>
</tr>
</thead>
<tbody>
<tr>
<td>left mouse button and drag</td>
<td>Zooms in.</td>
<td>All modes</td>
</tr>
<tr>
<td>middle mouse button</td>
<td>Adds a point.</td>
<td>Geometry</td>
</tr>
<tr>
<td>middle mouse button and drag</td>
<td>Adds a line.</td>
<td>Geometry</td>
</tr>
<tr>
<td>middle mouse button + move or copy and drag</td>
<td>Copies or moves selected points and lines if move or copy button is toggled on.</td>
<td>Geometry</td>
</tr>
<tr>
<td>right mouse button</td>
<td>Selects/unselects the closest point or line</td>
<td>Geometry</td>
</tr>
<tr>
<td>right mouse button and drag</td>
<td>Selects points and lines inside a rectangular area.</td>
<td>Geometry</td>
</tr>
<tr>
<td>CTRL left mouse button</td>
<td>Assigns the selected material.</td>
<td>Materials</td>
</tr>
<tr>
<td>left mouse button</td>
<td>Selects one region (and unselects already selected region(s)).</td>
<td>Simulation</td>
</tr>
<tr>
<td>CTRL left mouse button</td>
<td>Selects more than one region.</td>
<td>Simulation</td>
</tr>
<tr>
<td>middle mouse button</td>
<td>Selects one line (and unselect already selected line(s)).</td>
<td>Simulation</td>
</tr>
<tr>
<td>CTRL middle mouse button</td>
<td>Selects more than one line.</td>
<td>Simulation</td>
</tr>
<tr>
<td>middle mouse button and drag</td>
<td>Selects/unselects region lines inside a rectangular area</td>
<td>Simulation</td>
</tr>
<tr>
<td>right mouse button</td>
<td>Defines the first node of a polyline (only used in Monitor/Profile: Polylines dialog)</td>
<td>Simulation</td>
</tr>
<tr>
<td>CTRL right mouse button</td>
<td>Defines the nodes of a polyline (only used in Monitor/Profile: Polylines dialog).</td>
<td>Simulation</td>
</tr>
<tr>
<td>right mouse button and drag</td>
<td>Selects/unselects regions inside a rectangular area</td>
<td>Simulation</td>
</tr>
</tbody>
</table>
## Appendix B. Units and File Information

### B.1. Units of Measurement

#### B.1.1. General units

<table>
<thead>
<tr>
<th>General</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Crystal rotation</td>
<td>Hz</td>
</tr>
<tr>
<td>Current frequency</td>
<td>Hz</td>
</tr>
<tr>
<td>Current intensity</td>
<td>A</td>
</tr>
<tr>
<td>Gas pressure</td>
<td>n/m²</td>
</tr>
<tr>
<td>Gravity</td>
<td>m/s²</td>
</tr>
<tr>
<td>Growth rate</td>
<td>m/s</td>
</tr>
<tr>
<td>Length, Coordinates</td>
<td>m</td>
</tr>
<tr>
<td>Magnetic induction</td>
<td>T</td>
</tr>
<tr>
<td>Power</td>
<td>W</td>
</tr>
<tr>
<td>Time</td>
<td>s</td>
</tr>
<tr>
<td>Travelling wavelength</td>
<td>m</td>
</tr>
</tbody>
</table>

#### B.1.2. Units of variables

<table>
<thead>
<tr>
<th>Variable</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Concentration</td>
<td>1/m³</td>
</tr>
<tr>
<td>Conductivity</td>
<td>W/(m · K)</td>
</tr>
<tr>
<td>Displacement</td>
<td>m</td>
</tr>
<tr>
<td>Heat flux</td>
<td>W/m²</td>
</tr>
<tr>
<td>Inductive heat source</td>
<td>J/m³</td>
</tr>
<tr>
<td>In-phase/out-of-phase potential</td>
<td>V · s/m</td>
</tr>
<tr>
<td>Lorentz forces</td>
<td>N/m³</td>
</tr>
<tr>
<td>Phase shift</td>
<td>rad</td>
</tr>
<tr>
<td>Pressure</td>
<td>N/m²</td>
</tr>
<tr>
<td>RMF lorentz-p</td>
<td>N/m³</td>
</tr>
<tr>
<td>RMF sinus component</td>
<td>V</td>
</tr>
<tr>
<td>Stream function</td>
<td>m²/s</td>
</tr>
<tr>
<td>Stress (all kinds)</td>
<td>N/m²</td>
</tr>
<tr>
<td>Temperature</td>
<td>K</td>
</tr>
<tr>
<td>Variable</td>
<td>Unit</td>
</tr>
<tr>
<td>------------------------</td>
<td>----------</td>
</tr>
<tr>
<td>Temperature gradient</td>
<td>K/m</td>
</tr>
<tr>
<td>Velocity</td>
<td>m/s</td>
</tr>
</tbody>
</table>

### B.1.3. Material properties units

<table>
<thead>
<tr>
<th>Material properties</th>
<th>Units</th>
</tr>
</thead>
<tbody>
<tr>
<td>Conductivity r, z</td>
<td>W/(m · K)</td>
</tr>
<tr>
<td>Critical T</td>
<td>K</td>
</tr>
<tr>
<td>Density</td>
<td>kg/m³</td>
</tr>
<tr>
<td>Diffusion coefficient</td>
<td>m²/s</td>
</tr>
<tr>
<td>Electrical conductivity</td>
<td>S/m</td>
</tr>
<tr>
<td>Emissivity</td>
<td></td>
</tr>
<tr>
<td>Heat capacity</td>
<td>J/(kg · K)</td>
</tr>
<tr>
<td>Latent heat</td>
<td>J/kg</td>
</tr>
<tr>
<td>Magnetic permeability</td>
<td>H/m</td>
</tr>
<tr>
<td>Marangoni coefficient</td>
<td>N/(K · m)</td>
</tr>
<tr>
<td>Melting point</td>
<td>K</td>
</tr>
<tr>
<td>Molar weight</td>
<td>kg/mol</td>
</tr>
<tr>
<td>Mushy zone</td>
<td>K</td>
</tr>
<tr>
<td>Partition coefficient</td>
<td></td>
</tr>
<tr>
<td>Phi</td>
<td>DEG</td>
</tr>
<tr>
<td>Solutal expansion coefficient</td>
<td>1/wt · pct</td>
</tr>
<tr>
<td>Stress coefficients</td>
<td>Pa</td>
</tr>
<tr>
<td>Thermal expansion</td>
<td>1/K</td>
</tr>
<tr>
<td>Viscosity</td>
<td>kg/(m · s)</td>
</tr>
<tr>
<td>Visibility windows</td>
<td>μm</td>
</tr>
<tr>
<td>Volumetric expansion coefficient</td>
<td>1/K</td>
</tr>
</tbody>
</table>

### B.2. Log and Monitoring Files

The following tables explain the structure of files automatically saved by CrysVUn at certain points of time or initiated by the user, e.g. by selecting Write isoline. All output files are ASCII and can be opened with any editing tool.

#### B.2.1. File saved in pseudo stationary temperature calculation
### Units and File Information

#### B.2.2. File saved in time-dependent temperature calculation

<table>
<thead>
<tr>
<th>File extension</th>
<th>Column no.</th>
<th>Content</th>
</tr>
</thead>
<tbody>
<tr>
<td>*.infoT</td>
<td>1</td>
<td>Iteration number</td>
</tr>
<tr>
<td></td>
<td>2</td>
<td>CPU time for calculation</td>
</tr>
<tr>
<td></td>
<td>3</td>
<td>Real time for calculation</td>
</tr>
<tr>
<td></td>
<td>4</td>
<td>Maximum temperature</td>
</tr>
<tr>
<td></td>
<td>5</td>
<td>Temperature value at first control point (No. 0)</td>
</tr>
<tr>
<td></td>
<td>5+n</td>
<td>Temperature value at control points n+1 (n = 0, 1, 2, 3,...)</td>
</tr>
<tr>
<td></td>
<td>Last column</td>
<td>Norm of the temperature residual</td>
</tr>
</tbody>
</table>

#### B.2.3. File saved in stationary convection calculation

<table>
<thead>
<tr>
<th>File extension</th>
<th>Column no.</th>
<th>Content</th>
</tr>
</thead>
<tbody>
<tr>
<td>*.infoV</td>
<td>1</td>
<td>CPU time for calculation</td>
</tr>
<tr>
<td></td>
<td>2</td>
<td>Real time for calculation</td>
</tr>
<tr>
<td></td>
<td>3</td>
<td>Maximum temperature</td>
</tr>
<tr>
<td></td>
<td>4</td>
<td>Maximum velocity</td>
</tr>
<tr>
<td></td>
<td>5</td>
<td>Temperature at first control point (No. 0)</td>
</tr>
<tr>
<td></td>
<td>5+n</td>
<td>Temperature at control points n+1 (n = 0, 1, 2, 3,...)</td>
</tr>
<tr>
<td></td>
<td>5+n+1</td>
<td>Norm of the temperature</td>
</tr>
<tr>
<td></td>
<td>Last column</td>
<td>Norm of the residual of the momentum</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>File extension</th>
<th>Column no.</th>
<th>Content</th>
</tr>
</thead>
<tbody>
<tr>
<td>*.res</td>
<td>1</td>
<td>Total CPU time for calculation</td>
</tr>
<tr>
<td></td>
<td>2</td>
<td>Global Iteration for temperature and convec-</td>
</tr>
<tr>
<td></td>
<td></td>
<td>tion coupled</td>
</tr>
</tbody>
</table>
### File extension | Column no. | Content
---|---|---
| | 3 | Iterations for temperature class
| | 4 | Iterations for convection class (SIMPEL/SIMPLER) per global iteration step
| | 5 | Sum of iterations for convection class for all global iterations
| | 6 | Norm of the residual for the momentum equation
| | 7 | Maximum changes in the velocities u or v
| | 8 | Norm of the residual of the continuity equation
| | 9 | Changes in the pressure
| *.res | 10 | Norm of the residual of the temperature class
| | 11 | Kinetic energy inside the fluid
| | 12 | Factor for starting density variations in density ramp
| | 13 | Movement of the solid-liquid interface
| | 14 | Under relaxation factor for temperature class
| | 15 | Under relaxation factor for momentum equation
| | 16 | Under relaxation factor for continuity equation
| | 17 | Maximum positive u velocity
| | 18 | Maximum negative u velocity
| | 19 | Maximum positive v velocity
| | 20 | Maximum negative v velocity
| | 21 | Maximum positive w velocity
| | 22 | Maximum negative w velocity

### B.2.4. File saved in time-dependent convection calculation

| File extension | Column no. | Content
---|---|---
| *.time | 1 | Simulation time
| | 2 | Number of iterations in time step
| | 3 | Maximum u velocity
| | 4 | Maximum v velocity
| | 5 | Maximum w velocity
B.2.5. Monitoring file

A *.mon file will be generated, if the user sets monitoring points in time-dependent calculations. In the headline you find the name of the file.

The 1st column contains the time value, the 2nd column the r-coordinate of the monitoring point and the 1st line of the 3rd column contains the coordinates of the monitoring point as well as the labels of the variables in the variable group selected. The 2nd line contains the values. These two lines are repeated for every monitoring point defined and every variable selected.

**Note**

Because of the ASCII format of the *.mon file labels and values are not aligned.

For the variable group temperature the output file will be structured like this:

<table>
<thead>
<tr>
<th>File extension</th>
<th>Column no.</th>
<th>Line no.</th>
<th>Content</th>
</tr>
</thead>
<tbody>
<tr>
<td>*.mon</td>
<td>1</td>
<td>1</td>
<td>Label: # time</td>
</tr>
<tr>
<td></td>
<td>1</td>
<td>2</td>
<td>Time value in seconds</td>
</tr>
<tr>
<td></td>
<td>2</td>
<td>1</td>
<td>Label: r-coordinate</td>
</tr>
<tr>
<td></td>
<td>2</td>
<td>2</td>
<td>Value of r-coordinate</td>
</tr>
<tr>
<td></td>
<td>3</td>
<td>1</td>
<td>Label: z-coordinate</td>
</tr>
<tr>
<td></td>
<td>3</td>
<td>2</td>
<td>Value of z-coordinate</td>
</tr>
<tr>
<td></td>
<td>4</td>
<td>1</td>
<td>Label of 1st variable in variable group, e.g. Temperature</td>
</tr>
<tr>
<td></td>
<td>4</td>
<td>2</td>
<td>Value of 1st variable</td>
</tr>
<tr>
<td></td>
<td>4+n</td>
<td>1</td>
<td>Label of variable 1+n, e.g. Radial Gradient</td>
</tr>
<tr>
<td></td>
<td>4+n</td>
<td>2</td>
<td>Value of variable 1+n</td>
</tr>
</tbody>
</table>

B.2.6. Files generated during post processing

Files produced by the menu items in the Analysis menu have the following extensions:

<table>
<thead>
<tr>
<th>Menu item</th>
<th>Extension</th>
</tr>
</thead>
<tbody>
<tr>
<td>Write Isoline</td>
<td>*.iso(1 Isoline)</td>
</tr>
<tr>
<td>Write Profile</td>
<td>Points: *p.mon Polylines: *p10.mon (polyline 0), *p11.mon (polyline 1), *p12.mon (polyline 2) etc.</td>
</tr>
<tr>
<td>Export Data</td>
<td>Selected area: *.gpro</td>
</tr>
<tr>
<td>Write Interface</td>
<td>*-gradients.dat</td>
</tr>
</tbody>
</table>

With the exception of *.iso and *-gradients.dat files, all files have an identical structure:
### Units and File Information

#### For the *-gradients.dat file saved with the Write Interface option the structure is:

<table>
<thead>
<tr>
<th>File extension</th>
<th>Column no.</th>
<th>Content</th>
</tr>
</thead>
<tbody>
<tr>
<td>*-gradients.dat</td>
<td>1</td>
<td>r-coordinate</td>
</tr>
<tr>
<td></td>
<td>2</td>
<td>z-coordinate</td>
</tr>
<tr>
<td></td>
<td>3</td>
<td>radial Gradient</td>
</tr>
<tr>
<td></td>
<td>4</td>
<td>axial Gradient</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Column no.</th>
<th>Content</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Simulation time</td>
</tr>
<tr>
<td>2</td>
<td>r-coordinate</td>
</tr>
<tr>
<td>3</td>
<td>z-coordinate</td>
</tr>
<tr>
<td>4</td>
<td>First variable of variable group</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Column no.</th>
<th>Content</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>r-coordinate</td>
</tr>
<tr>
<td>3</td>
<td>z-coordinate</td>
</tr>
<tr>
<td>4</td>
<td>Variable 1+n of variable group</td>
</tr>
</tbody>
</table>
Appendix C. FAQ - Frequently asked questions

- General problems (page 269)
- Preparation of the furnace model (page 270)
- Performance of the computations (page 271)

C.1. General problems

- What is the meaning of the name CrysVUn? (page 269)
- What kind of support can I get from CGL? (page 269)
- What kind of computer do I need for the computations? (page 269)
- Do you recommend the Windows or the Linux version of CrysVUn? (page 269)
- I am not familiar with numerical techniques. Can you provide me some literature? (page 269)
- My CrysVUn license is expired? How can I extend it? (page 270)
- Is there an ideal way to perform numerical simulations? (page 270)
- How can I learn details on the implemented physical models in CrysVUn? (page 270)
- Why is the Context Sensitive Help not activated in CrysVUn? (page 270)

What is the meaning of the name CrysVUn?

CrysVUn stands for Crystal and Finite-Volume technique on Unstructured meshes. (Although the program can be used in the meantime also for the simulation of alloy solidification processes we have decided to keep the name.)

What kind of support can I get from CGL?

Each CrysVUn license includes a one week training at CGL. This is usually enough to get familiar with all features of the program and to define a basic model of your furnace set-up. Nevertheless, if problems occur you can contact our hotline. Currently, our contact person is: Flaviu.Jurma@iisb.fraunhofer.de. In order to get the best support you have to precisely define your problem. In some cases it might be necessary to send the *.crys file of your furnace model. Of course, all your data will be treated as confidential.

What kind of computer do I need for the computations?

CrysVUn runs on a standard PC. As the simulations require a big amount of computational resources you should use the fastest CPU you can get. The memory is normally not the bottleneck. Please note also, that you may create a huge amount of data. A rather big hard disc drive is therefore recommended as well.

Do you recommend the Windows or the Linux version of CrysVUn?

Both CrysVUn versions are completely identical - the choice is up to you.

I am not familiar with numerical techniques. Can you provide me some literature?

There are many good books on this topic available. Although it is already a rather old
book, beginners should have a look in the book of S.V. Patankar: "Numerical heat transfer and fluid flow", Hemisphere Publishing Corporation, 1980. The book presents in a very descriptive way the principles of a finite-difference/finite-volume discretization, different time-discretization schemes and the sources for numerical instabilities. It is interesting to note, that even today the book is regularly cited in the scientific literature on this topic. Another interesting book is from J.H. Ferziger and M. Peric: "Computational methods for fluid dynamics", Springer, 1999. This book is a bit more mathematical than the previous one. In addition to the previous topics, the reader finds some nice sections on the solution of linear equation systems and the modeling of turbulent flows. Furthermore, every phd-thesis created at the numeric group of CGL usually contains a chapter on numerical issues as well. A lot of valuable information can be found, e.g., in M. Hainke: "Computation of convection and alloy solidification with the software package CrysVUn", Tech. Fac. Erlangen-Nuremberg, 2004.

My CrysVUn license is expired? How can I extend it?
You should either contact the user support of CGL, which is currently Flaviu.Jurma@iisb.fraunhofer.de, or the head of our group Jochen.Friedrich@iisb.fraunhofer.de.

Is there an ideal way to perform numerical simulations?
Unfortunately not. Nevertheless, there are some basic principles which you should consider when performing a numerical simulation. First of all never forget that a lot of complicated numerics is going on in the background. You should stepwise increase the complexity of the model. First make sure that you are able to make a normal forward simulation of the temperature field. Then include one or more control points. In a next step you could start to consider convection as well. In order not to forget any parameter setting, you should always follow the CrysVUn menu structure, which is from left to right (preparation/simulation/analysis) and from the top to the bottom in each menu. When you perform your computations you will soon recognize that you create a lot of files with even more data. We therefore recommend to use the File Info dialogue, where you can add a short description of the performed computation.

How can I learn details on the implemented physical models in CrysVUn?
Some information is already provided in this document. Additional information can be found in phd-thesis or diploma thesis, created at CGL (Bibliography (page277)). The best information on the numerical treatment of the energy equation and the principle of the inverse simulation can be found in M.R.H. Kurz: "Development of CrysVUn++, a software system for numerical modelling and control of industrial crystal growth processes", Tech. Fac. Erlangen-Nuremberg, 1998. Information on the numerical treatment of convection and the binary alloy solidification model can be found in M. Hainke: "Computation of convection and alloy solidification with the software package CrysVUn", Tech. Fac. Erlangen-Nuremberg, 2004.

Why is the Context Sensitive Help not activated in CrysVUn?
The help system is based on the on-line (HTML) version of CrysVUn User Manual. If you get the software by e-mail, the installation kit does not contain the user manual. You have to download it from CGL home page [http://www.cgl-erlangen.com] and install it into CrysVUn Doc subdirectory.
If you have installed the user manual files and the help is still not available, you should check the program configuration, see Activating the Context Sensitive Help (page 8) section.

C.2. Preparation of the furnace model

• How precise do I have to make the CAD drawing? (page271)
• I have problems importing my CAD drawing. What shall I do? (page271)
How precise do I have to make the CAD drawing?
The CAD drawing should contain all elements which are assumed to be relevant for the heat transfer within the furnace. All constructive parts, like screws, should be removed from the drawing. In the case of axi-symmetry, only one half of the geometry is needed. It may be also necessary already in this stage to identify potential gaps inside the furnace, which may have a severe impact on the resulting temperature field.

I have problems importing my CAD drawing. What shall I do?
CrysVUn can import .dxf files, which is a standard format for CAD drawings. You should export your drawing in the oldest possible .dxf format. Under Linux it sometimes occurs that a .dxf file can not be read by CrysVUn. In this case, you should open the drawing with another CAD program, e.g., "qcad" and just save the file again. Usually, this fixes the problem.

How precise do I have to know the material properties?
If the material properties show a strong temperature dependence, it is mandatory that this behavior is defined for the corresponding property as well. On the other hand, you should never forget that you are just creating a model of reality - it will always be just an approximation. Please consider also, that other effects like thermal contact resistances may have a strong impact on the temperature field. Usually, this effect may be approximated by slightly changed values of the thermal conductivity.

Where can I get accurate data for the material properties?
A lot of data is provided in the Internet, especially on the web sites of the material suppliers. CGL has also quite a large material data base. On the other hand, some properties like the emissivity are not only material dependent, but strongly affected by the surface itself. In addition, these properties may also change during the operation of the furnace due to aging.

C.3. Performance of the computations

• Why shall I use the interpolation routine? (page272)
• How can I document my simulations? (page272)
• How can I create an optimum grid? (page272)
• When shall I use the Initial Values dialogue? (page273)
• My simulation is not converging. What shall I do? (page273)
• I get the message "Error in function cvTMaterial::Phase(). Inconsistent Material: xxx at T = xxx". (page273)
• What is the ideal strategy to make convection computations? (page273)
• I have problems to reach the control temperatures. What is the best solution strategy? (page273)
• What is the correct abortion criterion for a temperature computation? (page274)
• Why shall I change the values of the underrelaxation factors? (page274)
• Which kind of matrix solver shall I use for my computations? (page274)
• How can I avoid errors during the set-up of the model and the numerical parameters? (page 274)
• How can I check the accuracy of the view factor computation? (page 274)
• Shall I use the constrained or the unconstrained solver? (page 274)
• What is the meaning of a sensitivity analysis? (page 274)
• What kind of data can I export with CrysVUn? (page 274)
• Which value should I choose for the regularization parameter? (page 274)
• Is it necessary to specify an underrelaxation factor for the pressure computation? (page 275)
• What is the meaning of the "do steps at" parameters in the "Ramps" dialogue? (page ?)
• What do I have to consider if I want to specify inflow boundary conditions? (page 275)
• How can I set in- and outflow conditions for convection computations? (page 275)
• How can I activate the turbulence model? (page 275)
• How can I specify a real vacuum region? (page 275)
• How can I identify the current values as used in the material property ramp? (page 275)

Why shall I use the interpolation routine?

The routine can be used to transfer results from one grid to another. This is very helpful in conjunction with fluid flow computations. You should start the computation on a rather coarse mesh. After you have received a certain level of accuracy, you should stop the computation and interpolate the results on the finer grid. Usually, with this strategy you will obtain a converged computation much faster than by starting from the fine mesh. Please take care, that the view factors still have to be computed for the destination grid. Don’t forget that the interpolation on the finer grid is not sufficient to reduce the numerical error! Some iterations on the finer grid are needed in any case.

How can I document my simulations?

The best way is to use the File Info dialogue, where you can add comments to a crys file, e.g., "Changed the relaxation factor to x.x" or "Control point temperature changed to x.x". Some people also try to identify the content of the file with a proper file name (which usually leads to rather large names after some time).

How can I create an optimum grid?

A good way is to start with the default values for the grid parameters. You should then select the regions which are of special interest (like the crystal or the crucible) or where you expect strong variations of the physical quantities. Here, you should stepwise improve the grid parameters. Probably, it is not necessary to recompute the whole grid, but only in the selected regions. Don’t refine the parameters to strong, as this may result in a rather fine mesh, which will take some time to compute. Once you have defined the optimum parameters, you should once more compute the grid in the whole furnace. It is interesting to note, that in CrysVUn for the temperature and convection computation usually the dependence of the results on the mesh is not so strong, due to the applied approximation schemes. For temperature computations the most important criterion is very often the accuracy of the resulting view factors, for convection computations a refined mesh may be needed due to stability issues.
When shall I use the Initial Values dialogue?

The basic intention is to specify the start values for time-dependent calculations. Nevertheless, you may also use this feature in the case of stationary calculations. In some cases, the numerical solution procedure is much more stable, if you start from a higher temperature value (e.g., 1500K) instead with the default value of 300K. In addition, in the case of a diverged computation you can reset the values without recomputing the grid and the view factors.

My simulation is not converging. What shall I do?

For temperature calculations you should first of all try to identify if it is a problem with the controller or if the convergence problems exits already in the case of a simple forward simulation. The first thing is usually to reduce slightly the underrelaxation factor for the temperature computation (Setting Numerical parameters (page 76)). If this does not help, several other causes should be checked. You may have to refine the grid in some regions, for example near the phase interface (esp. for higher growth velocities). In the case of an inverse computation, you could reduce the value for the controller relaxation factor as well (Setting parameters for inverse simulation (page 81)). Maybe you should also slightly increase the tolerance of the control points (Control Points for Inverse Simulation (page 64)). You should also check the upper and lower limits of the heater powers (Heaters (page 61)). If you have chosen the unconstrained solver this could cause problems. For convection computation things are more complicated, cf. What is the ideal strategy to make convection computations? (page 273)

I get the message "Error in function cvTMaterial::Phase(). Inconsistent Material: xxx at T = xxx".

This message occurs if the temperature inside a region is higher than the value specified in the materials dialog (Materials dialog window (page 26)). The default value is 10000K. The original idea was to provide information for the case that the temperature is higher than the material can support. In the case of the default value, the message is usually the first identification that your computation is diverging.

What is the ideal strategy to make convection computations?

This is a complicated question, which can not be answered in a general sense. Nevertheless, there are some hints. First of all it is important to recognize, that a convection calculation is usually much more effort than a simple temperature computation. You have to solve more variables, the velocity is a vector instead of a simple scalar value and the value for the pressure is only indirectly specified via the constraint of the continuity equation. In addition, the system of equations you are dealing with is much more unstable than in the case of a simple temperature equation. To get control over everything you have mainly two items to consider: the underrelaxation factor for the momentum equation (Setting Convection parameters (page 84)) and the usage of material property ramps (Setting ramp parameters (page 86)). A typical value for the underrelaxation factor in the case of a stationary computation is 0.1 or 0.2. The idea of the application of ramps is to start the computation with slightly increased values for the viscosity (e.g., increased by a factor of 40 (VGF) or even 1000 (Si-Cz)) and decreased values for the heat capacity (e.g., 0.1). The effect of this modifications is that the fluid is much more stabilized and the temperature field is not so strongly coupled with the flow field. The idea is to adjust these factors continuously to 1 during the computations. To do so, you just have to specify the values for the residuum of the energy equation and the momentum equation. The factor for the viscosity has to be decreased (e.g., factor 0.8) the value for the specific heat capacity has to be increased (e.g., factor 1.2). Normally you should not use a density ramp for buoyancy driven flows. The abortion criteria for a convection computation should not be too strict: 0.001 for the momentum equation and 1.e-6 for the energy equation are usually rather reasonable values.

I have problems to reach the control temperatures. What is the best solution strategy?

This is really dependent from case to case. The important thing is that you develop a feel-
ing for the problem. Play a bit with the set-up, set a few heaters to fixed power and change the tolerance for the control points (Control Points for Inverse Simulation (page 64)). Maybe you just have to use smaller values for the underrelaxation factor of the temperature controller (Setting parameters for inverse simulation (page 81)).

What is the correct abortion criterion for a temperature computation?
By default the norm or the residuum of the temperature equation is required to be smaller than 1.e-12, which is a rather strict criterion - usually 1.e-10 might do it as well. If you are performing parameter studies, you may even use higher values, like 1.e-8. The best way is to check also the value for the temperature at certain locations inside the furnace.

Why shall I change the values of the underrelaxation factors?
Usually, smaller values for the underrelaxation factors help to stabilize the solution procedure. Nevertheless, this will also slow down the solution procedure. Try to find a compromise.

Which kind of matrix solver shall I use for my computations?
You will probably either work with the iterative solver STABBiCG or the direct solver GSSV. The others are nearly never used, even by the developers at CGL. Usually, iterative solvers are said to be a bit faster than the direct ones.

How can I avoid errors during the set-up of the model and the numerical parameters?
One important thing is to follow the CrysVUn menu structure. From left to right (preparation/computation/analysis) and from the top to the bottom in each pull down menu.

How can I check the accuracy of the view factor computation?
You can either have a look at the Show Solver Information dialogue (Show Solver Information (page 248)) or perform the so called view factor test. The latter works as follows. Remove all heaters from your furnace model and set the boundaries to some arbitrary high value, e.g., 1500K. Start a computation and check the temperature field inside the furnace. If you have a strong deviation from the expected value of 1500K, refine the mesh at the corresponding positions.

Shall I use the constrained or the unconstrained solver?
The constrained solver is able to handle the limits for the heater power, which is a good reason to choose this solver. The unconstrained solver was the first solver implemented in CrysVUn and is for some cases more stable than the constrained one.

What is the meaning of a sensitivity analysis?
The idea is to create a furnace model and to investigate at the very beginning the influence of the material properties on the resulting temperature field. As an example you may vary each property by +/-30% and investigate it's impact on the temperature field. The big advantage of this strategy is that you get a pretty good understanding of the furnace model from the very beginning of your simulations. Although it may cost some time at first, you will surely save much more work time in the end.

What kind of data can I export with CrysVUn?
CrysVUn allows to export data in ascii format at points, lines or complete areas.

Which value should I choose for the regularization parameter?
The regularization parameter determines the importance of the heater power during an inverse simulation (Setting parameters for inverse simulation (page 81)). A good value to start with is 1.e-6. Decreasing this value means reducing the importance of the heater power, by increasing this value the solution with the minimum heater power gains more and more importance. In the case of the UNCONSTRAINED solver and an unequal num-
ber of heaters and control points the value of the regularization parameter has to be non-zero. The CONSTRAINED solver does his job in this case also with a zero value for the regularization parameter.

Is it necessary to specify an underrelaxation factor for the pressure computation?

In CrysVUn we use the SIMPLER algorithm to compute the pressure. Here, the pressure is computed directly instead of a pressure correction as in the case of the SIMPLE algorithm. For SIMPLER no underrelaxation factor for the pressure computation is required.

What is the meaning of the "do steps at" parameters in the "Ramps" dialogue?

Once the norms of the residuum of the momentum and the temperature equation have fallen below the specified values, the next step in the ramp will be made. Dependent on the user definition the current values of viscosity and/or heat capacity will be multiplied by the specified factors. A good strategy is normally to start with slightly increased values for the viscosity (e.g. factor 100) and slightly decreased values for the specific heat capacity (e.g. factor 0.01).

What do I have to consider if I want to specify inflow boundary conditions?

In CrysVUn the normal vector of the outer boundaries is pointing outwards of the furnace geometry. This means if a user wants to specify an inflow condition (either heat flux or a velocity profile) the values have to be multiplied by the factor -1. ATTENTION: The specification of flux conditions at interior boundary lines is currently not supported by CrysVUn.

How can I set in- and outflow conditions for convection computations?

All necessary parameters are specified in the boundary dialog (Boundaries (page 221)). At the inflow boundary the user has to specify a velocity profile for the variable UVW, which may look for a quadratic inflow profile something like: -vmax*(1-l*l) (the negative sign comes from the convention, that the outer normal is pointing outwards from the region.). At the outflow boundary the UVW variable has to be set to Outflow. In addition it is recommended to set the pressure to some fix value (Dirichlet), e.g. P=101325Pa. In- and outflow conditions are available both for incompressible and compressible flows. For the computation of compressible flow, it is sometimes advisable to specify the density-temperature relation directly, instead of using the "ideal gas" option. To do so, just specify the density as a function of T according to the well-known relation: density=(MolarWeight*Pressure)/(8.31451*T). This is probably the best way for laminar flow computations. For the computation you should as usual apply the "Ramps" utility of CrysVUn. If it turns out, that the flow is turbulent the "ideal gas" feature has to be activated.

How can I activate the turbulence model?

The activation of the turbulence model is simple. Just start with a normal laminar flow computation. Once you have obtained a reasonable start solution (you may use the ramp feature and use the laminar model as long as possible), stop the computation and activate the turbulence model in the Physical Phenomena dialogue (Physical Phenomena (page 56)). Now, continue the fluid flow computation. No additional boundary conditions have to be specified. For additional questions on the utilization of the turbulence model just contact: Jakob.Fainberg@iisb.fraunhofer.de

How can I specify a real vacuum region?

For regions which contain a material with the name "vacuum" no grid will be created. In this case only radiative heat transfer will be considered for the temperature field computation.

How can I identify the current values as used in the material property ramp?

One way is to have a look at the terminal output. Once the momentum equations are
solved, you get an output reading like this: 1 2 3 4 2.9 0.0039 1.4e-19 1 2.2e-05 0 1 0.1 40
0.056 ----- solved uv-p. The values nearly at the end “1 0.1 40” are the current multiplication factors for density (never use this), heat capacity and viscosity. Another way would be to re-open the ramp dialog in the GUI. In this case the current values are refreshed in the GUI.
## Appendix D. Bibliography

<table>
<thead>
<tr>
<th>Author(s)</th>
<th>Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>Birkmann, B./ Rasp, M./ Stenzenberger, J. / Mueller, G.</td>
<td>Growth of 3&quot; and 4&quot; gallium arsenide crystals by the vertical gradient freeze (VGF) method; Journal of Crystal Growth, Volume 211, Issue 1, 2000, Pages 157-162</td>
</tr>
<tr>
<td>Derby, J. / Daoutidis, P. / Kwon, Y. / Pandy, A. / Sonda, P. / Vartak, B. / Yeckel, A. / Hainke, M. / Mueller, G.</td>
<td>High performance computing, multi scale models for crystal growth systems; AHPCRC, Preprint 2001-017</td>
</tr>
<tr>
<td>Fischer, B.</td>
<td>Modellierung zeitabhaengiger Magnetfelder in Kristallzuechtungsanordnungen PhD thesis Universitaet Erlangen Nuernberg, 2001</td>
</tr>
<tr>
<td>Frank, Ch. / Jacob, K. / Neubert, M / Rudolph, P. / Fainberg, J.</td>
<td>Temperature field simulation and correlation to the structural quality of semi-insulating GaAs crystals</td>
</tr>
</tbody>
</table>

277
<table>
<thead>
<tr>
<th>Author(s)</th>
<th>Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mueller, G.</td>
<td>grown by the vapour pressure controlled Czochralski method (VCz); Journal of Crystal Growth 213, (2000) 10-18</td>
</tr>
<tr>
<td>Grant, I. R. / Sahr, U.</td>
<td>Growth of InP and GaAs Substrate Crystals by the Vertical Gradient Freeze Method; Conference Proceedings, 14th International Conference on Indium Phosphide and Related Materials (2002) 413-415</td>
</tr>
<tr>
<td>Kurz, M. / Fainberg, J. / Friedrich.</td>
<td>Equipment and process modelling of industrial crystal...</td>
</tr>
<tr>
<td>Author(s)</td>
<td>Title</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>J. / Mueller, G.</td>
<td>growth using the finite volume codes CrysVUN++ and STHAMAS; American Society of Mechanical Engineers, Pressure Vessels and Piping Division (Publication) PVP, Volume 397 (1999) 275-281</td>
</tr>
<tr>
<td>Metzger, M.</td>
<td>Optimal Control of Crystal Growth; Journal of Crystal Growth, Volume 230, Issues 1-2, August 2001, Pages 210-216</td>
</tr>
<tr>
<td>Molchanov, A. / Hilburger, U. / Friedrich, J. / Finkbeiner, M. / Wehrhan, G. / Mueller, G.</td>
<td>Experimental verification of the numerical model for a CaF2 crystal growth process; Crystal Research and Technology 37 (2002), 77-82</td>
</tr>
<tr>
<td>Mueller, G. / Friedrich, J.</td>
<td>Juwelen fuer Innovation; Schott Info 100 (2002) 12-14</td>
</tr>
<tr>
<td>Mueller, G. / Berwian, P. / Buhrig</td>
<td>GaAs Substrate for high power laser diodes;</td>
</tr>
</tbody>
</table>

279
<table>
<thead>
<tr>
<th>Author(s)</th>
<th>Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>Voigt, A. / Metzger, M.</td>
<td>Numerical Simulation and Control of Industrial Crystal Growth by the Czochralski and Vertical Gradient Freeze Method; caesar preprint 2000-2, (2000)</td>
</tr>
</tbody>
</table>
Index

A
Abortion, 84
Adapt grid, 99
Align left, 22
Align origin, 23
Alloy solidification, 89, 187
Analysis, 107
  Export Data, 115
  Write Entire File, 114
  Write Interface, 116
  Write Isoline, 107
  Write Points, 109
  Write Polygons, 111
  Write Profile, 108, 146
Assigning Materials, 37
Assigning materials, 138

B
Batch Mode, 193
Bibliography, 277
Blocks, 20
Boundaries, 58, 123, 149, 158

C
CAD file, 23
Cancelling selection
  Geometry Mode, 14
  Simulation Mode, 48
Characteristic Numbers, 44, 216
Computation, 70
  Alloy parameters, 89
  Convection parameters, 84
  Numerical parameters, 76
  Process parameters, 71
  Solver Information, 96
  Time Model, 70
  View factors, 100
Concentration, 182
Connecting points, 11
Control Points, 64, 65, 142
Convexion, 84
  Abortion, 84
  Boundaries, 158
  Characteristic Numbers, 216
  Computing, 156
  Materials properties, 156
  Multiphase, 85
  Ramps, 86
  Solvers, 87
  Time-dependent, 162
  Turbulence, 88
Convection parameters, 159
Copy, 19
Copy-to, 18

D
Dangling points, 12
Database, 136, 214
Deleting elements, 19
Dialog windows, 7
Dialogs, 197
Drag and drop, 18, 132
Drawing lines, 13
DXF file, 23

E
Export Data, 115

F
File, 197, 209
Flip, 22
Forward, 80

G
General Process parameters, 71
Generating grid, 99
Geometry, 10
  Blocks, 20
  CAD file, 23
  Connecting points, 11
  Copy, 19
  Copy-to, 18
  Deleting elements, 19
  Drag and drop, 18, 132
  Drawing lines, 13
  Drawing points, 11
  Grid alignment, 20
  Move-to, 17, 132
  Raster, 14
  Rotate, 21
  Scrolling, 11
  Selecting elements, 13, 130
  Splitting lines, 16
  Tolerance, 14
Grashof Number, 44
Grid
  Generating, 99, 120
  Properties, 53, 157
  Grid alignment, 20
  Growth rate, 71, 125, 144, 231

H
Hartmann Number, 44
Heaters, 61, 124
  Defining, 61, 141
  Deleting, 64
  Inductive Heating, 174
  Inverse Simulation, 141
  Properties, 64
  Time-dependent Simulation, 150

I
Inductive Heating, 172
  Controlled power, 177
  Fixed power, 174
  Heater, 173
Moving Regions, 66
  Physical Phenomena, 56
    Symmetry, 25
Show, 105
Show Solver Information, 96
Solutal Peclet Number, 44
Solvers, 76, 87
Species parameters, 82
Splitting lines, 16, 133
Stationary Magnetic Field, 179
Stress, 170
Supersaturation, 186
Symmetry, 25

T
  Temperature, 118
  Thermal analysis, 118
  Thermal Peclet Number, 44
  Thermoelastic stress, 170
  Time Model, 70, 148
  Translation heat flux, 231
  Travelling magnetic field
    Continuous model, 73
    Discrete model, 74
  Turbulence, 88
  Tutorial
    Alloy model, 187
    Batch Mode, 193
    Concentration, 182
    Convection, 156
    Handling Materials, 135
    Inductive Heating, 172
    Inverse Simulation, 140
    Modifying Cartridge, 130
    Moving Regions, 153
    Rotating Magnetic Field, 178
    Stationary Magnetic Field, 179
    Supersaturation, 186
    Thermal analysis, 118
    Thermoelastic stress, 170
    Time-dependent Simulation, 147
    Turbulent Gas Convection, 163

V
  View factors, 100
  Visualization, 105, 144
  von Mises stress, 170

W
  Write
    Entire File, 114, 258
    Isoline, 107
    Monitor, 254
    Points, 109, 255
    Polylines, 111, 256
    Profile, 254
  Write Interface, 116
  Write Isoline, 107, 129, 146
  Write Profile, 108, 146, 151