Importing a CAD File (dxf-Format)

If a CAD program was used for furnace design, the geometry in CrysMAS can be build on the CAD file, provided it has a standard *.dxf format. But in any case you have to fix the *.dxf files to meet CrysMAS 's requirements. Maybe you notice that some of the lines in the *.dxf file are intersected and some contours not closed.

You may be confronted with the following problems when importing a *.dxf file:

CrysMAS is prepared to handle these problems. The following sequence exemplifies the most common procedure:

  1. Close your current file by selecting File > Close.

  2. Change to Geometry Mode by selecting Mode > Geometry.

  3. Select File > Import.

    The Import File dialog opens:

    Import File dialog 

    Figure 7. Import File dialog

  4. Select the desired *.dxf file ( Furnace.dxf in the example above), and click on Open.

  5. If the drawing contains arcs, CrysMAS converts these arcs into lines before processing the file. In the Arc dialog, you are asked to specify the length of the lines (arc unit length) which the arcs shall be segmented into.

    Dialog for specifying the arc unit length 

    Figure 8. Dialog for specifying the arc unit length

    Type the arc unit length into the input field of the Arc dialog, in the example: 14.

    After loading the *.dxf file the lines of converted arcs are automatically selected (displayed in red).

  6. Because CAD designers tend to use millimeters, convert the length unit from millimeter to meter:

    Select Edit > scale and set the scale factor to 0.001.

  7. Click on the Toggle Raster button   to activate the Raster.

  8. Set the tolerance to the minimum length of the CAD drawing. For instance, if the minimum length is 5 mm, set the tolerance to 0.005.

  9. Select Edit > Select All to be sure not to miss any point or line.

  10. Select Edit > mesh Alignment to align the drawing to the raster.

  11. Set the tolerance to a higher value, e.g. 0.01, because you can continue on a coarser raster.

  12. Draw a vertical line from the top to the bottom of the object to serve as symmetry axis.

  13. Select all points and lines on the left side using the right mouse button.

  14. Click on the Delete button in the tool bar.

    or

    Select Edit > Delete.

    The left side of the drawing vanishes. If more lines were deleted than expected, select Edit > Undo or draw them again.

  15. Select Edit > Align Left to set the symmetry axis to x = 0.

  16. Select File > Save to save the geometry information in the *.pcs format.

  17. Now you can verify the geometry by switching to Materials Mode.

    Select Mode > Materials.

    If CrysMAS fails to compute the regions because of dangling points, you will get a message and you need to take care of them, see Drawing and connecting points, before you are allowed to switch to Materials Mode.

Note

If CrysMAS cannot open a *.dxf file, try to save the file in AutoCAD standard R13. For loading and saving your file, you can also use a Linux software, such as qcad.